summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2010-03-14 20:56:11 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2010-03-14 20:56:11 +0000
commitd40bf9f48449de4e1bcb1688bea8720503dd2d9e (patch)
treecd4b035eecf645935ef8ccb8bcfd5b62e8867557 /x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild
parentAdd fixes for python/tcl bindings and python.eclass fixes by Thomas Beierlein (diff)
downloadhistorical-d40bf9f48449de4e1bcb1688bea8720503dd2d9e.tar.gz
historical-d40bf9f48449de4e1bcb1688bea8720503dd2d9e.tar.bz2
historical-d40bf9f48449de4e1bcb1688bea8720503dd2d9e.zip
Little workaround for broken expectk binary, see bug #308713.
Package-Manager: portage-2.1.7.17/cvs/Linux i686
Diffstat (limited to 'x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild')
-rw-r--r--x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild b/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..2a9b5cf5fc5c
--- /dev/null
+++ b/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild,v 1.1 2010/03/14 20:56:09 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="Control a remote computer running VNC from X"
+HOMEPAGE="http://fredrik.hubbe.net/x2vnc.html"
+SRC_URI="http://fredrik.hubbe.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="tk"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXext
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-proto/scrnsaverproto
+ x11-proto/xproto
+ x11-proto/xineramaproto
+ tk? ( dev-tcltk/expect )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/contrib"
+ epatch "${FILESDIR}/expectk.patch"
+}
+
+src_install() {
+ dodir /usr/share /usr/bin
+ make DESTDIR="${D}" install || die
+ use tk && dobin contrib/tkx2vnc
+ dodoc ChangeLog README
+}