summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-10-08 08:34:49 +0000
committerAlex Alexander <wired@gentoo.org>2010-10-08 08:34:49 +0000
commit74c4ffe8f9e748fe923d96a44333d5ff1baef729 (patch)
tree6fa214a813b687234f7d054acdb779f4b328a67f /x11-misc/qterm/qterm-0.5.11.ebuild
parentMarked ~mips for bug #233554 (diff)
downloadhistorical-74c4ffe8f9e748fe923d96a44333d5ff1baef729.tar.gz
historical-74c4ffe8f9e748fe923d96a44333d5ff1baef729.tar.bz2
historical-74c4ffe8f9e748fe923d96a44333d5ff1baef729.zip
version bump, fixes bug #338833
Package-Manager: portage-2.2_rc89/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/qterm/qterm-0.5.11.ebuild')
-rw-r--r--x11-misc/qterm/qterm-0.5.11.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/qterm/qterm-0.5.11.ebuild b/x11-misc/qterm/qterm-0.5.11.ebuild
new file mode 100644
index 000000000000..f3b2fcdb4378
--- /dev/null
+++ b/x11-misc/qterm/qterm-0.5.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qterm/qterm-0.5.11.ebuild,v 1.1 2010/10/08 08:34:49 wired Exp $
+
+EAPI="2"
+inherit cmake-utils eutils
+
+DESCRIPTION="A BBS client for Linux"
+HOMEPAGE="http://qterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qterm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/qt-gui-4.5:4[qt3support]
+ dev-libs/openssl"
+
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.7"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${PN}"-0.5.11-gentoo.patch
+}
+
+src_install() {
+ cmake-utils_src_install
+ mv "${D}"/usr/bin/qterm "${D}"/usr/bin/QTerm || die
+ dodoc README TODO
+}
+
+pkg_postinst() {
+ einfo
+ elog "Since 0.4.0-r1, /usr/bin/qterm has been renamed to /usr/bin/QTerm."
+ elog "Please see bug #176533 for more information."
+ einfo
+}