summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-07-08 13:49:19 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-07-08 13:49:19 +0000
commit7d083ae18829ae6f8a906955a84fcde2a4408aaf (patch)
tree306b18b4661d9e1f1c557f943f94f89dab704eb4 /x11-misc/icecc/icecc-2.4.ebuild
parentVersion bump (diff)
downloadhistorical-7d083ae18829ae6f8a906955a84fcde2a4408aaf.tar.gz
historical-7d083ae18829ae6f8a906955a84fcde2a4408aaf.tar.bz2
historical-7d083ae18829ae6f8a906955a84fcde2a4408aaf.zip
Version bump
Diffstat (limited to 'x11-misc/icecc/icecc-2.4.ebuild')
-rw-r--r--x11-misc/icecc/icecc-2.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/icecc/icecc-2.4.ebuild b/x11-misc/icecc/icecc-2.4.ebuild
new file mode 100644
index 000000000000..3dcc32ebfa30
--- /dev/null
+++ b/x11-misc/icecc/icecc-2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icecc/icecc-2.4.ebuild,v 1.1 2003/07/08 13:47:54 phosphan Exp $
+
+DESCRIPTION="IceWM Control Center (only main program, see icewm-tools for the rest)"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://icecc.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/qt-3.0.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}.patch || die "patch failed"
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ rm -rf ${D}/usr/doc
+ dohtml ${PN}/docs/en/*.{html,sgml}
+ dodoc AUTHORS ChangeLog README TODO
+ dodir /usr/share/${PN}/themes
+ cp -a theme/* ${D}/usr/share/${PN}/themes/
+ chmod go-w ${D}/usr/share/${PN}/themes/
+}
+
+pkg_postinst() {
+ einfo "emerge icewm-tools for the control center helper tools"
+}