summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-05-30 13:06:50 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-05-30 13:06:50 +0000
commita252d6fc309c38ab23e0ebe8f91aa00d2ed127c7 (patch)
treeff66518db3a6d70cd9ea12b8a5527ccb760411e7 /x11-libs
parentVersion bump, for testing (is masked) (diff)
downloadhistorical-a252d6fc309c38ab23e0ebe8f91aa00d2ed127c7.tar.gz
historical-a252d6fc309c38ab23e0ebe8f91aa00d2ed127c7.tar.bz2
historical-a252d6fc309c38ab23e0ebe8f91aa00d2ed127c7.zip
Version bump, for testing (is masked)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/Manifest4
-rw-r--r--x11-libs/qt/files/digest-qt-3.2.0_beta11
-rw-r--r--x11-libs/qt/qt-3.2.0_beta1.ebuild178
3 files changed, 181 insertions, 2 deletions
diff --git a/x11-libs/qt/Manifest b/x11-libs/qt/Manifest
index bfe5d76b9610..d700f5d741aa 100644
--- a/x11-libs/qt/Manifest
+++ b/x11-libs/qt/Manifest
@@ -3,8 +3,8 @@ MD5 63f1df1aa351dc17abe7d0321b70844a qt-2.3.2-r1.ebuild 2309
MD5 7574a34ccd181870ea18bf3145310e37 qt-3.0.5-r2.ebuild 3975
MD5 3460c684ba5ed6273d81f6c520e204b7 qt-3.1.0-r3.ebuild 4840
MD5 66b942151418494936c3b73e01e37d68 qt-3.1.1-r2.ebuild 4659
-MD5 59247151154e9eaf8b0da795c5951b2e ChangeLog 11490
-MD5 abb6140251f92f7e06371b350b1b97b2 qt-3.2.0_beta1.ebuild 4486
+MD5 2e1a2a2a1b2e2d32a8230d3f101e9b17 ChangeLog 11490
+MD5 7d57c6970431541c36f2b5204ef553c4 qt-3.2.0_beta1.ebuild 4489
MD5 2d5b68b38185a30a28ffb2b652258cb8 files/45qt3 83
MD5 7a287bc7609ad2420f70af6d4c58302f files/50qt2 63
MD5 c6dc1b6fadcb4897d4c7b0a768c2d196 files/qt-3.1.2-r3-qsocket.diff 447
diff --git a/x11-libs/qt/files/digest-qt-3.2.0_beta1 b/x11-libs/qt/files/digest-qt-3.2.0_beta1
new file mode 100644
index 000000000000..a8b60fe65abd
--- /dev/null
+++ b/x11-libs/qt/files/digest-qt-3.2.0_beta1
@@ -0,0 +1 @@
+MD5 508034be1018a30326288f2c096fcd9b qt-x11-free-3.2.0b1.tar.bz2 13762095
diff --git a/x11-libs/qt/qt-3.2.0_beta1.ebuild b/x11-libs/qt/qt-3.2.0_beta1.ebuild
new file mode 100644
index 000000000000..c25cfa791ea0
--- /dev/null
+++ b/x11-libs/qt/qt-3.2.0_beta1.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.2.0_beta1.ebuild,v 1.1 2003/05/30 13:06:35 caleb Exp $
+
+inherit eutils
+
+IUSE="cups nas postgres opengl mysql odbc gif"
+
+MY_P="qt-x11-free-3.2.0b1"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="QT version ${PV}"
+SLOT="3"
+LICENSE="QPL-1.0"
+
+KEYWORDS="~x86"
+
+SRC_URI="ftp://ftp.trolltech.com/qt/source/${MY_P}.tar.bz2"
+
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ media-libs/lcms
+ media-libs/jpeg
+ >=media-libs/libmng-1.0.0
+ >=media-libs/freetype-2
+ virtual/xft
+ nas? ( >=media-libs/nas-1.4.1 )
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ mysql? ( >=dev-db/mysql-3.2.10 )
+ opengl? ( virtual/opengl virtual/glu )
+ postgres? ( >=dev-db/postgresql-7.2 )"
+
+RDEPEND="$DEPEND"
+ #doc? ( ~app-doc/qt-docs- )"
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+
+src_unpack() {
+
+ export QTDIR=${S}
+
+ unpack ${A}
+
+ cd ${S}
+
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+
+ cd mkspecs/linux-g++
+ # use env's $CC, $CXX
+ if [ -n "$CXX" ]; then
+ einfo 'Using environment definition of $CXX'
+ cp qmake.conf qmake.conf.orig
+ sed -e "s:= g++:= ${CXX}:" qmake.conf.orig > qmake.conf
+ fi
+ if [ -n "$CC" ]; then
+ einfo 'Using environment definition of $CC'
+ cp qmake.conf qmake.conf.orig
+ sed -e "s:= gcc:= ${CC}:" qmake.conf.orig > qmake.conf
+ fi
+
+ # hppa and alpha people, please review the following
+
+ # hppa need some additional flags
+ if [ "${ARCH}" = "hppa" ]; then
+ echo "QMAKE_CFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_CXXFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_LFLAGS += -ffunction-sections -Wl,--stub-group-size=25000" >> qmake.conf
+ fi
+
+ # on alpha we need to compile everything with -fPIC
+ if [ ${ARCH} == "alpha" ]; then
+ cp qmake.conf qmake.conf.orig
+ sed -e "s:= -O2:= -O2 -fPIC:" qmake.conf.orig > qmake.conf
+ cat >> ${S}/tools/designer/editor/editor.pro <<_EOF_
+QMAKE_CFLAGS += -fPIC
+QMAKE_CXXFLAGS += -fPIC
+_EOF_
+ fi
+
+
+}
+
+src_compile() {
+
+ # fix #11144; qt wants to create lock files etc. in that directory
+ [ -d "$QTBASE/etc/settings" ] && addwrite "$QTBASE/etc/settings"
+
+ export QTDIR=${S}
+
+ export LDFLAGS="-ldl"
+
+ use cups || myconf="${myconf} -no-cups"
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/server"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ use opengl && myconf="${myconf} -enable-module=opengl" || myconf="${myconf} -disable-opengl"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+ export YACC='byacc -d'
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg -verbose \
+ -qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
+ -system-libpng -ldl -lpthread -xft -platform linux-g++ -xplatform \
+ linux-g++ -xrender -prefix ${QTBASE} -fast ${myconf} || die
+
+ export QTDIR=${S}
+
+ emake src-qmake src-moc sub-src sub-tools || die
+
+}
+
+src_install() {
+
+ export QTDIR=${S}
+
+ cd ${S}
+
+ # binaries
+ into $QTBASE
+ dobin bin/*
+
+ # libraries
+ dolib lib/libqt-mt.so.3.2.0 lib/libqui.so.1.0.0 lib/lib{editor,qassistantclient,designer}.a
+ cd ${D}$QTBASE/lib
+ for x in libqui.so
+ do
+ ln -s $x.1.0.0 $x.1.0
+ ln -s $x.1.0 $x.1
+ ln -s $x.1 $x
+ done
+
+ # version symlinks - 3.2.0->3.2->3->.so
+ ln -s libqt-mt.so.3.2.0 libqt-mt.so.3.2
+ ln -s libqt-mt.so.3.2 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # libqt -> libqt-mt symlinks
+ ln -s libqt-mt.so.3.2.0 libqt.so.3.2.0
+ ln -s libqt-mt.so.3.2 libqt.so.3.2
+ ln -s libqt-mt.so.3 libqt.so.3
+ ln -s libqt-mt.so libqt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{45qt3,50qtdir3}
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${S}:${QTBASE}:g" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
+ doins $x
+ done
+
+}
+