summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-02-15 15:59:12 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-02-15 15:59:12 +0000
commit34ecc680ac9d8fbb7877d35c775e232f3ecd193e (patch)
tree91e5fc318ed4bfe3d99ed0fc3c0f6bd904495f8e /x11-libs
parentthis is a functional version 0.1 (diff)
downloadhistorical-34ecc680ac9d8fbb7877d35c775e232f3ecd193e.tar.gz
historical-34ecc680ac9d8fbb7877d35c775e232f3ecd193e.tar.bz2
historical-34ecc680ac9d8fbb7877d35c775e232f3ecd193e.zip
small fixes
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/motif-config/Manifest2
-rwxr-xr-xx11-libs/motif-config/files/motif-config-0.118
2 files changed, 15 insertions, 5 deletions
diff --git a/x11-libs/motif-config/Manifest b/x11-libs/motif-config/Manifest
index e5b94f532a81..9d2b1cca8676 100644
--- a/x11-libs/motif-config/Manifest
+++ b/x11-libs/motif-config/Manifest
@@ -1,5 +1,5 @@
MD5 8e8719acd2a777294914e060d4f86976 motif-config-0.1.ebuild 1006
MD5 7d70d9fe42eb317221f10ba1d8a9a06e ChangeLog 386
MD5 503ccb1138f9c49f0855884d830988a6 metadata.xml 253
-MD5 72a4fc85127f536dcdb5e4957075854a files/motif-config-0.1 6243
+MD5 31cffcac67f38408ba2a20655924b149 files/motif-config-0.1 6368
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-motif-config-0.1 0
diff --git a/x11-libs/motif-config/files/motif-config-0.1 b/x11-libs/motif-config/files/motif-config-0.1
index 314d13670d08..f1d90cee04a7 100755
--- a/x11-libs/motif-config/files/motif-config-0.1
+++ b/x11-libs/motif-config/files/motif-config-0.1
@@ -126,17 +126,17 @@ switch_profile() {
exit 1
fi
- _deactivate_profile
-
if [ -n "$1" ]; then
if [ ! -e ${PROFILE_PATH}/${1} ]; then
eerror "$0: no such profile ${1}"
else
+ _deactivate_profile
_activate_profile $1
fi
else
for x in `ls ${PROFILE_PATH}`; do
if [ "${x}" != "current" ]; then
+ _deactivate_profile
_activate_profile ${x}
break
fi
@@ -269,64 +269,74 @@ for x in "$@"; do
-c|--get-current-profile)
[[ $# -ne 1 ]] && usage 1
get_current_profile
+ exit $?
;;
-l|--list-profiles)
[[ $# -ne 1 ]] && usage 1
list_profiles
+ exit $?
;;
-s|--set-profile)
- # switch profile
[[ $# -ne 2 ]] && usage 1
switch_profile $2
+ exit $?
;;
-L|--get-lib-path)
[[ $# -gt 2 ]] && usage 1
get_lib_path $2
+ exit $?
;;
-I|--get-inc-path)
[[ $# -gt 2 ]] && usage 1
get_lib_path $2
+ exit $?
;;
--cflags)
[[ $# -gt 2 ]] && usage 1
get_cflags $2
+ exit $?
;;
--libs)
[[ $# -gt 2 ]] && usage 1
get_libs $2
+ exit $?
;;
--install)
[[ $# -ne 2 ]] && usage 1
install_profile $2
+ exit $?
;;
--uninstall)
[[ $# -ne 2 ]] && usage 1
uninstall_profile $2
+ exit $?
;;
-h|--help)
usage 0
+ exit $?
;;
-v|--version)
echo "motif-config-0.1"
+ exit $?
;;
-*)
usage 1
;;
-
*)
usage 1
;;
+
esac
done