summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-09-30 10:32:22 +0000
committerFabian Groffen <grobian@gentoo.org>2010-09-30 10:32:22 +0000
commit0840e7cb9c0227e7cd9f84f78b00f78664747ba1 (patch)
tree85a9bb916b1a586340f417719b3cf2dfc7d68ae7 /x11-libs
parentMake the ebuild respect LDFLAGS (bug #337408). (diff)
downloadhistorical-0840e7cb9c0227e7cd9f84f78b00f78664747ba1.tar.gz
historical-0840e7cb9c0227e7cd9f84f78b00f78664747ba1.tar.bz2
historical-0840e7cb9c0227e7cd9f84f78b00f78664747ba1.zip
Import x11-libs/ige-mac-integration, a package to do Mac OS X specific stuff with GTK+. Live ebuild, thanks to Heiko Przybyl.
Package-Manager: portage-2.2.01.16706-prefix/cvs/Darwin powerpc
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/ige-mac-integration/ChangeLog13
-rw-r--r--x11-libs/ige-mac-integration/Manifest5
-rw-r--r--x11-libs/ige-mac-integration/ige-mac-integration-0.8.2.ebuild31
-rw-r--r--x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild37
-rw-r--r--x11-libs/ige-mac-integration/metadata.xml5
5 files changed, 91 insertions, 0 deletions
diff --git a/x11-libs/ige-mac-integration/ChangeLog b/x11-libs/ige-mac-integration/ChangeLog
new file mode 100644
index 000000000000..ca0ff27c740b
--- /dev/null
+++ b/x11-libs/ige-mac-integration/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for x11-libs/ige-mac-integration
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ige-mac-integration/ChangeLog,v 1.1 2010/09/30 10:32:22 grobian Exp $
+
+*ige-mac-integration-9999 (30 Sep 2010)
+*ige-mac-integration-0.8.2 (30 Sep 2010)
+
+ 30 Sep 2010; Fabian Groffen <grobian@gentoo.org>
+ +ige-mac-integration-0.8.2.ebuild, +ige-mac-integration-9999.ebuild,
+ +metadata.xml:
+ Import x11-libs/ige-mac-integration, a package to do Mac OS X specific
+ stuff with GTK+. Live ebuild, thanks to Heiko Przybyl.
+
diff --git a/x11-libs/ige-mac-integration/Manifest b/x11-libs/ige-mac-integration/Manifest
new file mode 100644
index 000000000000..7b3a2d2a4fc0
--- /dev/null
+++ b/x11-libs/ige-mac-integration/Manifest
@@ -0,0 +1,5 @@
+DIST ige-mac-integration-0.8.2.tar.gz 374304 RMD160 857dce9f7377484901e08ce68fd8a72f5261abd5 SHA1 4d5f2a88c3d354133105b3c84e4a12abcb017eeb SHA256 3e42ebbc5ce54b547eea92c36e61293f961b6d3cbe42b5e83dc8867b1829240f
+EBUILD ige-mac-integration-0.8.2.ebuild 868 RMD160 e5951845515714e4eb905a4e40192b7d0cd21b79 SHA1 02eccf990eee9659430ea4e29e2bbb0fe0d88caf SHA256 ce0909188c931b31af1b6de06794b84b92cb48352c468755e01fe35daa661705
+EBUILD ige-mac-integration-9999.ebuild 882 RMD160 b09b0eca9886bde2d6edb4330c1384258ecea89f SHA1 b22498535dd0ebe6265af558b706059e4b546342 SHA256 e25c30c986b9b064f253e618c30174e1db3bbfd04298c8e9ceb6fedc9312a79e
+MISC ChangeLog 582 RMD160 58abe8392b1076f19e74fdcc0c9e050926ad46b4 SHA1 a4b4f870f170581905b933280f7ddc140d79dcc2 SHA256 52b6bf7ed23b3f0bad4a46cce89af62c7d241602b2d5b4afe43905c4f525e146
+MISC metadata.xml 159 RMD160 daf7422c2bde2c03abbeccce93691898dee7460a SHA1 dac0288d1bc404d23c4d31e83c51d9f9381a2828 SHA256 9f4e165acd1a7bdc5c8ccdb4a40a2e969e056b8463bfe94a1b2e29cc4ef62af4
diff --git a/x11-libs/ige-mac-integration/ige-mac-integration-0.8.2.ebuild b/x11-libs/ige-mac-integration/ige-mac-integration-0.8.2.ebuild
new file mode 100644
index 000000000000..eee5f72d0b84
--- /dev/null
+++ b/x11-libs/ige-mac-integration/ige-mac-integration-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ige-mac-integration/ige-mac-integration-0.8.2.ebuild,v 1.1 2010/09/30 10:32:22 grobian Exp $
+
+EAPI="3"
+
+inherit base python libtool
+
+DESCRIPTION="GTK+ bindings for Mac OS X specific tasks"
+LICENSE="LGPL-2"
+HOMEPAGE="http://live.gnome.org/GTK+/OSX/Integration"
+SRC_URI="http://ftp.imendio.com/pub/imendio/ige-mac-integration/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+
+ dev-python/pygtk"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # fix the lookup of the codegen tools
+ sed -e "s|\$(datadir)/pygtk/2.0|${EPREFIX}/$(python_get_sitedir)/gtk-2.0|g" \
+ -i bindings/python/Makefile.am || die
+ elibtoolize
+}
+
+src_configure() {
+ econf --with-compile-warnings=no
+}
diff --git a/x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild b/x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild
new file mode 100644
index 000000000000..7caed8b31ebc
--- /dev/null
+++ b/x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild,v 1.1 2010/09/30 10:32:22 grobian Exp $
+
+EAPI="3"
+
+inherit autotools base git python
+
+EGIT_REPO_URI="git://github.com/rhult/ige-mac-integration.git"
+SRC_URI=""
+
+DESCRIPTION="GTK+ bindings for Mac OS X specific tasks"
+LICENSE="LGPL-2"
+HOMEPAGE="http://live.gnome.org/GTK+/OSX/Integration"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RESTRICT="stricter"
+RDEPEND="x11-libs/gtk+
+ dev-python/pygtk"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ git_src_prepare
+
+ # fix the lookup of the codegen tools
+ sed -e "s|\$(datadir)/pygtk/2.0|${EPREFIX}/$(python_get_sitedir)/gtk-2.0|g" \
+ -i bindings/python/Makefile.am
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-compile-warnings=no
+}
diff --git a/x11-libs/ige-mac-integration/metadata.xml b/x11-libs/ige-mac-integration/metadata.xml
new file mode 100644
index 000000000000..46dee96f4e7a
--- /dev/null
+++ b/x11-libs/ige-mac-integration/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>prefix</herd>
+</pkgmetadata>