summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-08-01 15:16:26 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-08-01 15:16:26 +0000
commitdc15b956ec36ad2d0419b4765a2237e2bda0c160 (patch)
treee8e6d13a40a3316c6538bee7de5d903419a1b87b /x11-libs/xview
parentstable amd64 (diff)
downloadhistorical-dc15b956ec36ad2d0419b4765a2237e2bda0c160.tar.gz
historical-dc15b956ec36ad2d0419b4765a2237e2bda0c160.tar.bz2
historical-dc15b956ec36ad2d0419b4765a2237e2bda0c160.zip
Backported fix for bug #67924 to the stable tree. Removed stale versions.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'x11-libs/xview')
-rw-r--r--x11-libs/xview/ChangeLog7
-rw-r--r--x11-libs/xview/xview-3.2-r5.ebuild61
2 files changed, 39 insertions, 29 deletions
diff --git a/x11-libs/xview/ChangeLog b/x11-libs/xview/ChangeLog
index 0bb854b73843..c2814c886293 100644
--- a/x11-libs/xview/ChangeLog
+++ b/x11-libs/xview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/xview
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/ChangeLog,v 1.21 2006/08/01 01:59:32 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/ChangeLog,v 1.22 2006/08/01 15:16:26 ribosome Exp $
+
+ 01 Aug 2006; Olivier Fisette <ribosome@gentoo.org> -xview-3.2.ebuild,
+ -xview-3.2-r1.ebuild, -xview-3.2-r3.ebuild, -xview-3.2-r4.ebuild,
+ xview-3.2-r5.ebuild, -xview-3.2-r6.ebuild:
+ Backported fix for bug #67924 to the stable tree. Removed stale versions.
*xview-3.2-r6 (01 Aug 2006)
diff --git a/x11-libs/xview/xview-3.2-r5.ebuild b/x11-libs/xview/xview-3.2-r5.ebuild
index e80de7ebb3ad..dc39d73d9211 100644
--- a/x11-libs/xview/xview-3.2-r5.ebuild
+++ b/x11-libs/xview/xview-3.2-r5.ebuild
@@ -1,37 +1,32 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/xview-3.2-r5.ebuild,v 1.2 2006/03/16 06:24:52 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xview/xview-3.2-r5.ebuild,v 1.3 2006/08/01 15:16:26 ribosome Exp $
inherit eutils
-DESCRIPTION="The X Window-System-based Visual/Integrated Environment for Workstations"
-HOMEPAGE="http://physionet.caregroup.harvard.edu/physiotools/xview/"
-
MY_PN="${P}p1.4-18c"
GCC_PATCHVER="0.1"
-# This is our compound patch derived from debian. We use it because:
-# * xview is a contribution made by Sun Microsystems (?) to the X community, but
-# fixes for it don't appear to be around other than in the other free distributions.
-# * It does little harm, only some defaults are changed which we can redefine anyway
-#SRC_PATCH="${PN}_3.2p1.4-16woody2.diff"
-
+DESCRIPTION="The X Window-System-based Visual/Integrated Environment for Workstations"
+HOMEPAGE="http://physionet.caregroup.harvard.edu/physiotools/xview/"
+LICENSE="sun-openlook"
# We use the xview tarball available from the X organization, but xfree86 appears
# to be up and available more often so we use that (it's their primary mirror).
SRC_URI="http://physionet.caregroup.harvard.edu/physiotools/xview/${MY_PN}.tar.gz
mirror://gentoo/${P}-gcc-4.1-v${GCC_PATCHVER}.patch.bz2"
- #mirror://debian/pool/main/x/xview/${SRC_PATCH}.gz
-S=${WORKDIR}/${MY_PN}
-LICENSE="sun-openlook"
+ # mirror://debian/pool/main/x/xview/${SRC_PATCH}.gz
+
SLOT="0"
-KEYWORDS="-alpha -amd64 ~ppc ~sparc x86"
IUSE=""
+KEYWORDS="-alpha -amd64 ~ppc ~sparc x86"
RDEPEND="|| ( ( x11-libs/libXpm
x11-proto/xextproto
)
virtual/x11
- )"
+ )
+ media-fonts/font-bh-75dpi
+ media-fonts/font-sun-misc"
DEPEND="${RDEPEND}
|| ( ( app-text/rman
@@ -40,9 +35,19 @@ DEPEND="${RDEPEND}
virtual/x11
)"
+S="${WORKDIR}/${MY_PN}"
+
src_unpack() {
- unpack $A
+ unpack ${A}
cd "${S}"
+ # This is our compound patch derived from debian. We use it because:
+ # * xview is a contribution made by Sun Microsystems (?) to the X community,
+ # but fixes for it don't appear to be around other than in the other free
+ # distributions.
+ # * It does little harm, only some defaults are changed which we can redefine
+ # anyway.
+ #
+ # SRC_PATCH="${PN}_3.2p1.4-16woody2.diff"
epatch "${FILESDIR}"/CAN-2005-0076.patch
epatch "${FILESDIR}"/lseek.diff
epatch "${DISTDIR}"/${P}-gcc-4.1-v${GCC_PATCHVER}.patch.bz2
@@ -59,36 +64,36 @@ src_unpack() {
src_compile() {
# Create the makefile
- imake -DUseInstalled -I${S}/config -I/usr/X11R6/lib/X11/config \
+ imake -DUseInstalled -I"${S}"/config -I/usr/X11R6/lib/X11/config \
|| die "imake failed"
# This is crazy and I know it, but wait till you read the code in
# Build-LinuxXView.bash.
- OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash libs \
+ OPENWINHOME="/usr/X11R6" bash Build-LinuxXView.bash libs \
|| die "building libs failed"
- OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash clients \
+ OPENWINHOME="/usr/X11R6" bash Build-LinuxXView.bash clients \
|| die "building clients failed"
- OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash contrib \
+ OPENWINHOME="/usr/X11R6" bash Build-LinuxXView.bash contrib \
|| die "building contrib failed"
- OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash olvwm \
+ OPENWINHOME="/usr/X11R6" bash Build-LinuxXView.bash olvwm \
|| die "building olvwm failed"
}
src_install() {
- DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instlibs \
+ DESTDIR="${D}" OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instlibs \
|| die "installing libs failed"
- DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instclients \
+ DESTDIR="${D}" OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instclients \
|| die "installing clients failed"
- DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instcontrib \
+ DESTDIR="${D}" OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instcontrib \
|| die "installing contrib failed"
- DESTDIR=${D} OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instolvwm \
+ DESTDIR="${D}" OPENWINHOME=/usr/X11R6 bash Build-LinuxXView.bash instolvwm \
|| die "installing olvwm failed"
- cd ${D}/usr
+ cd "${D}"/usr
ln -s X11R6 openwin
# The rest of the docs is already installed
- cd ${S}/doc
+ cd "${S}"/doc
dodoc README xview-info olgx_api.txt olgx_api.ps sel_api.txt \
dnd_api.txt whats_new.ps bugform config/usenixws/paper.ps
- rm -rf ${D}/usr/X11R6/share/doc/xview && rm -rf ${D}/usr/X11R6/share/doc
+ rm -rf "${D}"/usr/X11R6/share/doc/xview && rm -rf "${D}"/usr/X11R6/share/doc
}