summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-08-01 11:12:30 +0000
committerDan Armak <danarmak@gentoo.org>2002-08-01 11:12:30 +0000
commit0f4422fe685910e56e0072a0e4b782f5c59429b4 (patch)
treeac682be3150561ee8f9287cd532c0ac80b9f9d93 /x11-libs/xforms
parentupdated copyright year (diff)
downloadhistorical-0f4422fe685910e56e0072a0e4b782f5c59429b4.tar.gz
historical-0f4422fe685910e56e0072a0e4b782f5c59429b4.tar.bz2
historical-0f4422fe685910e56e0072a0e4b782f5c59429b4.zip
fix #5741: use custom CFLAGS
Diffstat (limited to 'x11-libs/xforms')
-rw-r--r--x11-libs/xforms/ChangeLog6
-rw-r--r--x11-libs/xforms/xforms-1.0_rc4.ebuild22
2 files changed, 25 insertions, 3 deletions
diff --git a/x11-libs/xforms/ChangeLog b/x11-libs/xforms/ChangeLog
index d743710b768e..0620e6fdc41d 100644
--- a/x11-libs/xforms/ChangeLog
+++ b/x11-libs/xforms/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/xforms
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# /space/gentoo/cvsroot/gentoo-x86/x11-libs/xforms/ChangeLog,v 1.2 2002/06/08 02:21:53 gerk Exp
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/ChangeLog,v 1.8 2002/08/01 11:12:30 danarmak Exp $
+
+ 01 Aug 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Use custom CFLAGS (fix bug #5741) (1.0_rc4 only).
*xforms-1.0_rc4 (28 Jul 2002)
28 Jul 2002; Owen Stampflee <owen@gentoo.org> xforms-1.0_rc4.ebuild
diff --git a/x11-libs/xforms/xforms-1.0_rc4.ebuild b/x11-libs/xforms/xforms-1.0_rc4.ebuild
index dc59137a46fc..2948cab53520 100644
--- a/x11-libs/xforms/xforms-1.0_rc4.ebuild
+++ b/x11-libs/xforms/xforms-1.0_rc4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0_rc4.ebuild,v 1.2 2002/07/29 05:16:48 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0_rc4.ebuild,v 1.3 2002/08/01 11:12:30 danarmak Exp $
DESCRIPTION="This is a sample skeleton ebuild file"
HOMEPAGE="http://world.std.com/~xforms"
@@ -13,10 +13,28 @@ DEPEND="virtual/x11"
PROVIDES="virtual/xforms"
S="${WORKDIR}/xforms-1.0RC4"
+src_unpack() {
+
+ unpack $A
+ cd $S
+
+ # use custom CFLAGS
+ cp Imakefile Imakefile.orig
+ sed -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
+ -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Imakefile.orig > Imakefile
+
+}
+
src_compile() {
xmkmf -a
cp Makefile Makefile.orig
sed -e s/'demos$'// Makefile.orig > Makefile
+
+ # use custom CFLAGS
+ cp Makefile Makefile.orig
+ sed -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
+ -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Makefile.orig > Makefile
+
make || die
}