summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:16:32 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:16:32 +0000
commit45ba6dc94d34f43a48e911b0874ad5a264f14aa2 (patch)
treed1b1bc806f2c3adbe1e9930ab5f0e70f5b776ab9 /x11-libs/qt-xmlpatterns
parentForgot to add to IUSE. (diff)
downloadhistorical-45ba6dc94d34f43a48e911b0874ad5a264f14aa2.tar.gz
historical-45ba6dc94d34f43a48e911b0874ad5a264f14aa2.tar.bz2
historical-45ba6dc94d34f43a48e911b0874ad5a264f14aa2.zip
Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
`technical preview`, so this will appear as a downgrade if you installed that version. Thanks to David Leverton, Bo Andresen, Bernd Steinhauser & Arfrever Frehtes Taifersar Arahesis Fixes bugs: 206975, 212086, 172219, 212069, 206976 Package-Manager: portage-2.1.4.4
Diffstat (limited to 'x11-libs/qt-xmlpatterns')
-rw-r--r--x11-libs/qt-xmlpatterns/ChangeLog12
-rw-r--r--x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.4.0_beta1.ebuild27
2 files changed, 37 insertions, 2 deletions
diff --git a/x11-libs/qt-xmlpatterns/ChangeLog b/x11-libs/qt-xmlpatterns/ChangeLog
index c4f5e1dfaaf7..dff72289863c 100644
--- a/x11-libs/qt-xmlpatterns/ChangeLog
+++ b/x11-libs/qt-xmlpatterns/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-xmlpatterns
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/ChangeLog,v 1.1 2007/12/21 20:03:25 caleb Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/ChangeLog,v 1.2 2008/03/05 23:11:46 ingmar Exp $
+
+*qt-xmlpatterns-4.4.0_beta1 (05 Mar 2008)
+
+ 05 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +qt-xmlpatterns-4.4.0_beta1.ebuild:
+ Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
+ `technical preview`, so this will appear as a downgrade if you installed
+ that version.
*qt-xmlpatterns-4.4.0_rc1 (21 Dec 2007)
diff --git a/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.4.0_beta1.ebuild b/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.4.0_beta1.ebuild
new file mode 100644
index 000000000000..8fc4ef3315f0
--- /dev/null
+++ b/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.4.0_beta1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.4.0_beta1.ebuild,v 1.1 2008/03/05 23:11:46 ingmar Exp $
+
+inherit qt4-build
+
+DESCRIPTION="The patternist module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/xmlpatterns tools/xmlpatterns"
+QCONFIG_ADD="xmlpatterns"
+QCONFIG_DEFINE="QT_XMLPATTERNS"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -xmlpatterns"
+
+ qt4-build_src_compile
+}