summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 15:09:06 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 15:09:06 +0000
commitda10f69e263bca65438ab67122f1fa023d1e1789 (patch)
tree18fe3bbba4e17771b8e146add9d3c6833053d35c /x11-libs/qt-webkit
parentAutomated update of use.local.desc (diff)
downloadhistorical-da10f69e263bca65438ab67122f1fa023d1e1789.tar.gz
historical-da10f69e263bca65438ab67122f1fa023d1e1789.tar.bz2
historical-da10f69e263bca65438ab67122f1fa023d1e1789.zip
Version bump
Package-Manager: portage-2.2_rc83/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-webkit')
-rw-r--r--x11-libs/qt-webkit/ChangeLog8
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index ebffc587ccc4..1cdd408c0c47 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.100 2010/09/13 21:23:54 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.101 2010/09/21 15:07:37 tampakrap Exp $
+
+*qt-webkit-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-webkit-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-webkit-4.6.2.ebuild:
diff --git a/x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild b/x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild
new file mode 100644
index 000000000000..06efa94c559f
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.7.0.ebuild,v 1.1 2010/09/21 15:07:37 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus kde"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[dbus?,debug=]
+ ~x11-libs/qt-multimedia-${PV}[debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[debug=]
+ dbus? ( ~x11-libs/qt-dbus-${PV}[debug=] )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[dbus=,debug=]
+ media-sound/phonon ) )
+ kde? ( media-sound/phonon )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/3rdparty/webkit/JavaScriptCore
+ src/3rdparty/webkit/WebCore
+ tools/designer/src/plugins/qwebview"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ QCONFIG_ADD="webkit"
+ QCONFIG_DEFINE="QT_WEBKIT"
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit $(qt_use dbus qdbus)"
+ qt4-build_src_configure
+}