summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:16:32 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:16:32 +0000
commit45ba6dc94d34f43a48e911b0874ad5a264f14aa2 (patch)
treed1b1bc806f2c3adbe1e9930ab5f0e70f5b776ab9 /x11-libs/qt-sql
parentForgot to add to IUSE. (diff)
downloadhistorical-45ba6dc94d34f43a48e911b0874ad5a264f14aa2.tar.gz
historical-45ba6dc94d34f43a48e911b0874ad5a264f14aa2.tar.bz2
historical-45ba6dc94d34f43a48e911b0874ad5a264f14aa2.zip
Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
`technical preview`, so this will appear as a downgrade if you installed that version. Thanks to David Leverton, Bo Andresen, Bernd Steinhauser & Arfrever Frehtes Taifersar Arahesis Fixes bugs: 206975, 212086, 172219, 212069, 206976 Package-Manager: portage-2.1.4.4
Diffstat (limited to 'x11-libs/qt-sql')
-rw-r--r--x11-libs/qt-sql/ChangeLog12
-rw-r--r--x11-libs/qt-sql/qt-sql-4.4.0_beta1.ebuild60
2 files changed, 70 insertions, 2 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index 153ad2f6e376..8ddb7a7178c0 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-sql
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.1 2007/12/21 19:04:14 caleb Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.2 2008/03/05 23:09:33 ingmar Exp $
+
+*qt-sql-4.4.0_beta1 (05 Mar 2008)
+
+ 05 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +qt-sql-4.4.0_beta1.ebuild:
+ Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
+ `technical preview`, so this will appear as a downgrade if you installed
+ that version.
*qt-sql-4.4.0_rc1 (21 Dec 2007)
diff --git a/x11-libs/qt-sql/qt-sql-4.4.0_beta1.ebuild b/x11-libs/qt-sql/qt-sql-4.4.0_beta1.ebuild
new file mode 100644
index 000000000000..7e64b1575ac4
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.4.0_beta1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.4.0_beta1.ebuild,v 1.1 2008/03/05 23:09:33 ingmar Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="firebird mysql odbc postgres +qt3support +sqlite"
+
+DEPEND="
+ ~x11-libs/qt-core-${PV}
+ firebird? ( dev-db/firebird )
+ sqlite? ( dev-db/sqlite:3 )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/libpq
+ dev-db/postgresql )
+ odbc? ( dev-db/unixODBC )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
+
+pkg_setup() {
+ if ! (use firebird || use mysql || use odbc || use postgres || use sqlite); then
+ ewarn "You need to enable at least one SQL driver. Enable at least"
+ ewarn "one of these USE flags: \"firebird mysql odbc postgres sqlite\""
+ die "Enable at least one SQL driver."
+ fi
+
+ use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} qt3support"
+
+ qt4-build_pkg_setup
+}
+
+src_compile() {
+ local myconf
+ # Don't support sqlite2 anymore
+ myconf="${myconf} -no-sql-sqlite2
+ $(qt_use mysql sql-mysql) $(use mysql && echo "-I/usr/include/mysql -L/usr/$(get_libdir)/mysql ")
+ $(qt_use postgres sql-psql) $(use postgres && echo "-I/usr/include/postgresql/pgsql ")
+ $(qt_use sqlite sql-sqlite) $(qt_use sqlite system-sqlite)
+ $(qt_use odbc sql-odbc)
+ $(qt_use qt3support)"
+
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-qdbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
+ -no-glib -no-opengl"
+
+ qt4-build_src_compile
+}