summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-10-07 23:14:39 +0000
committerMart Raudsepp <leio@gentoo.org>2006-10-07 23:14:39 +0000
commit3f3be62b3d8774c960e46c10b68a3e5c9c958c01 (patch)
tree24952a247153ecd8d5a5d59837377a53aed2459e /x11-libs/gtk+
parentinitial commit. (diff)
downloadhistorical-3f3be62b3d8774c960e46c10b68a3e5c9c958c01.tar.gz
historical-3f3be62b3d8774c960e46c10b68a3e5c9c958c01.tar.bz2
historical-3f3be62b3d8774c960e46c10b68a3e5c9c958c01.zip
Version bump to 2.10.6. Remove older 2.10.4 which has crashing issues, and 2.10.5 which is very similar to 2.10.6 but needs a patch to fix build
Package-Manager: portage-2.1.2_pre2-r5
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog9
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.10.63
-rw-r--r--x11-libs/gtk+/gtk+-2.10.6.ebuild160
3 files changed, 171 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index beb9e38a1e47..af999085ffc2 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.271 2006/10/07 18:55:24 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.272 2006/10/07 23:14:39 leio Exp $
+
+*gtk+-2.10.6 (07 Oct 2006)
+
+ 07 Oct 2006; Mart Raudsepp <leio@gentoo.org>
+ -files/gtk+-2.10.5-buildfile_typo.patch, -gtk+-2.10.4.ebuild,
+ -gtk+-2.10.5.ebuild, +gtk+-2.10.6.ebuild:
+ New version in the 2.10 series
07 Oct 2006; Markus Rothe <corsair@gentoo.org> gtk+-1.2.10-r12.ebuild:
Stable on ppc64; bug #150355
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.10.6 b/x11-libs/gtk+/files/digest-gtk+-2.10.6
new file mode 100644
index 000000000000..2cfe924d1589
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.10.6
@@ -0,0 +1,3 @@
+MD5 13c62b610c910255934452d0617403f7 gtk+-2.10.6.tar.bz2 14561124
+RMD160 929386610a634e82b7ddb10f43930b27194fa67b gtk+-2.10.6.tar.bz2 14561124
+SHA256 ca98edcea2034ab36c1024121a44d047de192d282127c8f8b77d14afba0ca468 gtk+-2.10.6.tar.bz2 14561124
diff --git a/x11-libs/gtk+/gtk+-2.10.6.ebuild b/x11-libs/gtk+/gtk+-2.10.6.ebuild
new file mode 100644
index 000000000000..1c381d151ab9
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.10.6.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.10.6.ebuild,v 1.1 2006/10/07 23:14:39 leio Exp $
+
+inherit gnome.org flag-o-matic eutils debug autotools virtualx
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc jpeg tiff xinerama"
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXfixes
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.12.1
+ >=x11-libs/pango-1.12.0
+ >=dev-libs/atk-1.10.1
+ >=x11-libs/cairo-1.2.0
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ >=dev-util/pkgconfig-0.9
+ =sys-devel/automake-1.7*
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/xineramaproto
+ doc? (
+ >=dev-util/gtk-doc-1.4
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+
+RESTRICT="confcache"
+
+
+pkg_setup() {
+ if ! built_with_use x11-libs/cairo X pdf ; then
+ einfo "Please re-emerge x11-libs/cairo with the X and pdf USE flag set"
+ die "cairo needs the X and pdf flag set"
+ fi
+}
+
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ use x86 && [ "$(get_libdir)" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Optionalize xinerama support
+ epatch "${FILESDIR}"/${PN}-2.8.10-xinerama.patch
+
+ # use an arch-specific config directory so that 32bit and 64bit versions
+ # dont clash on multilib systems
+ has_multilib_profile && epatch "${FILESDIR}"/${PN}-2.8.0-multilib.patch
+
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ if use x86 && [ "$(get_libdir)" == "lib32" ]; then
+ epatch "${FILESDIR}"/${PN}-2.8.0-multilib.patch
+ fi
+
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ use ppc64 && append-flags -mminimal-toc
+
+ # remember, eautoreconf applies elibtoolize.
+ # if you remove this, you should manually run elibtoolize
+ export WANT_AUTOMAKE=1.7
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR="."
+ eautoreconf
+
+ epunt_cxx
+}
+
+src_compile() {
+ # png always on to display icons (foser)
+ local myconf="$(use_enable doc gtk-doc) \
+ $(use_with jpeg libjpeg) \
+ $(use_with tiff libtiff) \
+ $(use_enable xinerama) \
+ --with-libpng \
+ --with-gdktarget=x11 \
+ --with-xinput"
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_test() {
+ Xmake check || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ set_gtk2_confdir
+ dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
+
+ # see bug #133241
+ echo 'gtk-fallback-icon-theme = "gnome"' > ${D}/${GTK2_CONFDIR}/gtkrc
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ dodir /etc/env.d
+ echo "GDK_USE_XFT=1" > ${D}/etc/env.d/50gtk2
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+}
+
+pkg_postinst() {
+ set_gtk2_confdir
+
+ if [ -d "${ROOT}${GTK2_CONFDIR}" ]; then
+ gtk-query-immodules-2.0 > ${ROOT}${GTK2_CONFDIR}/gtk.immodules
+ gdk-pixbuf-query-loaders > ${ROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders
+ else
+ ewarn "The destination path ${ROOT}${GTK2_CONFDIR} doesn't exist;"
+ ewarn "to complete the installation of GTK+, please create the"
+ ewarn "directory and then manually run:"
+ ewarn " cd ${ROOT}${GTK2_CONFDIR}"
+ ewarn " gtk-query-immodules-2.0 > gtk.immodules"
+ ewarn " gdk-pixbuf-query-loaders > gdk-pixbuf.loaders"
+ fi
+
+ einfo "If you experience text corruption issues, turn off RenderAccel"
+ einfo "in your xorg.conf. NVIDIA is working on this issue. "
+ einfo "See http://bugs.gentoo.org/113123 for more information."
+
+ if [ -e /usr/lib/gtk-2.0/2.[^1]* ]; then
+ elog "You need to rebuild ebuilds that installed into" /usr/lib/gtk-2.0/2.[^1]*
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC" /usr/lib/gtk-2.0/2.[^1]* ")"
+ fi
+}