summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-27 22:12:43 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-27 22:12:43 +0000
commit0f11e6ee6aaf877a970791d7005c76fa160fbdbb (patch)
tree0566e27ab58292bceca32b9c9f6ddc51453739fa /x11-libs/dnd
parentMasked out a few more packages (diff)
downloadhistorical-0f11e6ee6aaf877a970791d7005c76fa160fbdbb.tar.gz
historical-0f11e6ee6aaf877a970791d7005c76fa160fbdbb.tar.bz2
historical-0f11e6ee6aaf877a970791d7005c76fa160fbdbb.zip
OffiX Drag and Drop support, mostly for AfterStep
Diffstat (limited to 'x11-libs/dnd')
-rw-r--r--x11-libs/dnd/dnd-1.1.ebuild38
-rw-r--r--x11-libs/dnd/files/digest-dnd-1.11
-rw-r--r--x11-libs/dnd/files/dnd-1.1-gentoo.diff35
3 files changed, 74 insertions, 0 deletions
diff --git a/x11-libs/dnd/dnd-1.1.ebuild b/x11-libs/dnd/dnd-1.1.ebuild
new file mode 100644
index 000000000000..2ef28286a15c
--- /dev/null
+++ b/x11-libs/dnd/dnd-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/dnd-1.1.ebuild,v 1.1 2001/09/27 22:12:43 karltk Exp $
+
+S=${WORKDIR}/DND/DNDlib
+
+DESCRIPTION="OffiX' Drag'n'drop library"
+
+SRC_URI="http://leb.net/OffiX/dnd.1.1.tgz"
+
+HOMEPAGE="http://leb.net/OffiX"
+
+DEPEND="virtual/glibc virtual/x11"
+
+src_unpack() {
+
+ unpack dnd.1.1.tgz
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+
+}
+
+src_compile() {
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --with-x \
+ --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+
+}
+
diff --git a/x11-libs/dnd/files/digest-dnd-1.1 b/x11-libs/dnd/files/digest-dnd-1.1
new file mode 100644
index 000000000000..6eda6d45813f
--- /dev/null
+++ b/x11-libs/dnd/files/digest-dnd-1.1
@@ -0,0 +1 @@
+MD5 0d6b2a44801396e99e36831c87c25d6e dnd.1.1.tgz
diff --git a/x11-libs/dnd/files/dnd-1.1-gentoo.diff b/x11-libs/dnd/files/dnd-1.1-gentoo.diff
new file mode 100644
index 000000000000..970c5e473650
--- /dev/null
+++ b/x11-libs/dnd/files/dnd-1.1-gentoo.diff
@@ -0,0 +1,35 @@
+--- DragAndDrop.c.orig Tue Sep 25 21:14:11 2001
++++ DragAndDrop.c Tue Sep 25 21:14:16 2001
+@@ -81,23 +81,23 @@
+
+ static CursorData DndCursor[DndEND]={
+ { 0,0,NULL,NULL,0,0,0 },
+- { grey_width, grey_height,grey_bits,grey_mask_bits,
++ { grey_width, grey_height,(char*)grey_bits,(char*)grey_mask_bits,
+ grey_x_hot,grey_y_hot},
+- { file_width,file_height,file_bits,file_mask_bits,
++ { file_width,file_height,(char*)file_bits,(char*)file_mask_bits,
+ file_x_hot,file_y_hot},
+- { files_width,files_height,files_bits,files_mask_bits,
++ { files_width,files_height,(char*)files_bits,(char*)files_mask_bits,
+ files_x_hot,files_y_hot},
+- { text_width,text_height,text_bits,text_mask_bits,
++ { text_width,text_height,(char*)text_bits,(char*)text_mask_bits,
+ text_x_hot,text_y_hot },
+- { dir_width,dir_height,dir_bits,dir_mask_bits,
++ { dir_width,dir_height,(char*)dir_bits,(char*)dir_mask_bits,
+ dir_x_hot,dir_y_hot },
+- { link_width,link_height,link_bits,link_mask_bits,
++ { link_width,link_height,(char*)link_bits,(char*)link_mask_bits,
+ link_x_hot,link_y_hot},
+- { app_width,app_height,app_bits,app_mask_bits,
++ { app_width,app_height,(char*)app_bits,(char*)app_mask_bits,
+ app_x_hot,app_y_hot },
+- { url_width,url_height,url_bits,url_mask_bits,
++ { url_width,url_height,(char*)url_bits,(char*)url_mask_bits,
+ url_x_hot,url_y_hot },
+- { mime_width,mime_height,mime_bits,mime_mask_bits,
++ { mime_width,mime_height,(char*)mime_bits,(char*)mime_mask_bits,
+ mime_x_hot,mime_y_hot }
+ };
+