summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:56:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-04 15:56:17 +0000
commitf0460ac57748956c733c28968235feff71680944 (patch)
tree748015a54d8122996f8989b6bbc33eb29f4b3f30 /x11-drivers
parentia64/sparc stable wrt #268176 (diff)
downloadhistorical-f0460ac57748956c733c28968235feff71680944.tar.gz
historical-f0460ac57748956c733c28968235feff71680944.tar.bz2
historical-f0460ac57748956c733c28968235feff71680944.zip
Move use_ functions out of global scope.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog7
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild6
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.12.2.ebuild6
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild6
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0-r1.ebuild6
-rw-r--r--x11-drivers/xf86-video-via/ChangeLog6
-rw-r--r--x11-drivers/xf86-video-via/xf86-video-via-0.2.1-r1.ebuild7
-rw-r--r--x11-drivers/xf86-video-via/xf86-video-via-0.2.2.ebuild6
8 files changed, 36 insertions, 14 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 210f4f45161b..c37ea9666977 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.85 2009/04/15 15:51:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.86 2009/05/04 15:54:20 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ xf86-video-ati-6.6.3.ebuild, xf86-video-ati-6.8.0-r1.ebuild,
+ xf86-video-ati-6.12.1-r1.ebuild, xf86-video-ati-6.12.2.ebuild:
+ Move use_ functions out of global scope.
15 Apr 2009; Raúl Porcel <armin76@gentoo.org>
xf86-video-ati-6.12.1-r1.ebuild:
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild
index 9e1f0b038d46..ad96fac60370 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild,v 1.7 2009/04/15 15:51:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild,v 1.8 2009/05/04 15:54:20 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -30,7 +30,9 @@ DEPEND="${RDEPEND}
x11-proto/xf86driproto
>=x11-libs/libdrm-2 )"
-CONFIGURE_OPTIONS="$(use_enable dri)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable dri)"
+}
PATCHES=""
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.2.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.2.ebuild
index fb05aa5a1a65..4b6a4689a244 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.2.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.2.ebuild,v 1.1 2009/04/08 21:34:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.2.ebuild,v 1.2 2009/05/04 15:54:20 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -30,7 +30,9 @@ DEPEND="${RDEPEND}
x11-proto/xf86driproto
>=x11-libs/libdrm-2 )"
-CONFIGURE_OPTIONS="$(use_enable dri)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable dri)"
+}
PATCHES=""
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild
index da5ec6a4dedf..4c6af9f3ccfb 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild,v 1.13 2009/03/13 15:25:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild,v 1.14 2009/05/04 15:54:20 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -25,7 +25,9 @@ DEPEND="${RDEPEND}
x11-proto/xf86driproto
>=x11-libs/libdrm-2 )"
-CONFIGURE_OPTIONS="$(use_enable dri)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable dri)"
+}
src_install() {
x-modular_src_install
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0-r1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0-r1.ebuild
index 0e2858ce18ad..cdf0be0e687f 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0-r1.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0-r1.ebuild,v 1.11 2009/03/13 15:25:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0-r1.ebuild,v 1.12 2009/05/04 15:54:20 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -25,7 +25,9 @@ DEPEND="${RDEPEND}
x11-proto/xf86driproto
>=x11-libs/libdrm-2 )"
-CONFIGURE_OPTIONS="$(use_enable dri)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable dri)"
+}
PATCHES=(
"${FILESDIR}/${PV}/0001-Bump-CRTC-size-limits-on-AVIVO-chips-so-30-displays.patch"
diff --git a/x11-drivers/xf86-video-via/ChangeLog b/x11-drivers/xf86-video-via/ChangeLog
index 5c22fb77284c..bca3278a7d05 100644
--- a/x11-drivers/xf86-video-via/ChangeLog
+++ b/x11-drivers/xf86-video-via/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-drivers/xf86-video-via
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-via/ChangeLog,v 1.37 2009/03/13 16:08:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-via/ChangeLog,v 1.38 2009/05/04 15:56:17 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ xf86-video-via-0.2.1-r1.ebuild, xf86-video-via-0.2.2.ebuild:
+ Move use_ functions out of global scope.
13 Mar 2009; Raúl Porcel <armin76@gentoo.org>
xf86-video-via-0.2.1-r1.ebuild, xf86-video-via-0.2.2.ebuild:
diff --git a/x11-drivers/xf86-video-via/xf86-video-via-0.2.1-r1.ebuild b/x11-drivers/xf86-video-via/xf86-video-via-0.2.1-r1.ebuild
index d41daaccb2d2..fea6636e4f3c 100644
--- a/x11-drivers/xf86-video-via/xf86-video-via-0.2.1-r1.ebuild
+++ b/x11-drivers/xf86-video-via/xf86-video-via-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-via/xf86-video-via-0.2.1-r1.ebuild,v 1.9 2009/03/13 16:08:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-via/xf86-video-via-0.2.1-r1.ebuild,v 1.10 2009/05/04 15:56:17 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -24,4 +24,7 @@ DEPEND="${RDEPEND}
x11-libs/libX11 )"
PATCHES="${FILESDIR}/missing-assert.patch"
-CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable dri)"
+}
diff --git a/x11-drivers/xf86-video-via/xf86-video-via-0.2.2.ebuild b/x11-drivers/xf86-video-via/xf86-video-via-0.2.2.ebuild
index bf6ca9af0ace..0903fb0d1fae 100644
--- a/x11-drivers/xf86-video-via/xf86-video-via-0.2.2.ebuild
+++ b/x11-drivers/xf86-video-via/xf86-video-via-0.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-via/xf86-video-via-0.2.2.ebuild,v 1.8 2009/03/13 16:08:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-via/xf86-video-via-0.2.2.ebuild,v 1.9 2009/05/04 15:56:17 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -24,4 +24,6 @@ DEPEND="${RDEPEND}
>=x11-libs/libdrm-2
x11-libs/libX11 )"
-CONFIGURE_OPTIONS="$(use_enable dri)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable dri)"
+}