summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-08-13 07:54:39 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-08-13 07:54:39 +0000
commit3dd8d689e26b3ff2cc12e606ba90f144e25e5b6f (patch)
tree614e574e68444ac2a4ebe3529dff92bbd9ec287e /x11-base/opengl-update
parentFixed whitespace... silly tabs... (diff)
downloadhistorical-3dd8d689e26b3ff2cc12e606ba90f144e25e5b6f.tar.gz
historical-3dd8d689e26b3ff2cc12e606ba90f144e25e5b6f.tar.bz2
historical-3dd8d689e26b3ff2cc12e606ba90f144e25e5b6f.zip
Fixed a few leftover transition bugs in the eselect module.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'x11-base/opengl-update')
-rw-r--r--x11-base/opengl-update/Manifest10
-rwxr-xr-xx11-base/opengl-update/files/opengl-update-3.0.023
-rw-r--r--x11-base/opengl-update/files/opengl-update-3.0.0.eselect6
3 files changed, 27 insertions, 12 deletions
diff --git a/x11-base/opengl-update/Manifest b/x11-base/opengl-update/Manifest
index 2c84e4035a2d..f351d59e26fb 100644
--- a/x11-base/opengl-update/Manifest
+++ b/x11-base/opengl-update/Manifest
@@ -9,17 +9,17 @@ MD5 9ee8e7fcccc74e1ee7e79a75cbeeb4ee opengl-update-2.2.3.ebuild 2671
MD5 78f2778d5b41874016deb3135122b189 files/opengl-update-2.2.1 9849
MD5 219a292f64caeaa46b333eecde2197f2 files/digest-opengl-update-2.2.1 116
MD5 ae5b820a1034139870f7b0867f37be17 files/opengl-update-2.2.2 9702
-MD5 cf1441d189a90e495668ce495c1f08fd files/opengl-update-3.0.0.eselect 9797
+MD5 5f5127a43454869f28835f93a680f6a1 files/opengl-update-3.0.0.eselect 9832
MD5 219a292f64caeaa46b333eecde2197f2 files/digest-opengl-update-2.2.3 116
MD5 541a391b04dd49521480458bac48529d files/opengl-update-2.2.3 9859
MD5 91d9c17541be018d065a7838d7149c86 files/opengl-update-2.1.1 9110
-MD5 7c8a542ce809f07484ab35876520527f files/opengl-update-3.0.0 3588
+MD5 1d794ed70b97a34c41e8daa83b694b5c files/opengl-update-3.0.0 3799
MD5 600714175bf22abf40ed067b3dcb600d files/glxext.h-inttypes.patch 671
MD5 d6b4a7de2926d22a6b52f4d129ce3e7f files/digest-opengl-update-3.0.0 116
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFC/aTGArHZZzCEUG0RAifKAJ9iFxn2j9RTt7APtBQLyjLXNjJCGgCgiKpp
-h9qKx54rttp/beED2bsBXz8=
-=kzma
+iD8DBQFC/adSArHZZzCEUG0RAuJtAJ4h2EN1mMvK9rAp7P3k5KkSTw6ETACfb6Qq
+19enH/LYoOb/eIwShpuBEgs=
+=VNpl
-----END PGP SIGNATURE-----
diff --git a/x11-base/opengl-update/files/opengl-update-3.0.0 b/x11-base/opengl-update/files/opengl-update-3.0.0
index 723a15ea5b74..a542e1266cbf 100755
--- a/x11-base/opengl-update/files/opengl-update-3.0.0
+++ b/x11-base/opengl-update/files/opengl-update-3.0.0
@@ -1,12 +1,27 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-3.0.0,v 1.2 2005/08/13 07:43:47 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-3.0.0,v 1.3 2005/08/13 07:54:39 eradicator Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
# Further modifications by Donnie Berkholz <spyderous@gentoo.org>
# Further modifications based off submissions to bug #54984 <cyfred@gentoo.org>
# Further modifications by Jeremy Huddleston <eradicator@gentoo.org>
+. /etc/init.d/functions.sh
+
+hasq() {
+ local x
+
+ local me=${1}
+ shift
+
+ for x in "${@}"; do
+ if [[ "${x}" == "${me}" ]]; then
+ return 0
+ fi
+ done
+ return 1
+}
print_usage() {
cat << FOO
@@ -127,11 +142,11 @@ case ${ACTION} in
exit $?
;;
set-implementation)
- local myconf = "set ${NEW_GL_IMPLEM} --prefix=\"${PREFIX}\" --dst-prefix=\"${DST_PREFIX}\""
if [[ ${USE_PROFILE_HEADERS} == "yes" ]] ; then
- myconf="${myconf} --impl-headers"
+ eselect opengl set ${NEW_GL_IMPLEM} --prefix="${PREFIX}" --dst-prefix="${DST_PREFIX}" --impl-headers
+ else
+ eselect opengl set ${NEW_GL_IMPLEM} --prefix="${PREFIX}" --dst-prefix="${DST_PREFIX}"
fi
- eselect opengl ${myconf}
;;
usage)
print_usage
diff --git a/x11-base/opengl-update/files/opengl-update-3.0.0.eselect b/x11-base/opengl-update/files/opengl-update-3.0.0.eselect
index 661a4bec77d6..1ca9abd05048 100644
--- a/x11-base/opengl-update/files/opengl-update-3.0.0.eselect
+++ b/x11-base/opengl-update/files/opengl-update-3.0.0.eselect
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-3.0.0.eselect,v 1.1 2005/08/13 07:42:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-3.0.0.eselect,v 1.2 2005/08/13 07:54:39 eradicator Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
# Further modifications by Donnie Berkholz <spyderous@gentoo.org>
# Further modifications based off submissions to bug #54984 <cyfred@gentoo.org>
@@ -78,6 +78,7 @@ get_implementations() {
set-new-implementation() {
local GL_IMPLEM=${1}
local GL_LOCAL
+ local AVAIL_IMPLEMS=$(get_implementations)
check_version
check_user
@@ -86,8 +87,7 @@ set-new-implementation() {
umask 022
if ! hasq ${GL_IMPLEM} ${AVAIL_IMPLEMS}; then
- eerror "Invalid profile selected."
- exit 1
+ die -q "Invalid profile selected."
fi
echo -n "Switching to ${GL_IMPLEM} OpenGL interface..."