summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2005-11-11 20:00:02 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2005-11-11 20:00:02 +0000
commit73d0b54e07e2c46aaccde995a6306791535dae87 (patch)
treef3e0d79babf35c8b2ab23080614eab0df7f697f6 /x11-apps/xfs
parentBump for 7.0RC2. (diff)
downloadhistorical-73d0b54e07e2c46aaccde995a6306791535dae87.tar.gz
historical-73d0b54e07e2c46aaccde995a6306791535dae87.tar.bz2
historical-73d0b54e07e2c46aaccde995a6306791535dae87.zip
Bump for 7.0RC2.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'x11-apps/xfs')
-rw-r--r--x11-apps/xfs/ChangeLog7
-rw-r--r--x11-apps/xfs/files/digest-xfs-0.99.21
-rw-r--r--x11-apps/xfs/xfs-0.99.2.ebuild43
3 files changed, 50 insertions, 1 deletions
diff --git a/x11-apps/xfs/ChangeLog b/x11-apps/xfs/ChangeLog
index 1368ba36cc0a..25ac39e17197 100644
--- a/x11-apps/xfs/ChangeLog
+++ b/x11-apps/xfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xfs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.9 2005/10/31 21:43:12 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.10 2005/11/11 19:55:14 joshuabaergen Exp $
+
+*xfs-0.99.2 (11 Nov 2005)
+
+ 11 Nov 2005; Joshua Baergen <joshuabaergen@gentoo.org> +xfs-0.99.2.ebuild:
+ Bump for 7.0RC2.
31 Oct 2005; <dang@gentoo.org> xfs-0.99.1.ebuild:
Marked ~amd64
diff --git a/x11-apps/xfs/files/digest-xfs-0.99.2 b/x11-apps/xfs/files/digest-xfs-0.99.2
new file mode 100644
index 000000000000..20c6e79fdcc7
--- /dev/null
+++ b/x11-apps/xfs/files/digest-xfs-0.99.2
@@ -0,0 +1 @@
+MD5 c3a75285b1fb6ad4cd1d80ab6f7270ea xfs-0.99.2.tar.bz2 139228
diff --git a/x11-apps/xfs/xfs-0.99.2.ebuild b/x11-apps/xfs/xfs-0.99.2.ebuild
new file mode 100644
index 000000000000..f7d66cc24474
--- /dev/null
+++ b/x11-apps/xfs/xfs-0.99.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/xfs-0.99.2.ebuild,v 1.1 2005/11/11 19:55:14 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xfs application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+IUSE="ipv6"
+RDEPEND="x11-libs/libFS
+ x11-libs/libXfont"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --libdir=/etc"
+
+pkg_setup() {
+ enewgroup xfs 33
+ enewuser xfs 33 -1 /etc/X11/fs xfs
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^configdir =.*:configdir = \$(sysconfdir)/X11/fs:g" \
+ ${S}/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+
+ insinto /etc/X11/fs
+ newins ${FILESDIR}/xfs.config config
+ newinitd ${FILESDIR}/xfs.start xfs
+ newconfd ${FILESDIR}/xfs.conf.d xfs
+}