summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:40:31 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:40:31 +0000
commit87888f6159fd9b4a81e3b35dbb8dfb7bff8a2b13 (patch)
tree08ad2d754cc84fe0967ff22ac3a7a96460643478 /x11-apps/xedit
parentVersion bump. Includes quite a few bugfixes. (diff)
downloadhistorical-87888f6159fd9b4a81e3b35dbb8dfb7bff8a2b13.tar.gz
historical-87888f6159fd9b4a81e3b35dbb8dfb7bff8a2b13.tar.bz2
historical-87888f6159fd9b4a81e3b35dbb8dfb7bff8a2b13.zip
Version bump. Includes a Cygwin build fix.
Package-Manager: portage-2.1_pre10
Diffstat (limited to 'x11-apps/xedit')
-rw-r--r--x11-apps/xedit/ChangeLog8
-rw-r--r--x11-apps/xedit/files/digest-xedit-1.0.23
-rw-r--r--x11-apps/xedit/xedit-1.0.2.ebuild29
3 files changed, 39 insertions, 1 deletions
diff --git a/x11-apps/xedit/ChangeLog b/x11-apps/xedit/ChangeLog
index 270ec60f0afe..01395d65ecb3 100644
--- a/x11-apps/xedit/ChangeLog
+++ b/x11-apps/xedit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xedit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/ChangeLog,v 1.15 2006/03/22 04:42:34 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/ChangeLog,v 1.16 2006/04/29 16:40:31 joshuabaergen Exp $
+
+*xedit-1.0.2 (29 Apr 2006)
+
+ 29 Apr 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xedit-1.0.2.ebuild:
+ Version bump. Includes a Cygwin build fix.
22 Mar 2006; Joseph Jezak <josejx@gentoo.org> xedit-1.0.1.ebuild:
Marked ~ppc.
diff --git a/x11-apps/xedit/files/digest-xedit-1.0.2 b/x11-apps/xedit/files/digest-xedit-1.0.2
new file mode 100644
index 000000000000..67bb2d55bb81
--- /dev/null
+++ b/x11-apps/xedit/files/digest-xedit-1.0.2
@@ -0,0 +1,3 @@
+MD5 c56160e93c24ddf17e69891ed50deb72 xedit-1.0.2.tar.bz2 455400
+RMD160 09964b80b5bf129654ba1f088ca42154f67ead1f xedit-1.0.2.tar.bz2 455400
+SHA256 2658d78bbaf8c9effac261f3c229c035fbfda817fa9636dea1e46078213362df xedit-1.0.2.tar.bz2 455400
diff --git a/x11-apps/xedit/xedit-1.0.2.ebuild b/x11-apps/xedit/xedit-1.0.2.ebuild
new file mode 100644
index 000000000000..f89119ec19c0
--- /dev/null
+++ b/x11-apps/xedit/xedit-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/xedit-1.0.2.ebuild,v 1.1 2006/04/29 16:40:31 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xedit application"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXprintUtil
+ x11-libs/libXaw
+ xprint? ( x11-libs/libXprintUtil )"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+#src_compile() {
+# x-modular_src_configure
+# emake -j1 || die "emake failed"
+#}