summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-05-09 07:33:02 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-05-09 07:33:02 +0000
commitc0e89e150f83d160d7b4d4529cccc1a1292a5769 (patch)
treea3db8835c5a2e549a38dd1fbea8e771bc5ab8843 /x11-apps/ttmkfdir
parent(#204660) Fix build by passing in --with-render. (diff)
downloadhistorical-c0e89e150f83d160d7b4d4529cccc1a1292a5769.tar.gz
historical-c0e89e150f83d160d7b4d4529cccc1a1292a5769.tar.bz2
historical-c0e89e150f83d160d7b4d4529cccc1a1292a5769.zip
(#213773) Use CXXFLAGS, not CFLAGS -- this is C++.
Package-Manager: portage-2.1.5_rc7
Diffstat (limited to 'x11-apps/ttmkfdir')
-rw-r--r--x11-apps/ttmkfdir/ChangeLog6
-rw-r--r--x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/x11-apps/ttmkfdir/ChangeLog b/x11-apps/ttmkfdir/ChangeLog
index 9f5d7f6fadea..cadaeb13bc11 100644
--- a/x11-apps/ttmkfdir/ChangeLog
+++ b/x11-apps/ttmkfdir/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-apps/ttmkfdir
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/ttmkfdir/ChangeLog,v 1.7 2008/04/21 01:59:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/ttmkfdir/ChangeLog,v 1.8 2008/05/09 07:33:02 dberkholz Exp $
+
+ 09 May 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ ttmkfdir-3.0.9-r3.ebuild:
+ (#213773) Use CXXFLAGS, not CFLAGS -- this is C++.
21 Apr 2008; Ryan Hill <dirtyepic@gentoo.org>
+files/ttmkfdir-3.0.9-gcc43.patch, ttmkfdir-3.0.9-r3.ebuild:
diff --git a/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild b/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild
index 4b1f99da78e9..287d786ed354 100644
--- a/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild
+++ b/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild,v 1.7 2008/04/21 01:59:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/ttmkfdir/ttmkfdir-3.0.9-r3.ebuild,v 1.8 2008/05/09 07:33:02 dberkholz Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -38,7 +38,7 @@ src_compile() {
filter-flags -O -O? -foptimize-sibling-calls -fstack-protector
emake \
CXX="$(tc-getCXX)" \
- OPTFLAGS="${CFLAGS}" \
+ OPTFLAGS="${CXXFLAGS}" \
DEBUG="" \
|| die "emake failed"
}