summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-25 17:25:55 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-25 17:25:55 +0000
commitdba09da6ceb25745796631d79833b1bca304eb46 (patch)
tree3be122e91b7d593b156d0721116375b70148540e /www-servers
parentremoved now useless masks (diff)
downloadhistorical-dba09da6ceb25745796631d79833b1bca304eb46.tar.gz
historical-dba09da6ceb25745796631d79833b1bca304eb46.tar.bz2
historical-dba09da6ceb25745796631d79833b1bca304eb46.zip
* bump
Package-Manager: portage-2.1.2_pre3-r8
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.4.113
-rw-r--r--www-servers/nginx/nginx-0.4.11.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 3011e6c1cec1..7ef67226b4a3 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.116 2006/10/23 18:29:24 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.117 2006/10/25 17:25:55 voxus Exp $
+
+*nginx-0.4.11 (25 Oct 2006)
+
+ 25 Oct 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.4.10.ebuild, +nginx-0.4.11.ebuild:
+ Version bump.
*nginx-0.4.10 (23 Oct 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.4.11 b/www-servers/nginx/files/digest-nginx-0.4.11
new file mode 100644
index 000000000000..9bbd7f8248b0
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.4.11
@@ -0,0 +1,3 @@
+MD5 77ffa50e7849ad9b4a07d0fb41fd3d96 nginx-0.4.11.tar.gz 434669
+RMD160 ed2e37be0446a7028d15a9587f019c842dbea934 nginx-0.4.11.tar.gz 434669
+SHA256 339456af2c0d99a94934734fdf27855a1ba6af7ecb7d1ed7adefbb05a99622a7 nginx-0.4.11.tar.gz 434669
diff --git a/www-servers/nginx/nginx-0.4.11.ebuild b/www-servers/nginx/nginx-0.4.11.ebuild
new file mode 100644
index 000000000000..99b2e139e719
--- /dev/null
+++ b/www-servers/nginx/nginx-0.4.11.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.4.11.ebuild,v 1.1 2006/10/25 17:25:55 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}