summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-09-14 16:31:46 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-09-14 16:31:46 +0000
commit36099ded24bfb641c6f7095674b737ac1306aeea (patch)
tree6904da1de331b03743ffe0f38595f63240197c7e /www-servers
parentError commiting digest file (diff)
downloadhistorical-36099ded24bfb641c6f7095674b737ac1306aeea.tar.gz
historical-36099ded24bfb641c6f7095674b737ac1306aeea.tar.bz2
historical-36099ded24bfb641c6f7095674b737ac1306aeea.zip
* bump
Package-Manager: portage-2.1.1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.4.23
-rw-r--r--www-servers/nginx/nginx-0.4.2.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 802314fef2d2..92944a6da487 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.109 2006/09/14 15:28:57 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.110 2006/09/14 16:31:46 voxus Exp $
+
+*nginx-0.4.2 (14 Sep 2006)
+
+ 14 Sep 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.4.2.ebuild,
+ -nginx-0.4.1.ebuild:
+ Bump.
*nginx-0.4.1 (14 Sep 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.4.2 b/www-servers/nginx/files/digest-nginx-0.4.2
new file mode 100644
index 000000000000..045f5fefe85c
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.4.2
@@ -0,0 +1,3 @@
+MD5 b8c3bd4460dedaa3876c08c17121f00e nginx-0.4.2.tar.gz 419555
+RMD160 d08351b14e8159aa0df3f2ef8232a850ad19ec2a nginx-0.4.2.tar.gz 419555
+SHA256 64ce6799a4d81c320712ba5c58ef0c2b9231a5f00b36255e245f68dceed650b8 nginx-0.4.2.tar.gz 419555
diff --git a/www-servers/nginx/nginx-0.4.2.ebuild b/www-servers/nginx/nginx-0.4.2.ebuild
new file mode 100644
index 000000000000..1daf2628f6c2
--- /dev/null
+++ b/www-servers/nginx/nginx-0.4.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.4.2.ebuild,v 1.1 2006/09/14 16:31:46 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}