summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-07-22 18:15:55 +0000
committerAron Griffis <agriffis@gentoo.org>2005-07-22 18:15:55 +0000
commit39e5e3daea595838869818dcaea308e95b908f0b (patch)
tree1978ee3605928291a7ebe11d62ffd82a894b2289 /www-client/mozilla-launcher
parentAdded to ~ppc (diff)
downloadhistorical-39e5e3daea595838869818dcaea308e95b908f0b.tar.gz
historical-39e5e3daea595838869818dcaea308e95b908f0b.tar.bz2
historical-39e5e3daea595838869818dcaea308e95b908f0b.zip
Set MOZ_PLUGIN_PATH as a workaround since
(1) the nsplugins patch isn't working in mozilla/firefox/thunderbird, (2) we can't patch the binary stuff anyway Eventually it would be nice to set MOZ_PLUGIN_PATH only for the binary stuff, once the patch is fixed. Add remove_chrome() and the associated -unregister command-line arg that will eventually allow firefox/thunderbird to be uninstalled completely without leaving droppings on the filesystem. Package-Manager: portage-2.0.51.20-r5
Diffstat (limited to 'www-client/mozilla-launcher')
-rw-r--r--www-client/mozilla-launcher/ChangeLog16
-rw-r--r--www-client/mozilla-launcher/Manifest4
-rw-r--r--www-client/mozilla-launcher/files/digest-mozilla-launcher-1.411
-rw-r--r--www-client/mozilla-launcher/mozilla-launcher-1.41.ebuild42
4 files changed, 61 insertions, 2 deletions
diff --git a/www-client/mozilla-launcher/ChangeLog b/www-client/mozilla-launcher/ChangeLog
index faac64ce7154..9c15b87f96b3 100644
--- a/www-client/mozilla-launcher/ChangeLog
+++ b/www-client/mozilla-launcher/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for www-client/mozilla-launcher
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/ChangeLog,v 1.24 2005/07/21 12:46:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/ChangeLog,v 1.25 2005/07/22 18:15:55 agriffis Exp $
+
+*mozilla-launcher-1.41 (22 Jul 2005)
+
+ 22 Jul 2005; Aron Griffis <agriffis@gentoo.org>
+ +mozilla-launcher-1.41.ebuild:
+ Set MOZ_PLUGIN_PATH as a workaround since
+ (1) the nsplugins patch isn't working in mozilla/firefox/thunderbird,
+ (2) we can't patch the binary stuff anyway
+ Eventually it would be nice to set MOZ_PLUGIN_PATH only for the binary stuff,
+ once the patch is fixed.
+
+ Add remove_chrome() and the associated -unregister command-line arg that will
+ eventually allow firefox/thunderbird to be uninstalled completely without
+ leaving droppings on the filesystem.
*mozilla-launcher-1.39 (21 Jul 2005)
diff --git a/www-client/mozilla-launcher/Manifest b/www-client/mozilla-launcher/Manifest
index ab1325e8c5eb..0f28213d80d4 100644
--- a/www-client/mozilla-launcher/Manifest
+++ b/www-client/mozilla-launcher/Manifest
@@ -1,8 +1,10 @@
MD5 8f813a83fb8f29bd6c860c9dde7d7e63 mozilla-launcher-1.35.ebuild 1015
-MD5 008ee1e29e56b4d79b71f0cd8ee9046a ChangeLog 13988
+MD5 87d8dd0713a496457139755e103fe12f mozilla-launcher-1.41.ebuild 1025
+MD5 c307b3d566c34722995678f11b525fbf ChangeLog 14578
MD5 cc0891c820a717f0335919e48e686cbe metadata.xml 222
MD5 70a19e8491ee4674aaa4c92412570584 mozilla-launcher-1.39.ebuild 1025
MD5 a69b664a54ef105f276f52f14670092d files/digest-mozilla-launcher-1.35 68
MD5 a0bbf60e5a59de57c03c4a23e5e3d22d files/digest-mozilla-launcher-1.39 68
+MD5 75b4e03263918476c53b6cac8bac2e9d files/digest-mozilla-launcher-1.41 68
MD5 5f2388f082f553879f178d465eb546a3 files/mozilla-launcher-1.35-multilib.patch 1297
MD5 29ef6c963fe90532a8d9c606f8b6b885 files/mozilla-launcher-1.39-multilib.patch 1457
diff --git a/www-client/mozilla-launcher/files/digest-mozilla-launcher-1.41 b/www-client/mozilla-launcher/files/digest-mozilla-launcher-1.41
new file mode 100644
index 000000000000..d2c736707a10
--- /dev/null
+++ b/www-client/mozilla-launcher/files/digest-mozilla-launcher-1.41
@@ -0,0 +1 @@
+MD5 0a19920e6d25ac6227cac1a9bbb7b2d3 mozilla-launcher-1.41.bz2 6591
diff --git a/www-client/mozilla-launcher/mozilla-launcher-1.41.ebuild b/www-client/mozilla-launcher/mozilla-launcher-1.41.ebuild
new file mode 100644
index 000000000000..300b0f2fffc5
--- /dev/null
+++ b/www-client/mozilla-launcher/mozilla-launcher-1.41.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/mozilla-launcher-1.41.ebuild,v 1.1 2005/07/22 18:15:55 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="Script that launches mozilla or firefox"
+HOMEPAGE="http://dev.gentoo.org/~agriffis/dist/"
+SRC_URI="mirror://gentoo/${P}.bz2 \
+ http://dev.gentoo.org/~agriffis/dist/${P}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use amd64 && epatch ${FILESDIR}/${P}-multilib.patch
+}
+
+src_install() {
+ exeinto /usr/libexec
+ newexe ${P} mozilla-launcher || die
+}
+
+pkg_postinst() {
+ local f
+
+ find ${ROOT}/usr/bin -maxdepth 1 -type l | \
+ while read f; do
+ [[ $(readlink ${f}) == mozilla-launcher ]] || continue
+ einfo "Updating ${f} symlink to /usr/libexec/mozilla-launcher"
+ ln -sfn /usr/libexec/mozilla-launcher ${f}
+ done
+}