summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-07-05 21:43:04 +0000
committerPacho Ramos <pacho@gentoo.org>2010-07-05 21:43:04 +0000
commit48c6ffc7b02fc15407cb8f20974a6e56821f54f4 (patch)
tree71ea68bf99b9b149aa02d2469e297bf57e573409 /www-client/epiphany
parentppc64 stable wrt #323643 (diff)
downloadhistorical-48c6ffc7b02fc15407cb8f20974a6e56821f54f4.tar.gz
historical-48c6ffc7b02fc15407cb8f20974a6e56821f54f4.tar.bz2
historical-48c6ffc7b02fc15407cb8f20974a6e56821f54f4.zip
Revision bump to include some upstream fixes.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/ChangeLog12
-rw-r--r--www-client/epiphany/epiphany-2.30.2-r1.ebuild87
-rw-r--r--www-client/epiphany/files/epiphany-2.30.2-favicons-completion.patch50
-rw-r--r--www-client/epiphany/files/epiphany-2.30.2-history-embed.patch60
-rw-r--r--www-client/epiphany/files/epiphany-2.30.2-leave-fullscreen.patch25
-rw-r--r--www-client/epiphany/files/epiphany-2.30.2-referer-downloads.patch69
-rw-r--r--www-client/epiphany/files/epiphany-2.30.2-uri-crash.patch23
7 files changed, 325 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 49f560c2526a..24471d04854d 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-client/epiphany
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.244 2010/06/26 09:35:06 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.245 2010/07/05 21:43:04 pacho Exp $
+
+*epiphany-2.30.2-r1 (05 Jul 2010)
+
+ 05 Jul 2010; Pacho Ramos <pacho@gentoo.org> +epiphany-2.30.2-r1.ebuild,
+ +files/epiphany-2.30.2-favicons-completion.patch,
+ +files/epiphany-2.30.2-history-embed.patch,
+ +files/epiphany-2.30.2-leave-fullscreen.patch,
+ +files/epiphany-2.30.2-referer-downloads.patch,
+ +files/epiphany-2.30.2-uri-crash.patch:
+ Revision bump to include some upstream fixes.
26 Jun 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
-epiphany-2.24.3.ebuild:
diff --git a/www-client/epiphany/epiphany-2.30.2-r1.ebuild b/www-client/epiphany/epiphany-2.30.2-r1.ebuild
new file mode 100644
index 000000000000..95bf788e4d98
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.30.2-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.30.2-r1.ebuild,v 1.1 2010/07/05 21:43:04 pacho Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+
+# We are not ready for introspection yet
+IUSE="avahi doc networkmanager +nss test"
+
+# TODO: add seed support
+RDEPEND=">=dev-libs/glib-2.19.7
+ >=x11-libs/gtk+-2.19.5
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ >=net-libs/webkit-gtk-1.1.22
+ >=net-libs/libsoup-2.29.91[gnome]
+ >=gnome-base/gnome-keyring-2.26.0
+
+ x11-libs/libICE
+ x11-libs/libSM
+
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ nss? ( dev-libs/nss )
+ x11-themes/gnome-icon-theme"
+# introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.3.2
+ gnome-base/gnome-common
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-introspection
+ --disable-scrollkeeper
+ --disable-maintainer-mode
+ --with-distributor-name=Gentoo
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable nss)
+ $(use_enable test tests)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # ephy-toolbar: fix leave-fullscreen item visibility
+ epatch "${FILESDIR}/${P}-leave-fullscreen.patch"
+
+ # Send 'Referer' on headers sent for context menu HTTP downloads
+ epatch "${FILESDIR}/${P}-referer-downloads.patch"
+
+ # ephy-location-entry: reenable favicons in completion
+ epatch "${FILESDIR}/${P}-favicons-completion.patch"
+
+ # Allow not copying history when creating a new embed
+ epatch "${FILESDIR}/${P}-history-embed.patch"
+
+ # Fix crash when trying to load URIs with no path
+ epatch "${FILESDIR}/${P}-uri-crash.patch"
+}
+
+#src_compile() {
+ # Fix sandbox error with USE="introspection"
+ # https://bugs.webkit.org/show_bug.cgi?id=35471
+# addpredict "$(unset HOME; echo ~)/.local"
+# emake || die "Compile failed"
+#}
diff --git a/www-client/epiphany/files/epiphany-2.30.2-favicons-completion.patch b/www-client/epiphany/files/epiphany-2.30.2-favicons-completion.patch
new file mode 100644
index 000000000000..21b21f70289e
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.30.2-favicons-completion.patch
@@ -0,0 +1,50 @@
+From 0739487127652cf544257e7a0d48caa580f98ad2 Mon Sep 17 00:00:00 2001
+From: Diego Escalante Urrelo <descalante@igalia.com>
+Date: Tue, 20 Apr 2010 22:18:12 +0000
+Subject: ephy-location-entry: reenable favicons in completion
+
+Favicons in the completion popup were hidden because of an ugly flashing. It
+turns out it is caused by gtk_entry_set_icon_from_* functions. They queue a
+resize if the GtkEntry is visible, hence we see this ugly flash which is
+actually the completion obeying to the resize.
+
+The side effect is that when you start typying a new address in the location
+entry, the favicon of the current location will still be displayed. The
+previous behaviour was to set a 'text/html' icon when the user edited the
+location entry. Note that such icon will disappear as soon as you activate the
+location entry.
+
+Bug #616345
+---
+diff --git a/lib/widgets/ephy-location-entry.c b/lib/widgets/ephy-location-entry.c
+index cf34789..1f03810 100644
+--- a/lib/widgets/ephy-location-entry.c
++++ b/lib/widgets/ephy-location-entry.c
+@@ -466,8 +466,6 @@ editable_changed_cb (GtkEditable *editable,
+ g_regex_unref (quote_regex);
+ }
+
+- update_favicon (entry);
+-
+ g_signal_emit (entry, signals[USER_CHANGED], 0);
+ }
+
+@@ -1253,16 +1251,11 @@ ephy_location_entry_set_completion (EphyLocationEntry *entry,
+ g_signal_connect_after (completion, "action-activated",
+ G_CALLBACK (action_activated_after_cb), entry);
+
+- /* FIXME: this works fine, but the favicons seem to be
+- * added-removed the view constantly, and the visual effect is
+- * very ugly */
+-#if 0
+ cell = gtk_cell_renderer_pixbuf_new ();
+ gtk_cell_layout_pack_start (GTK_CELL_LAYOUT (completion),
+ cell, FALSE);
+ gtk_cell_layout_add_attribute (GTK_CELL_LAYOUT (completion),
+ cell, "pixbuf", favicon_col);
+-#endif
+
+ cell = gtk_cell_renderer_text_new ();
+ g_object_set (cell,
+--
+cgit v0.8.3.1
diff --git a/www-client/epiphany/files/epiphany-2.30.2-history-embed.patch b/www-client/epiphany/files/epiphany-2.30.2-history-embed.patch
new file mode 100644
index 000000000000..038109fdbff3
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.30.2-history-embed.patch
@@ -0,0 +1,60 @@
+From be3c8f50cefef8ea3f34854c0254b3bdaa851958 Mon Sep 17 00:00:00 2001
+From: Mario Sanchez Prada <msanchez@igalia.com>
+Date: Tue, 20 Apr 2010 20:15:25 +0000
+Subject: Allow not copying history when creating a new embed
+
+Just added a new flag and check it before copying the history
+
+Bug #611400
+
+Signed-off-by: Xan Lopez <xan@gnome.org>
+---
+diff --git a/src/ephy-shell.c b/src/ephy-shell.c
+index e276731..fc4caf9 100644
+--- a/src/ephy-shell.c
++++ b/src/ephy-shell.c
+@@ -435,6 +435,7 @@ ephy_shell_new_tab_full (EphyShell *shell,
+ gboolean open_page = FALSE;
+ gboolean jump_to;
+ gboolean active_is_blank = FALSE;
++ gboolean copy_history = TRUE;
+ GtkWidget *nb;
+ int position = -1;
+ gboolean is_empty = FALSE;
+@@ -443,6 +444,7 @@ ephy_shell_new_tab_full (EphyShell *shell,
+ if (flags & EPHY_NEW_TAB_OPEN_PAGE) open_page = TRUE;
+ if (flags & EPHY_NEW_TAB_IN_NEW_WINDOW) in_new_window = TRUE;
+ if (flags & EPHY_NEW_TAB_IN_EXISTING_WINDOW) in_new_window = FALSE;
++ if (flags & EPHY_NEW_TAB_DONT_COPY_HISTORY) copy_history = FALSE;
+
+ in_new_window = in_new_window && !eel_gconf_get_boolean (CONF_LOCKDOWN_FULLSCREEN);
+ g_return_val_if_fail (open_page == (gboolean)(request != NULL), NULL);
+@@ -493,11 +495,11 @@ ephy_shell_new_tab_full (EphyShell *shell,
+ ephy_embed_container_add_child (EPHY_EMBED_CONTAINER (window), embed, position, jump_to);
+ }
+
+- if (previous_embed != NULL)
+- {
++ if (copy_history && previous_embed != NULL)
++ {
+ ephy_web_view_copy_back_history (ephy_embed_get_web_view (previous_embed),
+ ephy_embed_get_web_view (embed));
+- }
++ }
+
+ ephy_gui_window_update_user_time (GTK_WIDGET (window), user_time);
+
+diff --git a/src/ephy-shell.h b/src/ephy-shell.h
+index c87a43b..895c91d 100644
+--- a/src/ephy-shell.h
++++ b/src/ephy-shell.h
+@@ -69,6 +69,7 @@ typedef enum
+
+ /* The way to load */
+ EPHY_NEW_TAB_FROM_EXTERNAL = 1 << 12,
++ EPHY_NEW_TAB_DONT_COPY_HISTORY = 1 << 13,
+
+ } EphyNewTabFlags;
+
+--
+cgit v0.8.3.1
diff --git a/www-client/epiphany/files/epiphany-2.30.2-leave-fullscreen.patch b/www-client/epiphany/files/epiphany-2.30.2-leave-fullscreen.patch
new file mode 100644
index 000000000000..a8ff7972c24f
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.30.2-leave-fullscreen.patch
@@ -0,0 +1,25 @@
+From 7f5202b49a8015bc09faa6e10c9f78c3e97ab83b Mon Sep 17 00:00:00 2001
+From: Diego Escalante Urrelo <descalante@igalia.com>
+Date: Mon, 01 Mar 2010 03:05:43 +0000
+Subject: ephy-toolbar: fix leave-fullscreen item visibility
+
+We were explicitely setting the separator and toolbar visibility but not the
+exit_button item. This meant the fixed_toolbar was shown but the exit_button
+remained hidden.
+
+Bug #611445
+---
+diff --git a/src/ephy-toolbar.c b/src/ephy-toolbar.c
+index a721831..9bb1e61 100644
+--- a/src/ephy-toolbar.c
++++ b/src/ephy-toolbar.c
+@@ -135,6 +135,7 @@ ephy_toolbar_update_fixed_visibility (EphyToolbar *toolbar)
+
+ show = priv->leave_fullscreen_visible;
+ g_object_set (priv->sep_item, "visible", show, NULL);
++ g_object_set (priv->exit_button, "visible", show, NULL);
+ g_object_set (priv->fixed_toolbar, "visible", show, NULL);
+ }
+
+--
+cgit v0.8.3.1
diff --git a/www-client/epiphany/files/epiphany-2.30.2-referer-downloads.patch b/www-client/epiphany/files/epiphany-2.30.2-referer-downloads.patch
new file mode 100644
index 000000000000..aaf70484e39c
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.30.2-referer-downloads.patch
@@ -0,0 +1,69 @@
+From b30cf3d0e24c51b0f77979af49f200bbac5bd050 Mon Sep 17 00:00:00 2001
+From: Mario Sanchez Prada <msanchez@igalia.com>
+Date: Wed, 14 Apr 2010 16:06:36 +0000
+Subject: Send 'Referer' on headers sent for context menu HTTP downloads
+
+Make sure the EphyEmbedPersist object is created specifying the
+EphyEmbed object, and create the network request inside of it
+using the URL from the associated web view as 'Referer'
+
+Bug #136292
+
+Signed-off-by: Xan Lopez <xan@gnome.org>
+---
+diff --git a/embed/ephy-embed-persist.c b/embed/ephy-embed-persist.c
+index 44910fe..8ee3df3 100644
+--- a/embed/ephy-embed-persist.c
++++ b/embed/ephy-embed-persist.c
+@@ -763,7 +763,36 @@ ephy_embed_persist_save (EphyEmbedPersist *persist)
+ */
+ g_object_ref (persist);
+
+- request = webkit_network_request_new (priv->source);
++ if (priv->embed)
++ {
++ EphyWebView *web_view;
++ SoupMessage *msg;
++ gchar *referer;
++
++ /* Get the webview associated to the embed */
++ web_view = ephy_embed_get_web_view (priv->embed);
++
++ /* Create the request with a SoupMessage to allow
++ setting the 'Referer' as got from the embed */
++ msg = soup_message_new (SOUP_METHOD_GET, priv->source);
++ request = WEBKIT_NETWORK_REQUEST (
++ g_object_new (WEBKIT_TYPE_NETWORK_REQUEST,
++ "message", msg,
++ NULL));
++
++ /* Add the referer to the request headers */
++ referer = ephy_web_view_get_location (web_view, FALSE);
++ soup_message_headers_append (msg->request_headers,
++ "Referer", referer);
++ g_free (referer);
++ g_object_unref (msg);
++ }
++ else
++ {
++ /* Create a normal network request otherwise */
++ request = webkit_network_request_new (priv->source);
++ }
++
+ priv->download = webkit_download_new (request);
+ g_object_unref (request);
+
+diff --git a/src/popup-commands.c b/src/popup-commands.c
+index 8930d83..c620d08 100644
+--- a/src/popup-commands.c
++++ b/src/popup-commands.c
+@@ -237,6 +237,7 @@ save_property_url (GtkAction *action,
+ ephy_embed_persist_set_persist_key
+ (persist, CONF_STATE_SAVE_DIR);
+ ephy_embed_persist_set_source (persist, location);
++ ephy_embed_persist_set_embed (persist, embed);
+
+ g_signal_connect (persist, "completed",
+ G_CALLBACK (save_property_url_completed_cb), NULL);
+--
+cgit v0.8.3.1
diff --git a/www-client/epiphany/files/epiphany-2.30.2-uri-crash.patch b/www-client/epiphany/files/epiphany-2.30.2-uri-crash.patch
new file mode 100644
index 000000000000..21ac4762d7fe
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.30.2-uri-crash.patch
@@ -0,0 +1,23 @@
+From 6a4715b8a9df0bc16394c890cd734bc0601bfd03 Mon Sep 17 00:00:00 2001
+From: Gustavo Noronha Silva <gns@gnome.org>
+Date: Mon, 17 May 2010 15:17:46 +0000
+Subject: Fix crash when trying to load URIs with no path
+
+Trying to load file:, for instance, will crash Epiphany. This commit
+fixes this. See http://bugs.debian.org/554595.
+---
+diff --git a/embed/ephy-web-view.c b/embed/ephy-web-view.c
+index 2e08480..d8604cb 100644
+--- a/embed/ephy-web-view.c
++++ b/embed/ephy-web-view.c
+@@ -2688,7 +2688,7 @@ ephy_web_view_can_go_up (EphyWebView *view)
+ return FALSE;
+ }
+
+- result = (uri->fragment || uri->query || strlen (uri->path) > 1);
++ result = uri->fragment || uri->query || (uri->path && (strlen (uri->path) > 1));
+ soup_uri_free (uri);
+
+ return result;
+--
+cgit v0.8.3.1