summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-07 01:02:43 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-07 01:02:43 +0000
commitd601c5200406e8ed3e6f75caca9e99fcf032121a (patch)
treebd05bb645d9f38d51dddc4a59482151e0f4981a2 /www-client/elinks
parentRemove versions with security issue. (diff)
downloadhistorical-d601c5200406e8ed3e6f75caca9e99fcf032121a.tar.gz
historical-d601c5200406e8ed3e6f75caca9e99fcf032121a.tar.bz2
historical-d601c5200406e8ed3e6f75caca9e99fcf032121a.zip
cleanup ebuild
Package-Manager: portage-2.0.53
Diffstat (limited to 'www-client/elinks')
-rw-r--r--www-client/elinks/Manifest14
-rw-r--r--www-client/elinks/elinks-0.10.6.ebuild71
2 files changed, 41 insertions, 44 deletions
diff --git a/www-client/elinks/Manifest b/www-client/elinks/Manifest
index 71c51087f8a2..d819d412a17e 100644
--- a/www-client/elinks/Manifest
+++ b/www-client/elinks/Manifest
@@ -1,9 +1,19 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 0d35da618ffc420988fe1c2a2f280588 ChangeLog 11617
MD5 460bf16e9409074244ba5f1c62f95b2e elinks-0.10.5-r1.ebuild 4025
MD5 166bcca8eca86c5303b39043887e950b elinks-0.10.5.ebuild 3530
-MD5 b12cca25f8b112f8fdcd853510afab3c elinks-0.10.6.ebuild 4023
-MD5 d94d306da3804e41296e1bf04c7c9cae metadata.xml 255
+MD5 8e664666571c5fe105e8e8873180a03a elinks-0.10.6.ebuild 3913
MD5 db4038d1a62b31535db38c97c40928d8 files/digest-elinks-0.10.5 132
MD5 db4038d1a62b31535db38c97c40928d8 files/digest-elinks-0.10.5-r1 132
MD5 a2f9214a88eeac493c0bbaef6c2bf76b files/digest-elinks-0.10.6 132
MD5 8641dcff9f251387e7eba19875a7077c files/elinks-osx-configure.diff 919
+MD5 d94d306da3804e41296e1bf04c7c9cae metadata.xml 255
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDljVigIKl8Uu19MoRAlzbAJ4o5ns+6E9vvNVolb7mv1DLO/yZsACggFy+
+op9TmUdAW+23u4raHWUE7Ig=
+=0/87
+-----END PGP SIGNATURE-----
diff --git a/www-client/elinks/elinks-0.10.6.ebuild b/www-client/elinks/elinks-0.10.6.ebuild
index 25a3a115f977..533fa5172545 100644
--- a/www-client/elinks/elinks-0.10.6.ebuild
+++ b/www-client/elinks/elinks-0.10.6.ebuild
@@ -1,24 +1,22 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/elinks-0.10.6.ebuild,v 1.6 2005/12/03 16:47:10 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/elinks-0.10.6.ebuild,v 1.7 2005/12/07 01:02:43 vapier Exp $
inherit eutils
-IUSE="gpm zlib bzip2 ssl X lua guile perl ruby gnutls idn javascript ipv6 \
-samba ftp gopher nntp finger javascript debug nls"
-
MY_P=${P/_/}
DESCRIPTION="Advanced and well-established text-mode web browser"
-HOMEPAGE="http://elinks.or.cz"
+HOMEPAGE="http://elinks.or.cz/"
SRC_URI="http://elinks.or.cz/download/${MY_P}.tar.bz2
http://dev.gentoo.org/~spock/portage/distfiles/elinks-0.10.4.conf.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ppc64 sparc x86"
+IUSE="bzip2 debug finger ftp gnutls gopher gpm guile idn ipv6 javascript javascript lua nls nntp perl ruby samba ssl X zlib"
+RESTRICT="test"
-DEPEND="virtual/libc
- >=dev-libs/expat-1.95.4
+DEPEND=">=dev-libs/expat-1.95.4
bzip2? ( >=app-arch/bzip2-1.0.2 )
ssl? ( >=dev-libs/openssl-0.9.6g )
X? ( virtual/x11 )
@@ -31,14 +29,12 @@ DEPEND="virtual/libc
ruby? ( dev-lang/ruby )
!mips? ( !alpha? ( javascript? ( dev-lang/spidermonkey ) ) )
samba? ( net-fs/samba )"
-
PROVIDE="virtual/textbrowser"
S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- cd ${WORKDIR}
mv "${PN}-0.10.4.conf" "${PN}.conf"
if ! use ftp ; then
sed -i -e 's/\(.*protocol.ftp.*\)/# \1/' ${PN}.conf
@@ -57,39 +53,39 @@ src_compile() {
myconf="--enable-fastmem"
fi
- econf --sysconfdir=/etc/elinks \
+ econf \
+ --sysconfdir=/etc/elinks \
--enable-leds \
--enable-256-colors \
--enable-html-highlight \
- `use_with gpm` \
- `use_with zlib` \
- `use_with bzip2 bzlib` \
- `use_with ssl openssl` \
- `use_with X x` \
- `use_with lua` \
- `use_with guile` \
- `use_with perl` \
- `use_with ruby` \
- `use_with idn` \
- `use_with javascript spidermonkey` \
- `use_enable nls` \
- `use_enable ipv6` \
- `use_enable samba smb` \
- `use_enable ftp` \
- `use_enable gopher` \
- `use_enable nntp` \
- `use_enable finger` \
- "${myconf}" || die
+ $(use_with gpm) \
+ $(use_with zlib) \
+ $(use_with bzip2 bzlib) \
+ $(use_with ssl openssl) \
+ $(use_with X x) \
+ $(use_with lua) \
+ $(use_with guile) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with idn) \
+ $(use_with javascript spidermonkey) \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable samba smb) \
+ $(use_enable ftp) \
+ $(use_enable gopher) \
+ $(use_enable nntp) \
+ $(use_enable finger) \
+ ${myconf} || die
emake || die "compile problem"
}
src_install() {
-
make DESTDIR="${D}" install || die
insopts -m 644 ; insinto /etc/elinks
- doins ${WORKDIR}/elinks.conf
+ doins "${WORKDIR}"/elinks.conf
newins contrib/keybind-full.conf keybind-full.sample
newins contrib/keybind.conf keybind.conf.sample
@@ -101,16 +97,7 @@ src_install() {
# Remove some conflicting files on OSX. The files provided by OSX 10.4
# are more or less the same. -- Fabian Groffen (2005-06-30)
- if use ppc-macos; then
- rm -f ${D}/usr/lib/charset.alias
- fi
-
- rm -f ${D}/usr/share/locale/locale.alias
-}
-
-# Disable it as the only test available is interactive..
-src_test() {
- return 0
+ rm -f "${D}"/usr/share/locale/locale.alias "${D}"/usr/lib/charset.alias
}
pkg_postinst() {