summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2005-01-27 00:22:03 +0000
committerScott W Taylor <swtaylor@gentoo.org>2005-01-27 00:22:03 +0000
commit4ac5f1e609a73c0ab16d67af1e6e5a320d00968f (patch)
tree3a18c4e7c948c2859622b36eb1eceab959b6eff9 /www-apps
parentmoved conflicting packages in RDEPEND (it's a runtime conflict) (diff)
downloadhistorical-4ac5f1e609a73c0ab16d67af1e6e5a320d00968f.tar.gz
historical-4ac5f1e609a73c0ab16d67af1e6e5a320d00968f.tar.bz2
historical-4ac5f1e609a73c0ab16d67af1e6e5a320d00968f.zip
bump. css fix and imagemagick works again
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gallery/Manifest4
-rw-r--r--www-apps/gallery/files/digest-gallery-1.4.4_p51
-rw-r--r--www-apps/gallery/gallery-1.4.4_p5.ebuild48
3 files changed, 52 insertions, 1 deletions
diff --git a/www-apps/gallery/Manifest b/www-apps/gallery/Manifest
index 25bb3126822b..61a8324e175b 100644
--- a/www-apps/gallery/Manifest
+++ b/www-apps/gallery/Manifest
@@ -1,5 +1,7 @@
+MD5 29819f451671ad3990643266da9547f2 gallery-1.4.4_p4.ebuild 1217
MD5 5a805d14dee43af14078c83964d5aebf ChangeLog 6509
+MD5 115d55c6934de86acfc13067009c3358 gallery-1.4.4_p5.ebuild 1219
MD5 c339473e0ff43da76eb2f2607c441921 metadata.xml 280
-MD5 29819f451671ad3990643266da9547f2 gallery-1.4.4_p4.ebuild 1217
MD5 6c85fc83b9792ffa77599fd7d057edb8 files/digest-gallery-1.4.4_p4 70
+MD5 a2ae212dd9cfcd3c7e5f931e09ce8686 files/digest-gallery-1.4.4_p5 70
MD5 1a10c9a2ede35b5bfcfcedc4d90373e3 files/postinstall-en.txt 287
diff --git a/www-apps/gallery/files/digest-gallery-1.4.4_p5 b/www-apps/gallery/files/digest-gallery-1.4.4_p5
new file mode 100644
index 000000000000..5ac5905bfd5a
--- /dev/null
+++ b/www-apps/gallery/files/digest-gallery-1.4.4_p5
@@ -0,0 +1 @@
+MD5 a590b494115f2c5ffa23417839311614 gallery-1.4.4-pl5.tar.gz 1759534
diff --git a/www-apps/gallery/gallery-1.4.4_p5.ebuild b/www-apps/gallery/gallery-1.4.4_p5.ebuild
new file mode 100644
index 000000000000..d3362724158a
--- /dev/null
+++ b/www-apps/gallery/gallery-1.4.4_p5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.4.4_p5.ebuild,v 1.1 2005/01/27 00:22:03 swtaylor Exp $
+
+inherit webapp
+
+MY_P=${P/_p/-pl}
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=net-www/apache-1.3.24-r1
+ >=dev-php/mod_php-4.1.2-r5
+ >=media-gfx/jhead-1.6
+ >=media-libs/netpbm-9.12
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ for file in AUTHORS ChangeLog README ChangeLog.archive.gz; do
+ dodoc ${file}
+ rm -f ${file}
+ done
+
+ touch ${S}/.htaccess ${S}/config.php
+ cp -R . ${D}/${MY_HTDOCSDIR}
+
+ # config files
+ webapp_configfile ${MY_HTDOCSDIR}/config.php
+
+ # owned files
+ dodir ${MY_HTDOCSDIR}/albums
+ webapp_serverowned ${MY_HTDOCSDIR}/albums
+ webapp_serverowned ${MY_HTDOCSDIR}/config.php
+ webapp_serverowned ${MY_HTDOCSDIR}/.htaccess
+
+ dohtml docs/*
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}