summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-09-12 03:46:59 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-09-12 03:46:59 +0000
commitb6b424ef1ea5c615b33584a37f8914806246ce81 (patch)
tree5903fe0b4d29e0f8a8ee2ce16e87f26131a43879 /www-apps/twiki
parentStable x86; bug #132536 (diff)
downloadhistorical-b6b424ef1ea5c615b33584a37f8914806246ce81.tar.gz
historical-b6b424ef1ea5c615b33584a37f8914806246ce81.tar.bz2
historical-b6b424ef1ea5c615b33584a37f8914806246ce81.zip
Version bump
Package-Manager: portage-2.1.1_pre2-r6
Diffstat (limited to 'www-apps/twiki')
-rw-r--r--www-apps/twiki/ChangeLog8
-rw-r--r--www-apps/twiki/files/digest-twiki-4.0.4-r26
-rw-r--r--www-apps/twiki/twiki-4.0.4-r2.ebuild87
3 files changed, 100 insertions, 1 deletions
diff --git a/www-apps/twiki/ChangeLog b/www-apps/twiki/ChangeLog
index 628512762872..0b4585e0d80d 100644
--- a/www-apps/twiki/ChangeLog
+++ b/www-apps/twiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/twiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/ChangeLog,v 1.36 2006/09/02 12:01:36 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/ChangeLog,v 1.37 2006/09/12 03:41:29 rl03 Exp $
+
+*twiki-4.0.4-r2 (12 Sep 2006)
+
+ 12 Sep 2006; Renat Lumpau <rl03@gentoo.org> -twiki-4.0.4-r1.ebuild,
+ +twiki-4.0.4-r2.ebuild:
+ Version bump
02 Sep 2006; Renat Lumpau <rl03@gentoo.org> twiki-4.0.4-r1.ebuild:
Added HTML-Parser, bug #145732.
diff --git a/www-apps/twiki/files/digest-twiki-4.0.4-r2 b/www-apps/twiki/files/digest-twiki-4.0.4-r2
new file mode 100644
index 000000000000..3b930156f9c0
--- /dev/null
+++ b/www-apps/twiki/files/digest-twiki-4.0.4-r2
@@ -0,0 +1,6 @@
+MD5 9be884c84c8d300ae2767e668ade6d35 TWiki-4.0.4.tgz 4251364
+RMD160 6d920a781aec1826d51421514c34d97142a987ea TWiki-4.0.4.tgz 4251364
+SHA256 ef4d436b769e4ef19a0433d187b5a4c328f62d1983fedb4a3530bd6dd1ee6eda TWiki-4.0.4.tgz 4251364
+MD5 cd1fa64ccf3001307234a41836113665 hotfix-4.0.4-3.tgz 256024
+RMD160 72411c20c3829c8dea842e7c3f000df8197db91e hotfix-4.0.4-3.tgz 256024
+SHA256 5e5f49cffaa94693022031567723d94d5b7f3202037e0bace4182af85034f098 hotfix-4.0.4-3.tgz 256024
diff --git a/www-apps/twiki/twiki-4.0.4-r2.ebuild b/www-apps/twiki/twiki-4.0.4-r2.ebuild
new file mode 100644
index 000000000000..9a78825d857c
--- /dev/null
+++ b/www-apps/twiki/twiki-4.0.4-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/twiki/twiki-4.0.4-r2.ebuild,v 1.1 2006/09/12 03:41:29 rl03 Exp $
+
+inherit webapp eutils
+
+WEBAPP_MANUAL_SLOT="yes"
+SLOT=4.0.4
+
+MY_PN="TWiki"
+
+DESCRIPTION="A Web Based Collaboration Platform"
+HOMEPAGE="http://twiki.org/"
+SRC_URI="http://twiki.org/p/pub/Codev/Release/${MY_PN}-${PV}.tgz
+http://twiki.org/p/pub/Codev/HotFix04x00x04x03/hotfix-4.0.4-3.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="apache2"
+
+S=${WORKDIR}
+
+RDEPEND=">=dev-lang/perl-5.8
+ >=app-text/rcs-5.7
+ sys-apps/diffutils
+ dev-perl/Algorithm-Diff
+ >=virtual/perl-CGI-3.20
+ perl-core/File-Spec
+ dev-perl/Text-Diff
+ perl-core/Time-Local
+ dev-perl/CGI-Session
+ perl-core/digest-base
+ dev-perl/Digest-SHA1
+ dev-perl/locale-maketext-lexicon
+ virtual/perl-libnet
+ dev-perl/URI
+ virtual/cron
+ dev-perl/HTML-Parser
+ apache2? ( >=net-www/apache-2.0.54 )
+ !apache2? ( =net-www/apache-1* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ mv ${S}/bin/LocalLib.cfg.txt ${S}/bin/LocalLib.cfg
+ mv ${S}/lib/LocalSite.cfg.txt ${S}/lib/LocalSite.cfg
+ # change web user to apache
+ cd ${S}/lib/TWiki
+ find . -name '*,v' -exec sed -i 's|nobody:|apache:|g' '{}' ';'
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -r . ${D}/${MY_HTDOCSDIR}
+
+ dodoc readme.txt
+ dohtml T*.html
+
+ for file in $(find data pub) lib/LocalSite.cfg; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ for a in bin/setlib.cfg bin/LocalLib.cfg lib/TWiki.cfg lib/LocalSite.cfg; do
+ webapp_configfile ${MY_HTDOCSDIR}/${a}
+ done
+ webapp_hook_script ${FILESDIR}/reconfig
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_postupgrade_txt en ${FILESDIR}/postupgrade-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from an older version of TWiki, back up your"
+ ewarn "data/ and pub/ directories and any local changes before upgrading!"
+ ewarn
+ ewarn "You are _strongly_ encouraged to to read the upgrade guide:"
+ ewarn "http://twiki.org/cgi-bin/view/TWiki/TWikiDocumentation"
+ ewarn
+ elog "webapp-config will not be run automatically"
+ elog "Run webapp-config -I -h <host> -d ${PN} ${PN} ${PVR} to install"
+ elog
+ # webapp_pkg_postinst
+}