summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-02-19 00:59:56 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-02-19 00:59:56 +0000
commit316288c0a7da0856c7baf8d666d5e10695644beb (patch)
tree426a3a504a217863413fe262ccfcbf4efdc1b369 /www-apps/gitweb/gitweb-264.ebuild
parentInitial commit, thanks to Adrian Fruehwirth, bug #104024 (diff)
downloadhistorical-316288c0a7da0856c7baf8d666d5e10695644beb.tar.gz
historical-316288c0a7da0856c7baf8d666d5e10695644beb.tar.bz2
historical-316288c0a7da0856c7baf8d666d5e10695644beb.zip
Version bump, reported by Donnie Berkholz <spyderous@gentoo.org> on bug #123081
Package-Manager: portage-2.0.54
Diffstat (limited to 'www-apps/gitweb/gitweb-264.ebuild')
-rw-r--r--www-apps/gitweb/gitweb-264.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-apps/gitweb/gitweb-264.ebuild b/www-apps/gitweb/gitweb-264.ebuild
new file mode 100644
index 000000000000..ca5461e0ee9f
--- /dev/null
+++ b/www-apps/gitweb/gitweb-264.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/gitweb-264.ebuild,v 1.1 2006/02/19 00:59:55 ferdy Exp $
+
+inherit webapp
+
+DESCRIPTION="Web interface to GIT repositories"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+>=dev-util/git-1.1.6"
+
+src_install() {
+ webapp_src_preinst
+ dodoc README "${FILESDIR}/README.gentoo"
+ rm -f README
+
+ sed -i \
+ -e 's:^\(my $projectroot = *\).*$:\1"/var/git";:g' \
+ -e 's:indextext\.html:index/text.html:g' \
+ gitweb.cgi || die "sed failed"
+
+ chmod +x gitweb.cgi
+
+ cp gitweb.cgi ${D}${MY_HTDOCSDIR}
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+}