summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2012-12-23 13:31:32 +0000
committerMatti Bickel <mabi@gentoo.org>2012-12-23 13:31:32 +0000
commit123811060e865c1153d912cc423347ae7e9376e2 (patch)
tree24a8fcc03b76861c689e4ae9833e2daeb79af8c1 /www-apps/egroupware/egroupware-1.4.004.ebuild
parentadd explicit link to libfontconfig (covered by DEPEND libXft), already fixed ... (diff)
downloadhistorical-123811060e865c1153d912cc423347ae7e9376e2.tar.gz
historical-123811060e865c1153d912cc423347ae7e9376e2.tar.bz2
historical-123811060e865c1153d912cc423347ae7e9376e2.zip
remove old
Package-Manager: portage-2.2.0_alpha148/cvs/Linux x86_64
Diffstat (limited to 'www-apps/egroupware/egroupware-1.4.004.ebuild')
-rw-r--r--www-apps/egroupware/egroupware-1.4.004.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/www-apps/egroupware/egroupware-1.4.004.ebuild b/www-apps/egroupware/egroupware-1.4.004.ebuild
deleted file mode 100644
index fa2f83d075e8..000000000000
--- a/www-apps/egroupware/egroupware-1.4.004.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/egroupware/egroupware-1.4.004.ebuild,v 1.8 2012/10/06 16:55:20 armin76 Exp $
-
-inherit eutils webapp depend.php
-
-MY_PN=eGroupWare
-
-DESCRIPTION="Web-based GroupWare suite"
-HOMEPAGE="http://www.egroupware.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-2.tar.bz2
- mirror://sourceforge/${PN}/${MY_PN}-egw-pear-${PV}-2.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 hppa ppc ~sparc x86"
-IUSE="jpgraph ldap mssql mysql postgres"
-
-RDEPEND="jpgraph? ( dev-php/jpgraph )
- dev-php/PEAR-PEAR
- virtual/cron"
-
-need_httpd_cgi
-need_php_httpd
-
-S="${WORKDIR}"/${PN}
-
-pkg_setup () {
- webapp_pkg_setup
- has_php
-
- local php_flags="imap session unicode"
-
- for f in ldap mssql mysql postgres; do
- use ${f} && php_flags="${php_flags} ${f}"
- done
-
- if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags} || \
- ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
- die "Re-install ${PHP_PKG} with ${php_flags} and either gd or gd-external."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- esvn_clean
-
- if use jpgraph; then
- einfo "Fixing jpgraph location"
- sed -i "s|EGW_SERVER_ROOT . '/../jpgraph/src/jpgraph.php'|'/usr/share/php${PHP_VERSION}/jpgraph/jpgraph.php'|" \
- projectmanager/inc/class.ganttchart.inc.php || die
- sed -i "s|EGW_SERVER_ROOT . '/../jpgraph/src/jpgraph_gantt.php'|'/usr/share/php${PHP_VERSION}/jpgraph/jpgraph_gantt.php'|" \
- projectmanager/inc/class.ganttchart.inc.php || die
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- webapp_serverowned "${MY_HTDOCSDIR}"/phpgwapi/images
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en-1.2.txt
- webapp_src_install
-}
-
-pkg_postinst() {
- if use ldap; then
- elog "If you are using LDAP contacts/addressbook, please read the upgrade instructions at"
- elog "http://www.egroupware.org/index.php?page_name=wiki&wikipage=ManualSetupUpdate"
- elog "before running the egroupware setup"
- fi
- webapp_pkg_postinst
-}