summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-09-11 11:39:20 +0000
committerPeter Volkov <pva@gentoo.org>2011-09-11 11:39:20 +0000
commitca4b3512a781851be555d549f526efee7004185d (patch)
tree54594f4430991c18bcb1ab6059c41664e4dd47fd /www-apps/cgit/cgit-0.9.0.2-r1.ebuild
parentFix bash-completion test. Drop emacs USE flag (bug #382177); fix bash-complet... (diff)
downloadhistorical-ca4b3512a781851be555d549f526efee7004185d.tar.gz
historical-ca4b3512a781851be555d549f526efee7004185d.tar.bz2
historical-ca4b3512a781851be555d549f526efee7004185d.zip
Fix XSS vulnerability in rename hint, bug #378803, thank Nikoli for this job. Drop old.
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'www-apps/cgit/cgit-0.9.0.2-r1.ebuild')
-rw-r--r--www-apps/cgit/cgit-0.9.0.2-r1.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/www-apps/cgit/cgit-0.9.0.2-r1.ebuild b/www-apps/cgit/cgit-0.9.0.2-r1.ebuild
new file mode 100644
index 000000000000..9ecf4627a779
--- /dev/null
+++ b/www-apps/cgit/cgit-0.9.0.2-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/cgit-0.9.0.2-r1.ebuild,v 1.1 2011/09/11 11:39:20 pva Exp $
+
+EAPI="4"
+
+WEBAPP_MANUAL_SLOT="yes"
+
+inherit webapp eutils multilib
+
+[[ -z "${CGIT_CACHEDIR}" ]] && CGIT_CACHEDIR="/var/cache/${PN}/"
+
+GIT_V="1.7.4"
+
+DESCRIPTION="a fast web-interface for git repositories"
+HOMEPAGE="http://hjemli.net/git/cgit/about/"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_V}.tar.bz2
+ http://hjemli.net/git/cgit/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc highlight"
+
+RDEPEND="
+ dev-vcs/git
+ sys-libs/zlib
+ dev-libs/openssl
+ virtual/httpd-cgi
+ highlight? ( app-text/highlight )
+"
+# ebuilds without WEBAPP_MANUAL_SLOT="yes" are broken
+DEPEND="${RDEPEND}
+ !<www-apps/cgit-0.8.3.3
+ doc? ( app-text/docbook-xsl-stylesheets
+ >=app-text/asciidoc-8.5.1 )
+"
+
+pkg_setup() {
+ webapp_pkg_setup
+ enewuser "${PN}"
+}
+
+src_prepare() {
+ rmdir git || die
+ mv "${WORKDIR}"/git-"${GIT_V}" git || die
+
+ epatch "${FILESDIR}"/${P}-fix-xss.patch
+
+ sed -i \
+ -e "/^CACHE_ROOT =/s:/var/cache/cgit:${CGIT_CACHEDIR}:" \
+ Makefile || die
+}
+
+src_compile() {
+ emake
+ use doc && emake doc-man
+}
+
+src_install() {
+ webapp_src_preinst
+
+ emake \
+ prefix="${EPREFIX}"/usr \
+ libdir="${EPREFIX}"/usr/$(get_libdir) \
+ CGIT_SCRIPT_PATH="${MY_CGIBINDIR}" \
+ CGIT_DATA_PATH="${MY_HTDOCSDIR}" \
+ DESTDIR="${D}" install
+
+ insinto /etc
+ doins "${FILESDIR}"/cgitrc
+
+ dodoc README
+ use doc && doman cgitrc.5
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+
+ keepdir "${CGIT_CACHEDIR}"
+ fowners ${PN}:${PN} "${CGIT_CACHEDIR}"
+ fperms 700 "${CGIT_CACHEDIR}"
+}
+
+pkg_postinst() {
+ ewarn "If you intend to run cgit using web server's user"
+ ewarn "you should change ${CGIT_CACHEDIR} permissions."
+}