summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-02-02 23:34:49 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-02-02 23:34:49 +0000
commitb83ff5f5d9ece09823e5e702cd36e989e8f92d65 (patch)
treefddb8779e87358f9e1b4093d5ed996957242278d /www-apache/mod_caucho/mod_caucho-3.2.1.ebuild
parentVersion bump. (diff)
downloadhistorical-b83ff5f5d9ece09823e5e702cd36e989e8f92d65.tar.gz
historical-b83ff5f5d9ece09823e5e702cd36e989e8f92d65.tar.bz2
historical-b83ff5f5d9ece09823e5e702cd36e989e8f92d65.zip
Version bump.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'www-apache/mod_caucho/mod_caucho-3.2.1.ebuild')
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.2.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild b/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild
new file mode 100644
index 000000000000..448e5f1a4228
--- /dev/null
+++ b/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.2.1.ebuild,v 1.1 2009/02/02 23:34:49 nelchael Exp $
+
+inherit eutils apache-module autotools
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="mod_caucho connects Resin and Apache2."
+HOMEPAGE="http://www.caucho.com/"
+SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
+ mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/resin-${PV}"
+
+# See apache-module.eclass for more information.
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="CAUCHO"
+
+need_apache2
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd "${S}"
+
+ for i in "${WORKDIR}"/${PV}/mod_caucho-*; do
+ epatch "${i}"
+ done
+
+ eautoreconf
+ chmod 755 ./configure
+
+}
+
+src_compile() {
+
+ econf --with-apxs=${APXS} || die "econf failed"
+ emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
+
+}
+
+src_install() {
+
+ cd "${S}/modules/c/src/apache2"
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}/${APACHE2_MOD_CONF}.conf" \
+ || die "internal ebuild error: ${APACHE2_MOD_CONF}.conf not found."
+
+}