summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2006-01-23 22:50:57 +0000
committerTom William Payne <twp@gentoo.org>2006-01-23 22:50:57 +0000
commit5a3858e940e38b5b247b7b3db7e1085c3a93a66e (patch)
tree61d5de7b33a95958189f691cfbfa35516060ed66 /www-apache/anyterm
parentRemove kde-base/metadata.xml mask. I'm not going to ask how that got there... (diff)
downloadhistorical-5a3858e940e38b5b247b7b3db7e1085c3a93a66e.tar.gz
historical-5a3858e940e38b5b247b7b3db7e1085c3a93a66e.tar.bz2
historical-5a3858e940e38b5b247b7b3db7e1085c3a93a66e.zip
Initial version. Bug # 98647.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'www-apache/anyterm')
-rw-r--r--www-apache/anyterm/ChangeLog14
-rw-r--r--www-apache/anyterm/Manifest9
-rw-r--r--www-apache/anyterm/anyterm-1.1.8.ebuild116
-rw-r--r--www-apache/anyterm/files/50_anyterm.conf8
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch28
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-browser-gentoo.patch46
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-common-extern.patch26
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-libpbe-no-pg_config.patch14
-rw-r--r--www-apache/anyterm/files/digest-anyterm-1.1.81
-rw-r--r--www-apache/anyterm/metadata.xml9
10 files changed, 271 insertions, 0 deletions
diff --git a/www-apache/anyterm/ChangeLog b/www-apache/anyterm/ChangeLog
new file mode 100644
index 000000000000..5121c1ba7dc4
--- /dev/null
+++ b/www-apache/anyterm/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for www-apache/anyterm
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.1 2006/01/23 22:50:57 twp Exp $
+
+*anyterm-1.1.8 (23 Jan 2006)
+
+ 23 Jan 2006; Tom Payne <twp@gentoo.org>
+ +files/anyterm-1.1.8-browser-gentoo.patch, +files/50_anyterm.conf,
+ +files/anyterm-1.1.8-apachemod-Makefile.patch,
+ +files/anyterm-1.1.8-common-extern.patch,
+ +files/anyterm-1.1.8-libpbe-no-pg_config.patch, +metadata.xml,
+ +anyterm-1.1.8.ebuild:
+ Initial version. Bug # 98647.
+
diff --git a/www-apache/anyterm/Manifest b/www-apache/anyterm/Manifest
new file mode 100644
index 000000000000..cddad1851650
--- /dev/null
+++ b/www-apache/anyterm/Manifest
@@ -0,0 +1,9 @@
+MD5 d4e8766f940c0d288e02cc054986cb6b ChangeLog 563
+MD5 91d0f104a0fea60c7b0df039fed9f407 anyterm-1.1.8.ebuild 3175
+MD5 a14a3081dd3f5b6827bae63d13585320 files/50_anyterm.conf 199
+MD5 5a58f6af7f808560b821511c1e00261c files/anyterm-1.1.8-apachemod-Makefile.patch 891
+MD5 a4626c724a8899ab60417d02554fc3c3 files/anyterm-1.1.8-browser-gentoo.patch 1242
+MD5 edfc9bd9803d9fd760243cef69b00575 files/anyterm-1.1.8-common-extern.patch 655
+MD5 a6069c73dec076f0f2c69ea2cb4b55b8 files/anyterm-1.1.8-libpbe-no-pg_config.patch 432
+MD5 1fafa77a32bc461f15aae771d3d2ea70 files/digest-anyterm-1.1.8 62
+MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
diff --git a/www-apache/anyterm/anyterm-1.1.8.ebuild b/www-apache/anyterm/anyterm-1.1.8.ebuild
new file mode 100644
index 000000000000..281df52dbdaa
--- /dev/null
+++ b/www-apache/anyterm/anyterm-1.1.8.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.8.ebuild,v 1.1 2006/01/23 22:50:57 twp Exp $
+
+inherit apache-module eutils toolchain-funcs webapp
+
+DESCRIPTION="A terminal anywhere"
+HOMEPAGE="http://anyterm.org/"
+SRC_URI="http://anyterm.org/download/${P}.tbz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="pam ssl"
+DEPEND="
+ dev-libs/boost
+ >=dev-libs/rote-0.2.8
+ >=sys-devel/gcc-3
+ virtual/ssh
+ pam? ( net-www/mod_auth_pam )
+ "
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="ANYTERM"
+useq ssl && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} -D SSL"
+useq pam && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} -D AUTH_PAM"
+APACHE2_MOD_FILE="${S}/apachemod/.libs/anyterm.so"
+DOCFILES="CHANGELOG README"
+
+need_apache2
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/${APACHE2_MOD_CONF}.conf ${S} || die
+ epatch ${FILESDIR}/${P}-apachemod-Makefile.patch
+ epatch ${FILESDIR}/${P}-common-extern.patch
+ epatch ${FILESDIR}/${P}-browser-gentoo.patch
+
+ # The bundled libpbe causes lots of problems because it links to various
+ # assorted packages, without any checks. These packages may or not be
+ # installed. Here we disable all packages which are not required.
+ epatch ${FILESDIR}/${P}-libpbe-no-pg_config.patch
+ for f in Database Recoder jpegsize; do
+ rm ${S}/libpbe/src/${f}.{cc,hh}
+ done
+}
+
+src_compile() {
+ ( cd apachemod && emake CC=$(tc-getCC) CXX=$(tc-getCXX) ) || die
+}
+
+src_install() {
+ apache-module_src_install
+
+ webapp_src_preinst
+ cp browser/* browser/.htaccess ${D}/${MY_HTDOCSDIR}
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ apache-module_pkg_postinst
+
+ if ! built_with_use 'net-www/apache' ssl || ! use pam; then
+
+ if ! built_with_use 'net-www/apache' ssl; then
+ eerror "net-www/apache is missing SSL support."
+ fi
+
+ if ! use pam; then
+ eerror "PAM support disabled."
+ fi
+
+ eerror
+ eerror "For security reasons, the default Gentoo anyterm installation"
+ eerror "requires SSL and PAM. You will need to edit anyterm's"
+ eerror ".htaccess to suit your configuration."
+ eerror
+ eerror "For more information see:"
+ eerror "\thttp://anyterm.org/security.html"
+ eerror
+
+ sleep 5
+
+ else
+
+ eerror
+ eerror "The default Gentoo installation of Anyterm uses SSL and PAM for"
+ eerror "security. However, you will have to disable logging yourself,"
+ eerror "otherwise anyone who can read your log files (EVERYBODY by"
+ eerror "default!) can observe all the characters you send, including"
+ eerror "passwords!"
+ eerror
+ eerror "To do this, add"
+ eerror "\tenv=!DONTLOG"
+ eerror "to the CustomLog directive in"
+ eerror "\t/etc/apache2/modules.d/41_mod_ssl.default-vhost.conf"
+ eerror
+ eerror "If you are using a custom SSL virtual host configuration"
+ eerror "(i.e. you don't use -D SSL_DEFAULT_VHOST) then you will need"
+ eerror "to modify CustomLog directives elsewhere."
+ eerror
+ eerror "For more information see:"
+ eerror "\thttp://anyterm.org/security.html"
+ eerror
+
+ einfo
+ einfo "Anyterm is now installed at:"
+ einfo "\thttps://localhost/anyterm/anyterm.html"
+ einfo
+
+ sleep 5
+
+ fi
+}
diff --git a/www-apache/anyterm/files/50_anyterm.conf b/www-apache/anyterm/files/50_anyterm.conf
new file mode 100644
index 000000000000..f84d7d89be55
--- /dev/null
+++ b/www-apache/anyterm/files/50_anyterm.conf
@@ -0,0 +1,8 @@
+<IfDefine ANYTERM>
+ <IfModule !anyterm.c>
+ LoadModule anyterm modules/anyterm.so
+ </IfModule>
+ <Directory "/var/www/localhost/htdocs/anyterm/">
+ AllowOverride All
+ </Directory>
+</IfDefine>
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch b/www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch
new file mode 100644
index 000000000000..680d5f9c5975
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch
@@ -0,0 +1,28 @@
+--- anyterm-1.1.8/apachemod/Makefile 2005-10-31 22:20:05.000000000 +0100
++++ anyterm/apachemod/Makefile 2006-01-23 16:45:26.000000000 +0100
+@@ -60,10 +60,10 @@
+ cd $(COMMON_DIR); $(MAKE)
+
+ %.lo: %.cc
+- $(LIBTOOL) --mode=compile g++ $(CC_COMPILE_FLAGS) -o $@ -c $<
++ $(LIBTOOL) --mode=compile $(CXX) $(CC_COMPILE_FLAGS) -o $@ -c $<
+
+ %.lo: %.c
+- $(LIBTOOL) --mode=compile gcc $(C_COMPILE_FLAGS) -o $@ -c $<
++ $(LIBTOOL) --mode=compile $(CC) $(C_COMPILE_FLAGS) -o $@ -c $<
+
+
+ compile: $(OBJS) $(COMMON_LIB)
+@@ -73,10 +73,10 @@
+ $(APXS2) -n anyterm -i anyterm.la
+
+ %.d: %.cc
+- g++ -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
++ $(CXX) -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
+
+ %.d: %.c
+- gcc -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
++ $(CC) -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
+
+ DEPENDS=$(addsuffix .d,$(basename $(OBJS)))
+
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-browser-gentoo.patch b/www-apache/anyterm/files/anyterm-1.1.8-browser-gentoo.patch
new file mode 100644
index 000000000000..50c15538e3d7
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.8-browser-gentoo.patch
@@ -0,0 +1,46 @@
+diff -Naur anyterm-1.1.8/browser/.htaccess anyterm/browser/.htaccess
+--- anyterm-1.1.8/browser/.htaccess 2005-09-05 00:49:44.000000000 +0200
++++ anyterm/browser/.htaccess 2006-01-23 22:36:42.000000000 +0100
+@@ -7,6 +7,11 @@
+
+ <IfModule anyterm>
+
++# twp: To force Anyterm installations to be as secure as possible "out-of-the-
++# twp: box", we also require that both mod_ssl and mod_auth_pam are present.
++<IfModule mod_ssl.c>
++<IfModule mod_auth_pam.c>
++
+ # Use an anyterm_command directive to specify the command to run
+ # inside the terminal:
+ #
+@@ -24,6 +29,18 @@
+ # Example:
+ # anyterm_command '/path/to/anygetty --remotehost "Anyterm: %h" --autologin=%u'
+
++# twp: Use ssh to avoid problems with Gentoo's /bin/login.
++anyterm_command '/usr/bin/ssh %u@%h'
++
++# twp: Only provide Anyterm over SSL connections.
++SSLRequireSSL
++
++# twp: Require a valid user using mod_auth_pam.
++AuthPAM_Enabled on
++AuthType Basic
++AuthName "Anyterm"
++Require valid-user
++
+ <Files anyterm-module>
+ SetHandler anyterm
+
+@@ -34,7 +51,10 @@
+ # CustomLog /path/to/logfile combined env=!DONTLOG
+ # See the Apache documentation for details. Note "=!" not "!=" !
+
+- # SetEnv DONTLOG
++ SetEnv DONTLOG
+ </Files>
+
+ </IfModule>
++</IfModule>
++
++</IfModule>
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-common-extern.patch b/www-apache/anyterm/files/anyterm-1.1.8-common-extern.patch
new file mode 100644
index 000000000000..77705ead99ce
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.8-common-extern.patch
@@ -0,0 +1,26 @@
+diff -Naur anyterm-1.1.8/common/html.hh anyterm/common/html.hh
+--- anyterm-1.1.8/common/html.hh 2005-09-05 09:50:28.000000000 +0200
++++ anyterm/common/html.hh 2006-01-23 16:52:24.000000000 +0100
+@@ -31,7 +31,9 @@
+
+ #include <string>
+
++extern "C" {
+ #include <rote/rote.h>
++}
+
+ #include "Screen.hh"
+
+diff -Naur anyterm-1.1.8/common/Screen.hh anyterm/common/Screen.hh
+--- anyterm-1.1.8/common/Screen.hh 2005-09-03 15:27:05.000000000 +0200
++++ anyterm/common/Screen.hh 2006-01-23 16:52:35.000000000 +0100
+@@ -24,7 +24,9 @@
+ #define Screen_hh
+
+ #include <vector>
++extern "C" {
+ #include <rote/rote.h>
++}
+
+
+ class Screen: public std::vector<RoteCell> {
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-libpbe-no-pg_config.patch b/www-apache/anyterm/files/anyterm-1.1.8-libpbe-no-pg_config.patch
new file mode 100644
index 000000000000..47e1888b46ee
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.8-libpbe-no-pg_config.patch
@@ -0,0 +1,14 @@
+diff -Naur anyterm-1.1.8/libpbe/src/Makefile anyterm/libpbe/src/Makefile
+--- anyterm-1.1.8/libpbe/src/Makefile 2005-10-25 18:07:39.000000000 +0200
++++ anyterm/libpbe/src/Makefile 2006-01-23 16:46:56.000000000 +0100
+@@ -42,9 +42,7 @@
+
+ DEBUG_FLAGS=
+
+-PG_INC_FLAGS=-I$(shell pg_config --includedir)
+-
+-INC_FLAGS=$(PG_INC_FLAGS)
++INC_FLAGS=
+
+ COMPILE_FLAGS=$(WARN_FLAGS) $(OPTIMISE_FLAGS) $(DEBUG_FLAGS) $(INC_FLAGS) -D_REENTRANT
+
diff --git a/www-apache/anyterm/files/digest-anyterm-1.1.8 b/www-apache/anyterm/files/digest-anyterm-1.1.8
new file mode 100644
index 000000000000..5aa11d832d47
--- /dev/null
+++ b/www-apache/anyterm/files/digest-anyterm-1.1.8
@@ -0,0 +1 @@
+MD5 5ad8d6127680122e8f5c45f39093bd58 anyterm-1.1.8.tbz2 75137
diff --git a/www-apache/anyterm/metadata.xml b/www-apache/anyterm/metadata.xml
new file mode 100644
index 000000000000..d9bb4626fb2b
--- /dev/null
+++ b/www-apache/anyterm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>twp@gentoo.org</email>
+ <name>Tom Payne</name>
+</maintainer>
+</pkgmetadata>