summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 06:38:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 06:38:24 +0000
commit153ee2bfc3c1519fe6d0427ed3f15dd597b96381 (patch)
tree639b80bcf811899b3f2747213e92d414ca11fc30 /sys-process/iotop
parentold (diff)
downloadhistorical-153ee2bfc3c1519fe6d0427ed3f15dd597b96381.tar.gz
historical-153ee2bfc3c1519fe6d0427ed3f15dd597b96381.tar.bz2
historical-153ee2bfc3c1519fe6d0427ed3f15dd597b96381.zip
Fix pkg_setup().
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'sys-process/iotop')
-rw-r--r--sys-process/iotop/Manifest12
-rw-r--r--sys-process/iotop/iotop-0.4.1.ebuild11
2 files changed, 9 insertions, 14 deletions
diff --git a/sys-process/iotop/Manifest b/sys-process/iotop/Manifest
index 81c1f22ff228..e24cf8ea5753 100644
--- a/sys-process/iotop/Manifest
+++ b/sys-process/iotop/Manifest
@@ -1,16 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
DIST iotop-0.4.1.tar.bz2 26203 RMD160 72764912c5d9a4e49792df34e4791bcd70fc9f9a SHA1 63dacdefa2825a3a7db048e1deadf55054644d6c SHA256 940e97278b66d87c105e1138fcf589a4d1a1586a8a27bd29c53b8b0ce7e0dbb5
DIST iotop-0.4.tar.bz2 25490 RMD160 0863e67a7f1ae841127499ed7dba56deb045ca0c SHA1 cb4fc9f5e1f2156312ad2bfdb9734682c7bc6af1 SHA256 09d933234a0b574c79ae50a6746f27d1de3450d8e7a37511894b84cb00724701
-EBUILD iotop-0.4.1.ebuild 822 RMD160 aa0be627b10274124c868cc118d7dd81e793d0b3 SHA1 71e292f52dc1130eb34bc8ea4dc9cec88f991662 SHA256 33c1442dcc8bdcda2d369571ff4666efb9955616feb5ef11cb3fe474771ab651
+EBUILD iotop-0.4.1.ebuild 883 RMD160 7e859a278c9ba2ba04d030dff65fdc15ce45b0b8 SHA1 ed50914e62783af3e5194d5ef670963df0edac52 SHA256 2989ca3e8748844c03cfefeb4560e0bf4961b11871737186c9f61d3ec41a025a
EBUILD iotop-0.4.ebuild 788 RMD160 f2fc98290e7a7ecaf86f28bcbe5ed16199e15455 SHA1 c614e14d1a009980ea1c5148d2d57a93f36171e2 SHA256 af166da9b3b558d626e667052d54f6b53a60e9d5124bd5697d7f177dc5e0c5a2
MISC ChangeLog 4532 RMD160 366c404ec88f58c04c85dd9b3c25702cf83aa3b7 SHA1 6014ee8807c10cd2ede34f072689719ac5045f22 SHA256 c42c50726fbfe0f602fbf2096e74e0928e55ab92bf891f80b8c941acba16b404
MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.15 (GNU/Linux)
-
-iEYEARECAAYFAkwoQl8ACgkQgAnW8HDreRY0lACeIe3mcZ5KpJgX4zOMxzqSd47T
-UwUAoI3C56wBaN9NgqdUvd3P6sSi7oXp
-=HSZA
------END PGP SIGNATURE-----
diff --git a/sys-process/iotop/iotop-0.4.1.ebuild b/sys-process/iotop/iotop-0.4.1.ebuild
index b6b3b20980c8..a3fc796c75c3 100644
--- a/sys-process/iotop/iotop-0.4.1.ebuild
+++ b/sys-process/iotop/iotop-0.4.1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.4.1.ebuild,v 1.1 2010/06/28 06:34:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.4.1.ebuild,v 1.2 2010/06/28 06:38:24 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2:2.5"
PYTHON_USE_WITH="ncurses"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
inherit distutils linux-info
@@ -20,11 +21,15 @@ IUSE=""
DEPEND=""
RDEPEND=""
-RESTRICT_PYTHON_ABIS="2.4 3.*"
CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
DOCS="NEWS README THANKS"
+pkg_setup() {
+ linux-info_pkg_setup
+ python_pkg_setup
+}
+
src_install() {
distutils_src_install
doman iotop.1