summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-10-22 08:24:58 +0000
committerChristian Heim <phreak@gentoo.org>2006-10-22 08:24:58 +0000
commit8703dd287a14d346faf7b69dadd82aad284ba5d9 (patch)
tree28ef0eebce5d6448b46d892449577c79b9bb0647 /sys-power
parentFixed metadata.xml by changing the herd from jruby to java. (diff)
downloadhistorical-8703dd287a14d346faf7b69dadd82aad284ba5d9.tar.gz
historical-8703dd287a14d346faf7b69dadd82aad284ba5d9.tar.bz2
historical-8703dd287a14d346faf7b69dadd82aad284ba5d9.zip
Another revision bump, seems my initial intention (the one in #152096) wasn't that good. Reverting my changes. Furthermore, seems like I missed to add automake to the DEPEND, #152290 (thanks to t35t0r <t35t0r at gmail.com>).
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/cpufreqd/ChangeLog12
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild77
-rw-r--r--sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d19
-rw-r--r--sys-power/cpufreqd/files/digest-cpufreqd-2.2.0-r26
4 files changed, 107 insertions, 7 deletions
diff --git a/sys-power/cpufreqd/ChangeLog b/sys-power/cpufreqd/ChangeLog
index 5ad803ded240..8aa71c217d6a 100644
--- a/sys-power/cpufreqd/ChangeLog
+++ b/sys-power/cpufreqd/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-power/cpufreqd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.39 2006/10/20 19:47:34 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.40 2006/10/22 08:24:58 phreak Exp $
+
+*cpufreqd-2.2.0-r2 (22 Oct 2006)
+
+ 22 Oct 2006; Christian Heim <phreak@gentoo.org>
+ -files/cpufreqd-2.2.0-Makefile.am.patch, files/cpufreqd-2.2.0-init.d,
+ -cpufreqd-2.2.0-r1.ebuild, +cpufreqd-2.2.0-r2.ebuild:
+ Another revision bump, seems my initial intention (the one in #152096)
+ wasn't that good. Reverting my changes. Furthermore, seems like I missed to
+ add automake to the DEPEND, #152290 (thanks to t35t0r <t35t0r at
+ gmail.com>).
*cpufreqd-2.2.0-r1 (20 Oct 2006)
diff --git a/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild b/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..174df940e48c
--- /dev/null
+++ b/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.2.0-r2.ebuild,v 1.1 2006/10/22 08:24:58 phreak Exp $
+
+inherit eutils autotools
+
+NVCLOCK_VERSION="0.8b"
+
+DESCRIPTION="CPU Frequency Daemon"
+HOMEPAGE="http://cpufreqd.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ nvidia? ( http://www.linuxhardware.org/nvclock/nvclock${NVCLOCK_VERSION}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
+RDEPEND=">=sys-power/cpufrequtils-002
+ lm_sensors? ( sys-apps/lm_sensors )"
+DEPEND="sys-apps/sed
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:acpi_event:acpi:" "${S}"/cpufreqd.conf
+
+ if use nvidia; then
+ cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
+ epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fpic.patch
+ fi
+}
+
+src_compile() {
+ local config
+
+ if use nvidia; then
+ cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
+ econf \
+ --disable-gtk \
+ --disable-qt \
+ --disable-nvcontrol \
+ || die "econf nvclock failed"
+ emake -j1 || die "emake nvclock failed"
+ config="--enable-nvclock=${WORKDIR}/nvclock${NVCLOCK_VERSION}"
+ fi
+
+ cd "${S}"
+ econf \
+ $(use_enable acpi) \
+ $(use_enable apm) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nforce2) \
+ $(use_enable pmu) \
+ ${config} \
+ || die "econf failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ newinitd "${FILESDIR}"/${P}-init.d ${PN}
+}
+
+pkg_postinst() {
+ if [ -f "${ROOT}"/etc/conf.d/cpufreqd ] ; then
+ ewarn "Please make sure, you remove \"/etc/conf.d/cpufreqd\". It breaks"
+ ewarn "the init-script! (#152096)"
+ ewarn
+ ewarn "Use this if you don't know how to do it:"
+ ewarn "# rm /etc/conf.d/cpufreqd"
+ fi
+}
diff --git a/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d b/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d
index e3a5d83fdc96..51065fb40fad 100644
--- a/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d
+++ b/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d
@@ -1,9 +1,9 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d,v 1.2 2006/10/20 19:47:34 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/files/cpufreqd-2.2.0-init.d,v 1.3 2006/10/22 08:24:58 phreak Exp $
-CONFIGFILE=/etc/conf.d/cpufreqd
+CONFIGFILE=/etc/pufreqd.conf
depend() {
need localmount
@@ -16,10 +16,17 @@ checkconfig() {
return 1
fi
- if [[ ! -e /proc/cpufreq ]] && [[ ! -e /sys/devices/system/cpu/cpu0/cpufreq ]]; then
- eerror "cpufreqd requires the kernel to be configured with CONFIG_CPU_FREQ"
- eerror "Make sure that the appropiate drivers for your CPU are available."
- return 1
+ if [ ! -e /proc/cpufreq ] ; then
+ for cpu in /sys/devices/system/cpu/cpu[0-9]* ; do
+ n=${cpu##*/}
+ n=${n/cpu/}
+
+ if [ ! -e /sys/devices/system/cpu/cpu${n}/cpufreq ] ; then
+ eerror "cpufreqd requires the kernel to be configured with CONFIG_CPU_FREQ"
+ eerror "Make sure that the appropiate drivers for your CPU are available."
+ return 1
+ fi
+ done
fi
}
diff --git a/sys-power/cpufreqd/files/digest-cpufreqd-2.2.0-r2 b/sys-power/cpufreqd/files/digest-cpufreqd-2.2.0-r2
new file mode 100644
index 000000000000..928d8acc56d6
--- /dev/null
+++ b/sys-power/cpufreqd/files/digest-cpufreqd-2.2.0-r2
@@ -0,0 +1,6 @@
+MD5 a8916004d3fb75ed43822eb978c08fc5 cpufreqd-2.2.0.tar.bz2 292219
+RMD160 2e61db9bac593ae564e5103c80b4c49b9a85011c cpufreqd-2.2.0.tar.bz2 292219
+SHA256 13b857d23dff773965eb03a1531e6265627c328d5cc448ec4d446a7c54348d3b cpufreqd-2.2.0.tar.bz2 292219
+MD5 df36711124e08b3349692a8788755d14 nvclock0.8b.tar.gz 353127
+RMD160 66cac5993dc141d00efaa95d8f5ec38ed53854f6 nvclock0.8b.tar.gz 353127
+SHA256 a1fbdb82837c33869c0ebfcb95b6e11fc53b86919e8d1d17265d1af71eb04393 nvclock0.8b.tar.gz 353127