summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-15 06:04:29 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-15 06:04:29 +0000
commit46221ba9bb58525b874da9fb4424bd5022a76d17 (patch)
tree51110077fa7fe48da4de63073004f90733cdd0ce /sys-power/cpufrequtils/files
parentImport some code from vlc ebuilds to fix asm dependencies useflags. sse2 -> s... (diff)
downloadhistorical-46221ba9bb58525b874da9fb4424bd5022a76d17.tar.gz
historical-46221ba9bb58525b874da9fb4424bd5022a76d17.tar.bz2
historical-46221ba9bb58525b874da9fb4424bd5022a76d17.zip
old
Diffstat (limited to 'sys-power/cpufrequtils/files')
-rw-r--r--sys-power/cpufrequtils/files/cpufrequtils-002-parallel-make.patch12
-rw-r--r--sys-power/cpufrequtils/files/cpufrequtils-conf.d10
-rw-r--r--sys-power/cpufrequtils/files/cpufrequtils-init.d43
3 files changed, 0 insertions, 65 deletions
diff --git a/sys-power/cpufrequtils/files/cpufrequtils-002-parallel-make.patch b/sys-power/cpufrequtils/files/cpufrequtils-002-parallel-make.patch
deleted file mode 100644
index 5f92fa18e633..000000000000
--- a/sys-power/cpufrequtils/files/cpufrequtils-002-parallel-make.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urp cpufrequtils-002/Makefile cpufrequtils-002-parallel-make/Makefile
---- cpufrequtils-002/Makefile 2006-06-01 10:54:41.000000000 +0200
-+++ cpufrequtils-002-parallel-make/Makefile 2006-06-05 00:14:53.000000000 +0200
-@@ -189,7 +189,7 @@ libcpufreq.la: $(LIB_OBJS) $(LIB_HEADERS
-
- libcpufreq: libcpufreq.la
-
--cpufreq-%: $(UTIL_OBJS)
-+cpufreq-%: libcpufreq.la $(UTIL_OBJS)
- $(QUIET) $(CC) $(CFLAGDEF) $(CFLAGS) -g -I. -I./lib/ -c -o utils/$@.o utils/$*.c
- $(QUIET) $(CC) $(CFLAGDEF) $(CFLAGS) -g -I./lib/ -L. -L./.libs/ -lcpufreq -o $@ utils/$@.o
- $(QUIET) $(STRIPCMD) $@
diff --git a/sys-power/cpufrequtils/files/cpufrequtils-conf.d b/sys-power/cpufrequtils/files/cpufrequtils-conf.d
deleted file mode 100644
index 5d80a1f50ba1..000000000000
--- a/sys-power/cpufrequtils/files/cpufrequtils-conf.d
+++ /dev/null
@@ -1,10 +0,0 @@
-# /etc/conf.d/cpufrequtils: config file for /etc/init.d/cpufrequtils
-
-# Which governor to use. Must be one of the governors listed in:
-# cat /sys/devices/system/cpu/cpu?/cpufreq/scaling_available_governors
-#
-GOVERNOR="ondemand"
-
-# This Governor is used when cpufrequtils is stopped
-RESTORED_GOVERNOR=performance
-
diff --git a/sys-power/cpufrequtils/files/cpufrequtils-init.d b/sys-power/cpufrequtils/files/cpufrequtils-init.d
deleted file mode 100644
index 9dee536f66c8..000000000000
--- a/sys-power/cpufrequtils/files/cpufrequtils-init.d
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/files/cpufrequtils-init.d,v 1.3 2008/08/11 17:46:54 armin76 Exp $
-
-checkconfig() {
- if [ -z "${GOVERNOR}" ]; then
- eerror "No governor set in /etc/conf.d/cpufrequtils"
- return 1
- fi
- if [ -z "${RESTORED_GOVERNOR}" ]; then
- eerror "Set the RESTORED_GOVERNOR value in /etc/conf.d/cpufrequtils"
- return 1
- fi
-}
-
-
-affect_change() {
- if [ "$#" != "2" ]; then
- eerror "affect_change called in correctly, need two args, action, and governor"
- return 1
- fi
- local cpu n
-
- for cpu in /sys/devices/system/cpu/cpu[0-9]*; do
- n=${cpu##*cpu}
-
- ebegin "${1} ${2} cpufreq governor on CPU${n}"
- cpufreq-set -c ${n} -g "${2}"
- eend ${?}
- done
-}
-
-
-start() {
- checkconfig || return 1
- affect_change "Enabling" "${GOVERNOR}"
-}
-
-stop() {
- checkconfig || return 1
- affect_change "Enabling" "${RESTORED_GOVERNOR}"
-}