summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-01-15 01:41:20 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-01-15 01:41:20 +0000
commitb541c482b6c7f5989101166fda3f8a4cbbf61b7e (patch)
treead2c00747b07f3c5483ce771e6565da7c63e0aec /sys-libs
parentnew digest (diff)
downloadhistorical-b541c482b6c7f5989101166fda3f8a4cbbf61b7e.tar.gz
historical-b541c482b6c7f5989101166fda3f8a4cbbf61b7e.tar.bz2
historical-b541c482b6c7f5989101166fda3f8a4cbbf61b7e.zip
reload init
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog4
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r2.ebuild16
2 files changed, 17 insertions, 3 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 4f144deba1b2..6c18af56b230 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.37 2003/01/15 00:36:35 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.38 2003/01/15 01:41:20 azarah Exp $
15 Jan 2003; Martin Schlemmer <azarah@gentoo.org> glibc-2.3.1-r2.ebuild :
@@ -9,6 +9,8 @@
Add MIPS patches, thanks to <tuxus@gentoo.org> and <dragon@gentoo.org>.
+ Reload init to fix fsck on reboot ...
+
28 Dec 2002; Martin Schlemmer <azarah@gentoo.org> glibc-2.3.1-r3.ebuild :
Always add --with-headers=${ROOT}usr/include as option to ./configure, as
diff --git a/sys-libs/glibc/glibc-2.3.1-r2.ebuild b/sys-libs/glibc/glibc-2.3.1-r2.ebuild
index 69a12e8ae595..339fd6611ae2 100644
--- a/sys-libs/glibc/glibc-2.3.1-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r2.ebuild,v 1.15 2003/01/15 00:36:35 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r2.ebuild,v 1.16 2003/01/15 01:41:20 azarah Exp $
IUSE="nls pic build"
@@ -155,7 +155,7 @@ src_compile() {
# Thread Local Storage support. This dont really work as of yet...
# use x86 && use tls \
# && myconf="${myconf} --with-tls"
- myconf="${myconf} --without-tls"
+ myconf="${myconf} --without-tls --without-__thread"
if [ "`uname -r | cut -d. -f2`" -ge "4" ]
then
@@ -263,5 +263,17 @@ pkg_postinst() {
rm -f ${ROOT}/etc/localtime
ln -s ../usr/share/zoneinfo/Factory ${ROOT}/etc/localtime
fi
+
+ # Generate fastloading iconv module configuration file.
+ if [ -x ${ROOT}/usr/sbin/iconvconfig ]
+ then
+ ${ROOT}/usr/sbin/iconvconfig --prefix=${ROOT}
+ fi
+
+ # Reload init ...
+ if [ "${ROOT}" = "/" ]
+ then
+ /sbin/init U &> /dev/null
+ fi
}