summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-05-24 11:48:14 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-05-24 11:48:14 +0000
commitb0875ec64fe07873f99b69ca68a57a0d3fb9cda9 (patch)
treee49f659ed42735f42cecff94a5f3083a5ce39216 /sys-libs
parentThe db ebuilds now should allow for db4 existing next to db3 (diff)
downloadhistorical-b0875ec64fe07873f99b69ca68a57a0d3fb9cda9.tar.gz
historical-b0875ec64fe07873f99b69ca68a57a0d3fb9cda9.tar.bz2
historical-b0875ec64fe07873f99b69ca68a57a0d3fb9cda9.zip
The db ebuilds now should allow for db4 existing next to db3
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/Manifest9
-rw-r--r--sys-libs/db/db-3.2.9-r5.ebuild156
-rw-r--r--sys-libs/db/db-4.0.14.ebuild29
-rw-r--r--sys-libs/db/db-4.1.24.ebuild28
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r51
5 files changed, 215 insertions, 8 deletions
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index 18ced7b4f1a9..a75ec667e4c2 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -1,14 +1,13 @@
-MD5 8e1e52e3784b00cd29677ebe266dc198 ChangeLog 4183
+MD5 06ae7922aa8825ca0844b604d0217ffc ChangeLog 4563
MD5 4e148693b2d6fe0b1e66a8724cbfc20c db-1.85-r1.ebuild 1411
MD5 744542679cd64194e3ac9e84e5f7056e db-3.2.3h-r4.ebuild 2455
MD5 4be311009c1216a911e76dcf33bb568d db-3.2.9-r1.ebuild 2587
MD5 e03298e927335414c7db1882f24ed8e4 db-3.2.9-r2.ebuild 3221
MD5 af7ea3ee5a3a001d516413c0b9bc52e5 db-3.2.9.ebuild 2464
MD5 2dd3cac46936c5510bf2133977ff5a48 db-3.3.11.ebuild 2408
-MD5 44cc5b9e56f3d42f2de9a5a0b140860c db-4.1.24.ebuild 1755
-MD5 e8c3c674282d356fa1da1400002f4ca4 db-4.0.14.ebuild 1904
-MD5 29658187ae92e1ab85d87fd21c629790 db-3.2.9-r5.ebuild 3786
-MD5 58fcf7338e65e0bc372c67256d3d200c db-3.2.9-r5.ebuild~ 3561
+MD5 632b7c2f6a5da4d0064202b9644bf05f db-4.1.24.ebuild 1756
+MD5 1f899d49fe0de735847c6c0016174745 db-4.0.14.ebuild 1904
+MD5 bd4838773fc92042828e59d812c59bea db-3.2.9-r5.ebuild 3914
MD5 194200b3295b95b46b4564980af27f1f files/db-3.2.9-fix-dep-link.patch 1005
MD5 ecd81fa9868ec49c61306444144d44a9 files/db.1.85.patch 55584
MD5 3057fcc117c33a02bd4c092586a58e49 files/digest-db-1.85-r1 59
diff --git a/sys-libs/db/db-3.2.9-r5.ebuild b/sys-libs/db/db-3.2.9-r5.ebuild
new file mode 100644
index 000000000000..414a3bc42598
--- /dev/null
+++ b/sys-libs/db/db-3.2.9-r5.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r5.ebuild,v 1.1 2003/05/24 11:48:05 pauldv Exp $
+
+IUSE=""
+
+inherit libtool
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com/"
+
+SLOT="3"
+LICENSE="DB"
+# This ebuild is to be the compatibility ebuild for when db4 is put
+# in the tree.
+KEYWORDS="-x86 -ppc -sparc -alpha -mips -hppa -arm"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ =sys-libs/db-1.85-r1
+ sys-devel/libtool
+ sys-devel/m4"
+# We need m4 too else build fails without config.guess
+
+# This doesn't build without exceptions
+export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
+src_unpack() {
+ unpack ${A}
+
+ chmod -R ug+w *
+
+ cd ${WORKDIR}/${P}
+ epatch ${FILESDIR}/patch.3.2.9.1
+ epatch ${FILESDIR}/patch.3.2.9.2
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ epatch ${FILESDIR}/${P}-fix-dep-link.patch
+
+ # We should get dump185 to link against system db1 ..
+ # <azarah@gentoo.org> (23 Feb 2003)
+ mv ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
+ sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
+ -e 's:DB185LIB=:DB185LIB= -ldb1:' \
+ ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in || die "Failed to sed"
+
+ # Fix invalid .la files
+ cd ${WORKDIR}/${P}/dist
+ rm -f ltversion.sh
+ # remove config.guess else we have problems with gcc-3.2
+ rm -f config.guess
+}
+
+src_compile() {
+ local conf=
+
+ conf="--host=${CHOST} \
+ --build=${CHOST} \
+ --enable-cxx \
+ --enable-compat185 \
+ --enable-dump185 \
+ --prefix=/usr"
+ # --enable-rpc aparently does not work .. should verify this
+ # at some stage ...
+
+ # NOTE: we should not build both shared and static versions
+ # of the libraries in the same build root!
+
+ einfo "Configuring ${P} (static)..."
+ mkdir -p ${S}/build-static
+ cd ${S}/build-static
+ ../dist/configure ${conf} \
+ --enable-static || die
+
+ einfo "Configuring ${P} (shared)..."
+ mkdir -p ${S}/build-shared
+ cd ${S}/build-shared
+ ../dist/configure ${conf} \
+ --enable-shared || die
+
+ # Parallel make does not work
+ MAKEOPTS="${MAKEOPTS} -j1"
+ einfo "Building ${P} (static)..."
+ cd ${S}/build-static
+ emake || die "Static build failed"
+ einfo "Building ${P} (shared)..."
+ cd ${S}/build-shared
+ emake || die "Shared build failed"
+}
+
+src_install () {
+ cd ${S}/build-shared
+ make libdb=libdb-3.2.a \
+ libcxx=libcxx_3.2.a \
+ prefix=${D}/usr \
+ install || die
+
+ cd ${S}/build-static
+ dolib.a libdb-3.2.a libdb_cxx-3.2.a
+
+ dodir usr/include/db3
+ cd ${D}/usr/include
+ mv *.h db3
+ ln db3/db.h db.h
+
+ cd ${D}/usr/lib
+ ln -s libdb-3.2.so libdb.so.3
+
+ # For some reason, db.so's are *not* readable by group or others,
+ # resulting in no one but root being able to use them!!!
+ # This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/lib
+ chmod go+rx *.so
+ # The .la's aren't readable either
+ chmod go+r *.la
+
+ cd ${S}
+ dodoc README LICENSE
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html
+ rm -rf ${D}/usr/docs
+
+ #making things work better with the db4 ebuild
+ for fname in ${D}/usr/bin/db_*
+ do
+ mv ${fname} ${fname//\/db_/\/db4_}
+ done
+ rm ${D}/usr/include/db.h
+}
+
+fix_so () {
+ cd /usr/lib
+ target=`find -type f -maxdepth 1 -name "libdb-*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb.so
+ target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
+ target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ cd -
+}
+
+pkg_postinst () {
+ fix_so
+}
+
+pkg_postrm () {
+ fix_so
+}
+
diff --git a/sys-libs/db/db-4.0.14.ebuild b/sys-libs/db/db-4.0.14.ebuild
index 88857327de70..28ea7d9c99a9 100644
--- a/sys-libs/db/db-4.0.14.ebuild
+++ b/sys-libs/db/db-4.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.14 2003/05/24 08:35:24 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.15 2003/05/24 11:48:05 pauldv Exp $
IUSE="tcltk java"
@@ -50,7 +50,32 @@ src_compile() {
src_install () {
einstall || die
-
+ for fname in ${D}/usr/bin/db_*
+ do
+ mv ${fname} ${fname//\/db_/\/db4_}
+ done
+
+ dodir /usr/include/db4
+ mv ${D}/usr/include/*.h ${D}/usr/include/db4/
+
dodir /usr/share/doc/${PF}/html
mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/
}
+
+fix_so () {
+ cd /usr/lib
+ target=`find -type f -maxdepth 1 -name "libdb-*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb.so
+ target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
+ target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+}
+
+pkg_postinst () {
+ fix_so
+}
+
+pkg_postrm () {
+ fix_so
+}
diff --git a/sys-libs/db/db-4.1.24.ebuild b/sys-libs/db/db-4.1.24.ebuild
index 41e0e07c58d0..93f2e23c556b 100644
--- a/sys-libs/db/db-4.1.24.ebuild
+++ b/sys-libs/db/db-4.1.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.9 2003/05/24 08:35:24 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.10 2003/05/24 11:48:05 pauldv Exp $
IUSE="tcltk java"
@@ -45,7 +45,33 @@ src_compile() {
src_install () {
einstall || die
+ for fname in ${D}/usr/bin/db_*
+ do
+ mv ${fname} ${fname//\/db_/\/db4_}
+ done
+
+ dodir /usr/include/db4
+ mv ${D}/usr/include/*.h ${D}/usr/include/db4/
dodir /usr/share/doc/${PF}/html
mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/
}
+
+fix_so () {
+ cd /usr/lib
+ target=`find -type f -maxdepth 1 -name "libdb-*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb.so
+ target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
+ target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
+ [ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ cd -
+}
+
+pkg_postinst () {
+ fix_so
+}
+
+pkg_postrm () {
+ fix_so
+}
diff --git a/sys-libs/db/files/digest-db-3.2.9-r5 b/sys-libs/db/files/digest-db-3.2.9-r5
new file mode 100644
index 000000000000..cc0f167ea09b
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.2.9-r5
@@ -0,0 +1 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238