summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-15 19:45:35 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-15 19:45:35 +0000
commit38e453299559238f1e394e2792a9715506b236fa (patch)
treeba310d527b3cfef9166003e9378e9722df247e49 /sys-libs
parentBumped to newest version. (diff)
downloadhistorical-38e453299559238f1e394e2792a9715506b236fa.tar.gz
historical-38e453299559238f1e394e2792a9715506b236fa.tar.bz2
historical-38e453299559238f1e394e2792a9715506b236fa.zip
cleaned up 3.3.11
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog16
-rw-r--r--sys-libs/db/db-3.3.11.ebuild93
2 files changed, 86 insertions, 23 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index f759b25f3fb0..0b11fcec0cca 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for sys-libs/db
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.13 2002/11/15 01:30:06 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.14 2002/11/15 19:45:35 seemant Exp $
-db-4.1.24 (08 Oct 2002)
+*db-3.3.11 (16 Nov 2002)
+
+ 16 Nov 2002; Seemant Kulleen <seemant@gentoo.org> db-3.3.11.ebuild :
+
+ Made this install similar to db-3.2.9 which should make this version more
+ usable. Still masked. Closes bug #9900 by l_calamandrei@neri-group.com
+ (Lapo Calamandrei)
+
+*db-4.1.24 (08 Oct 2002)
14 Nov 2002; Seemant Kulleen <seemant@gentoo.org> db-4.1.24.ebuild :
@@ -22,7 +30,7 @@ db-4.1.24 (08 Oct 2002)
version bump.. has new crypto support
-db-3.2.9-r1 (28 Jul 2002)
+*db-3.2.9-r1 (28 Jul 2002)
22 Oct 2002; Seemant Kulleen <seemant@gentoo.org> : db-3.2.9-r1.ebuild :
@@ -33,7 +41,7 @@ db-3.2.9-r1 (28 Jul 2002)
Update to get it working with gcc-3.2 (remove config.guess), as well
as cleanups.
-db-3.2.9 (25 Jul 2002)
+*db-3.2.9 (25 Jul 2002)
25 Jul 2002; Spider <spider@gentoo.org> :
Add a fix to remove -fno-exceptions in CXXFLAGS as it doesnt build then
diff --git a/sys-libs/db/db-3.3.11.ebuild b/sys-libs/db/db-3.3.11.ebuild
index 2b068bca3d62..cc8e4a44e6a5 100644
--- a/sys-libs/db/db-3.3.11.ebuild
+++ b/sys-libs/db/db-3.3.11.ebuild
@@ -1,37 +1,92 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.3.11.ebuild,v 1.10 2002/11/14 09:03:33 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.3.11.ebuild,v 1.11 2002/11/15 19:45:35 seemant Exp $
-S=${WORKDIR}/${P}
+S=${WORKDIR}/${P}/build_unix
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com/"
-DESCRIPTION="Berkeley DB"
-
-SRC_URI="http://www.sleepycat.com/update/3.3.11/db-3.3.11.tar.gz"
-
-HOMEPAGE="http://www.sleepycat.com"
SLOT="3"
LICENSE="DB"
-KEYWORDS="-x86 -ppc -sparc -sparc64"
+KEYWORDS="-x86 -ppc -sparc -sparc64 -alpha"
-DEPEND="virtual/glibc"
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ =sys-libs/db-1.85-r1
+ sys-devel/libtool
+ sys-devel/m4"
+# We need m4 to else build fails without config.guess
-src_compile() {
+# this doesnt build without exceptions
+export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
- cd dist
+src_unpack() {
+ unpack ${A}
- ./configure \
- --host=${CHOST} \
+ # fix invalid .la files
+ cd ${WORKDIR}/${P}/dist
+ rm -f ltversion.sh
+ cp ${ROOT}/usr/share/libtool/ltmain.sh . || \
+ die "Could not update ltmain.sh"
+ # remove config.guess else we have problems with gcc-3.2
+ rm -f config.guess
+}
+
+src_compile() {
+ ../dist/configure --host=${CHOST} \
+ --build=${CHOST} \
+ --enable-compat185 \
+ --enable-dump185 \
--prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die
- emake || die
+ --enable-shared \
+ --enable-static \
+ --enable-cxx || die
+
+ #--enable-rpc does not work
+ echo
+ # Parallel make does not work
+ einfo "Building static libs..."
+ make libdb=libdb-3.2.a libdb-3.2.a || die
+ make libcxx=libdb_cxx-3.2.a libdb_cxx-3.2.a || die
+ echo
+ einfo "Building db_dump185..."
+ /bin/sh ./libtool --mode=compile cc -c ${CFLAGS} -D_GNU_SOURCE \
+ -I/usr/include/db1 -I../dist/../include -D_REENTRANT \
+ ../dist/../db_dump185/db_dump185.c || die
+ gcc -s -static -o db_dump185 db_dump185.lo -L/usr/lib -ldb1 || die
+ echo
+ einfo "Building everything else..."
+ make libdb=libdb-3.2.a libcxx=libdb_cxx-3.2.a || die
}
src_install () {
- cd dist
+ make libdb=libdb-3.2.a \
+ libcxx=libcxx_3.2.a \
+ prefix=${D}/usr \
+ install || die
+
+ dolib.a libdb-3.2.a libdb_cxx-3.2.a
+
+ dodir usr/include/db3
+ cd ${D}/usr/include
+ mv *.h db3
+ ln db3/db.h db.h
+
+ cd ${D}/usr/lib
+ ln -s libdb-3.2.so libdb.so.3
- make prefix=${D}/usr install || die
+ #for some reason, db.so's are *not* readable by group or others, resulting in no one
+ #but root being able to use them!!! This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/lib
+ chmod go+rx *.so
+ #.la's aren't go readable either
+ chmod go+r *.la
+ cd ${S}/..
+ dodoc README LICENSE
+
dodir /usr/share/doc/${PF}/html
- mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/
+ mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html
+ rm -rf ${D}/usr/docs
}