summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2003-01-16 09:11:50 +0000
committerMichael Nazaroff <naz@gentoo.org>2003-01-16 09:11:50 +0000
commit2422983cd5ec02e3daccdfa74ea19330c6e40a83 (patch)
tree587be4f7a0b4ee6a3994d19faa5875798fcb3e46 /sys-libs
parentMarked stable. (diff)
downloadhistorical-2422983cd5ec02e3daccdfa74ea19330c6e40a83.tar.gz
historical-2422983cd5ec02e3daccdfa74ea19330c6e40a83.tar.bz2
historical-2422983cd5ec02e3daccdfa74ea19330c6e40a83.zip
Fixed gpm logging issue's
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gpm/files/digest-gpm-1.20.0-r63
-rw-r--r--sys-libs/gpm/gpm-1.20.0-r6.ebuild67
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-libs/gpm/files/digest-gpm-1.20.0-r6 b/sys-libs/gpm/files/digest-gpm-1.20.0-r6
new file mode 100644
index 000000000000..48c0817fada3
--- /dev/null
+++ b/sys-libs/gpm/files/digest-gpm-1.20.0-r6
@@ -0,0 +1,3 @@
+MD5 ab33423219cfef97fce158af48d3ad8c gpm-1.20.0.tar.bz2 390987
+MD5 efed498fca612e0d08824f26fad1d2d3 gpm-1.20.1-patch.tar.bz2 5171
+MD5 e2d25c3fae114b5c0ac7583134a3b2b6 gpm-1.20.1-log-fillup.patch.tar.bz2 12777
diff --git a/sys-libs/gpm/gpm-1.20.0-r6.ebuild b/sys-libs/gpm/gpm-1.20.0-r6.ebuild
new file mode 100644
index 000000000000..5331bd813f0b
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.20.0-r6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.0-r6.ebuild,v 1.1 2003/01/16 09:11:50 naz Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Console-based mouse driver"
+SRC_URI="ftp://arcana.linux.it/pub/gpm/gpm-1.20.0.tar.bz2
+ http://www.ibiblio.org/gentoo/distfiles/gpm-1.20.1-patch.tar.bz2
+ http://www.ibiblio.org/gentoo/distfiles/gpm-1.20.1-log-fillup.patch.tar.bz2"
+HOMEPAGE="ftp://arcana.linux.it/pub/gpm/"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ sys-devel/autoconf"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+src_unpack() {
+ unpack ${A}
+
+ # This little hack turns off EMACS byte compilation. We really
+ # don't want this thing auto-detecting emacs.
+ cd ${S}; epatch ${WORKDIR}/gpm.patch
+ cd ${S}; epatch ${WORKDIR}/gpm-log-fillup.patch
+
+ # Add missing 'mkinstalldirs' script
+ cp -f /usr/share/automake/mkinstalldirs ${S}
+}
+
+src_compile() {
+ econf --sysconfdir=/etc/gpm || die
+
+ # Do not create gpmdoc.ps, as it cause build to fail with our version
+ # of tetex (it is already there, so this will only create missing
+ # manpages)
+ cp doc/Makefile doc/Makefile.orig
+ sed -e 's:all\: $(srcdir)/gpmdoc.ps:all\::' \
+ doc/Makefile.orig > doc/Makefile
+
+ MAKEOPTS="-j1" emake || die
+}
+
+src_install() {
+ einstall
+
+ chmod 755 ${D}/usr/lib/*
+ # Fix missing /usr/lib/libgpm.so.1
+ preplib
+
+ dodoc BUGS COPYING ChangeLog Changes MANIFEST README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+ doinfo doc/gpm.info
+
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/gpm.rc6 gpm
+ insinto /etc/conf.d
+ newins ${FILESDIR}/gpm.conf.d gpm
+}
+