summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-29 21:05:49 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-29 21:05:49 +0000
commit1a5d8bb74336977974881156c98b8c46647cd272 (patch)
tree88e45a2d37b0027320fe57d62ee35dfacdf6a5a8 /sys-libs
parentdisable nptl checks for headers-only builds (diff)
downloadhistorical-1a5d8bb74336977974881156c98b8c46647cd272.tar.gz
historical-1a5d8bb74336977974881156c98b8c46647cd272.tar.bz2
historical-1a5d8bb74336977974881156c98b8c46647cd272.zip
Force compiler tests when building only headers #229391.
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.27.4 x86_64
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/files/eblits/src_compile.eblit8
2 files changed, 12 insertions, 2 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index b9f4c1da2a0d..b813d422a98e 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.592 2008/10/27 03:02:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.593 2008/11/29 21:05:49 vapier Exp $
+
+ 29 Nov 2008; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_compile.eblit:
+ Force compiler tests when building only headers #229391.
27 Oct 2008; Mike Frysinger <vapier@gentoo.org>
glibc-2.8_p20080602.ebuild:
diff --git a/sys-libs/glibc/files/eblits/src_compile.eblit b/sys-libs/glibc/files/eblits/src_compile.eblit
index 06684dfe7985..c7ce858acd30 100644
--- a/sys-libs/glibc/files/eblits/src_compile.eblit
+++ b/sys-libs/glibc/files/eblits/src_compile.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.5 2008/06/23 22:01:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.6 2008/11/29 21:05:49 vapier Exp $
glibc_do_configure() {
local myconf
@@ -128,6 +128,12 @@ toolchain-glibc_headers_compile() {
mkdir -p "${GBUILDDIR}"
cd "${GBUILDDIR}"
+ # if we don't have a compiler yet, we cant really test it now
+ export \
+ libc_cv_mlong_double_128=yes \
+ libc_cv_mlong_double_128ibm=yes \
+ libc_cv_ppc_machine=yes
+
# Pick out the correct location for build headers
local ports="" myconf="--disable-sanity-checks --enable-hacker-mode"
[[ -d ${S}/ports ]] && ports=",ports"