summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-12-14 14:22:12 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-12-14 14:22:12 +0000
commit15549c729337eb45760bfb33a6ffd4120297bb95 (patch)
tree4c09814880409d847c0721ecd730fa48284d525f /sys-libs
parentUpdate snapshot to 20031212, pre-release of 2.3.3. (diff)
downloadhistorical-15549c729337eb45760bfb33a6ffd4120297bb95.tar.gz
historical-15549c729337eb45760bfb33a6ffd4120297bb95.tar.bz2
historical-15549c729337eb45760bfb33a6ffd4120297bb95.zip
Update snapshot to 20031212, pre-release of 2.3.3.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest6
-rw-r--r--sys-libs/glibc/files/2.3.3/glibc-2.3.3-dl_execstack-PaX-support.patch70
-rw-r--r--sys-libs/glibc/files/digest-glibc-2.3.3_pre200312124
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20031212.ebuild634
4 files changed, 711 insertions, 3 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 62b50184ae92..ba9f43f7c6f3 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -1,14 +1,13 @@
MD5 2d20c306db480448c6f63e56b5982b79 glibc-2.3.2-r2.ebuild 17907
-MD5 e280dc5de098f11a4ec1c2d4a1f2bfcc .glibc-2.3.3_pre20031212.ebuild.swp 45056
MD5 4762cd7d1608529c8e8d3aca4e9e2ca2 glibc-2.3.2-r7.ebuild 17581
MD5 0ce5e5123c594c7f11a24d3ccf217e7b glibc-2.3.2-r3.ebuild 17342
MD5 4dd6a7760b1e06c798d72a1f22d49729 glibc-2.3.1-r5.ebuild 10876
-MD5 6d9d2d116b06c2946b16d318871c86f6 ChangeLog 23464
+MD5 4273a19b186792c5b2e6523f09168fd3 ChangeLog 23702
MD5 37a80c1e7123b26e6b8b84f9931b21c0 glibc-2.3.2-r8.ebuild 17087
MD5 354af62a75accecb67826891dae32a18 glibc-2.3.2-r9.ebuild 18432
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 8ed2bf1fdf0fa74a7a40ac1bbf9b1786 glibc-2.2.5-r9.ebuild 10003
-MD5 9e57fc51e35e476d9ab02db796b172f6 glibc-2.3.3_pre20031212.ebuild 18412
+MD5 8ee5fcb40540ca380be872af70bed2bd glibc-2.3.3_pre20031212.ebuild 18421
MD5 2013443f5192d4b999953ba4248d288c files/nscd.conf 1158
MD5 98ea363167dacaaad23fd9a66ba98d5b files/nscd 844
MD5 184eddb92615fb991dce41b9edbfa690 files/glibc-manpages-2.3.2.tar.bz2 14700
@@ -97,3 +96,4 @@ MD5 c34a3c6bf21274a506090f05b7ea60ff files/2.2.5/glibc-2.2.5-ppc-sqrtl.diff 715
MD5 a50da56218f9aabc347d7e1130961cec files/2.2.5/glibc-2.2.5.divbyzero.patch 1694
MD5 993732f56fdecf36f672198112fc5d5c files/2.2.5/glibc-2.2.5-threadsig.diff 636
MD5 56a7a0273e0666eb40b0c6b45d62881d files/2.2.5/glibc-2.2.5-arm-sysdeps-fix.diff 362
+MD5 1b5df7c58ad160593192704cece47347 files/2.3.3/glibc-2.3.3-dl_execstack-PaX-support.patch 1791
diff --git a/sys-libs/glibc/files/2.3.3/glibc-2.3.3-dl_execstack-PaX-support.patch b/sys-libs/glibc/files/2.3.3/glibc-2.3.3-dl_execstack-PaX-support.patch
new file mode 100644
index 000000000000..55188bd21d85
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.3/glibc-2.3.3-dl_execstack-PaX-support.patch
@@ -0,0 +1,70 @@
+--- glibc-2.3.3/sysdeps/unix/sysv/linux/dl-execstack.c 2003-12-13 15:42:16.853396224 +0200
++++ glibc-2.3.3.PaX/sysdeps/unix/sysv/linux/dl-execstack.c 2003-12-13 15:42:25.290113648 +0200
+@@ -47,11 +47,17 @@
+ PROT_READ|PROT_WRITE|PROT_EXEC|PROT_GROWSDOWN) == 0)
+ goto return_success;
+ # if __ASSUME_PROT_GROWSUPDOWN == 0
+- if (errno == EINVAL)
++ if (errno == EINVAL) {
+ no_growsdown = true;
+- else
++ } else {
++# endif
++ if (errno == EACCES) /* PAX is enabled */
++ return 0;
++ else
++ return errno;
++# if __ASSUME_PROT_GROWSUPDOWN == 0
++ }
+ # endif
+- return errno;
+ }
+ # endif
+
+@@ -73,8 +79,11 @@
+ page -= size;
+ else
+ {
+- if (errno != ENOMEM) /* Unexpected failure mode. */
++ if (errno == EACCES) { /* PAX is enabled */
++ return 0;
++ } else if (errno != ENOMEM) { /* Unexpected failure mode. */
+ return errno;
++ }
+
+ if (size == GL(dl_pagesize))
+ /* We just tried to mprotect the top hole page and failed.
+@@ -105,11 +114,17 @@
+ PROT_READ|PROT_WRITE|PROT_EXEC|PROT_GROWSUP) == 0)
+ goto return_success;
+ # if __ASSUME_PROT_GROWSUPDOWN == 0
+- if (errno == EINVAL)
++ if (errno == EINVAL) {
+ no_growsup = true;
+- else
++ } else {
++# endif
++ if (errno == EACCES) /* PAX is enabled */
++ return 0;
++ else
++ return errno;
++# if __ASSUME_PROT_GROWSUPDOWN == 0
++ }
+ # endif
+- return errno;
+ }
+ # endif
+
+@@ -130,8 +145,11 @@
+ page += size;
+ else
+ {
+- if (errno != ENOMEM) /* Unexpected failure mode. */
++ if (errno == EACCES) { /* PAX is enabled */
++ return 0;
++ } else if (errno != ENOMEM) { /* Unexpected failure mode. */
+ return errno;
++ }
+
+ if (size == GL(dl_pagesize))
+ /* We just tried to mprotect the lowest hole page and failed.
diff --git a/sys-libs/glibc/files/digest-glibc-2.3.3_pre20031212 b/sys-libs/glibc/files/digest-glibc-2.3.3_pre20031212
new file mode 100644
index 000000000000..628e4d2e5c72
--- /dev/null
+++ b/sys-libs/glibc/files/digest-glibc-2.3.3_pre20031212
@@ -0,0 +1,4 @@
+MD5 ede969aad568f48083e413384f20753c glibc-2.3.2.tar.bz2 13377170
+MD5 894b8969cfbdf787c73e139782167607 glibc-linuxthreads-2.3.2.tar.bz2 216310
+MD5 1e6598f9590b72d8be041efc336de75e glibc-2.3.3-branch-update-20031212.patch.bz2 1920718
+MD5 c7c27c0821245d98a0568a475c08f4e9 glibc-2.3.2-hppa-patches-p1.tar.bz2 18793
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20031212.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20031212.ebuild
new file mode 100644
index 000000000000..6173990c4b2c
--- /dev/null
+++ b/sys-libs/glibc/glibc-2.3.3_pre20031212.ebuild
@@ -0,0 +1,634 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20031212.ebuild,v 1.1 2003/12/14 14:22:02 azarah Exp $
+
+IUSE="nls pic build nptl"
+
+inherit eutils flag-o-matic gcc
+
+filter-flags "-fomit-frame-pointer -malign-double"
+
+# Recently there has been a lot of stability problem in Gentoo-land. Many
+# things can be the cause to this, but I believe that it is due to gcc3
+# still having issues with optimizations, or with it not filtering bad
+# combinations (protecting the user maybe from himeself) yet.
+#
+# This can clearly be seen in large builds like glibc, where too aggressive
+# CFLAGS cause the tests to fail miserbly.
+#
+# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
+# knows what he is talking about:
+#
+# People really shouldn't force code-specific options on... It's a
+# bad idea. The -march options aren't just to look pretty. They enable
+# options that are sensible (and include sse,mmx,3dnow when apropriate).
+#
+# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
+# you do not like it, comment it, but do not bugreport if you run into
+# problems.
+#
+# <azarah@gentoo.org> (13 Oct 2002)
+strip-flags
+
+# Lock glibc at -O2 -- linuxthreads needs it and we want to be conservative here
+export CFLAGS="${CFLAGS//-O?} -O2"
+export CXXFLAGS="${CFLAGS}"
+export LDFLAGS="${LDFLAGS//-Wl,--relax}"
+
+BRANCH_UPDATE="20031212"
+
+# Minimum kernel version for --enable-kernel
+export MIN_KV="2.4.1"
+# Minimum kernel version for enabling TLS and NPTL ...
+# NOTE: do not change this if you do not know what
+# you are doing !
+export MIN_NPTL_KV="2.6.0"
+
+#MY_PV="${PV/_}"
+MY_PV="2.3.2"
+#S="${WORKDIR}/${P%_*}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="GNU libc6 (also called glibc2) C library"
+SRC_URI="http://ftp.gnu.org/gnu/glibc/glibc-${MY_PV}.tar.bz2
+ ftp://sources.redhat.com/pub/glibc/snapshots/glibc-${MY_PV}.tar.bz2
+ http://ftp.gnu.org/gnu/glibc/glibc-linuxthreads-${MY_PV}.tar.bz2
+ ftp://sources.redhat.com/pub/glibc/snapshots/glibc-linuxthreads-${MY_PV}.tar.bz2
+ mirror://gentoo/${P/_*}-branch-update-${BRANCH_UPDATE}.patch.bz2
+ hppa? ( mirror://gentoo/${PN}-${MY_PV}-hppa-patches-p1.tar.bz2 )"
+HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
+
+KEYWORDS="~x86 ~mips ~sparc ~amd64 ~hppa ~alpha ~ia64"
+SLOT="2.2"
+LICENSE="LGPL-2"
+
+# We need new cleanup attribute support from gcc for NPTL among things ...
+DEPEND=">=sys-devel/gcc-3.2.3-r1
+ nptl? ( >=sys-devel/gcc-3.3.1-r1 )
+ >=sys-devel/binutils-2.14.90.0.6-r1
+ hppa? ( >=sys-kernel/hppa-headers-2.4.21_p13 ) : ( virtual/os-headers )
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/os-headers
+ sys-apps/baselayout
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/glibc"
+
+
+# Try to get a kernel source tree with version equal or greater
+# than $1. We basically just try a few default locations. The
+# version need to be that which KV_to_int() returns ...
+get_KHV() {
+ local headers=
+
+ [ -z "$1" ] && return 1
+
+ # - First check if linux-headers are installed (or symlink
+ # to current kernel ...)
+ # - Ok, do we have access to the current kernel's headers ?
+ # - Last option ... maybe its a weird bootstrap with /lib
+ # binded to the chroot ...
+
+ # We do not really support more than 2 arguments ...
+ if [ -n "$2" ]
+ then
+ headers="$2"
+ else
+ # We try to find the current kernel's headers first,
+ # as we would rather build against linux 2.5 headers ...
+ headers="/lib/modules/`uname -r`/build/include \
+ ${ROOT}/lib/modules/`uname -r`/build/include \
+ /usr/src/linux/include \
+ ${ROOT}/usr/src/linux/include \
+ ${ROOT}/usr/include"
+ fi
+
+ for x in ${headers}
+ do
+ local header="${x}/linux/version.h"
+
+ if [ -f ${header} ]
+ then
+
+ local version="`grep 'LINUX_VERSION_CODE' ${header} | \
+ sed -e 's:^.*LINUX_VERSION_CODE[[:space:]]*::'`"
+
+ if [ "${version}" -ge "$1" ]
+ then
+ echo "${x}"
+
+ return 0
+ fi
+ fi
+ done
+
+ return 1
+}
+
+use_nptl() {
+ # Enable NPTL support if:
+ # - We have 'nptl' in USE
+ # - We have linux-2.5 or later kernel (should prob check for 2.4.20 ...)
+ if [ -n "`use nptl`" -a "`get_KV`" -ge "`KV_to_int ${MIN_NPTL_KV}`" ]
+ then
+ # Enable NPTL support if:
+ # - We have 'x86' in USE and:
+ # - a CHOST of "i486-pc-linux-gnu"
+ # - a CHOST of "i586-pc-linux-gnu"
+ # - a CHOST of "i686-pc-linux-gnu"
+ # - Or we have 'alpha' in USE
+ # - Or we have 'amd64' in USE
+ # - Or we have 'mips' in USE
+ # - Or we have 'ppc' in USE
+ case ${ARCH} in
+ "x86")
+ if [ "${CHOST/-*}" = "i486" -o \
+ "${CHOST/-*}" = "i586" -o \
+ "${CHOST/-*}" = "i686" ]
+ then
+ return 0
+ fi
+ ;;
+ "alpha"|"amd64"|"mips"|"ppc"|"sparc")
+ return 0
+ ;;
+ *)
+ return 1
+ ;;
+ esac
+ fi
+
+ return 1
+}
+
+pkg_setup() {
+ # We need gcc 3.2 or later ...
+ if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
+ then
+ echo
+ eerror "As of glibc-2.3, gcc-3.2 or later is needed"
+ eerror "for the build to succeed."
+ die "GCC too old"
+ fi
+
+ echo
+
+ if use_nptl
+ then
+ # The use_nptl should have already taken care of kernel version,
+ # arch and CHOST, so now just check if we can find suitable kernel
+ # source tree or headers ....
+ einfon "Checking for sufficient version kernel headers ... "
+ if ! get_KHV "`KV_to_int ${MIN_NPTL_KV}`" &> /dev/null
+ then
+ echo "no"
+ echo
+ eerror "Could not find a kernel source tree or headers with"
+ eerror "version ${MIN_NPTL_KV} or later! Please correct this"
+ eerror "and try again."
+ die "Insufficient kernel headers present!"
+ else
+ echo "yes"
+ fi
+ fi
+
+ if [ "$(KV_to_int $(uname -r))" -gt "`KV_to_int '2.5.68'`" ]
+ then
+ local KERNEL_HEADERS="$(get_KHV "`KV_to_int ${MIN_NPTL_KV}`")"
+
+ einfon "Checking kernel headers for broken sysctl.h ... "
+ if ! gcc -I"${KERNEL_HEADERS}" \
+ -c ${FILESDIR}/test-sysctl_h.c -o ${T}/test1.o &> /dev/null
+ then
+ echo "yes"
+ echo
+ eerror "Your version of:"
+ echo
+ eerror " ${KERNEL_HEADERS}/linux/sysctl.h"
+ echo
+ eerror "is broken (from a user space perspective). Please apply"
+ eerror "the following patch:"
+ echo
+ eerror "*******************************************************"
+ cat ${FILESDIR}/fix-sysctl_h.patch
+ eerror "*******************************************************"
+ die "Broken linux/sysctl.h header included in kernel sources!"
+ else
+ echo "no"
+ fi
+ fi
+
+ if use_nptl
+ then
+ einfon "Checking gcc for __thread support ... "
+ if ! gcc -c ${FILESDIR}/test-__thread.c -o ${T}/test2.o &> /dev/null
+ then
+ echo "no"
+ echo
+ eerror "Could not find a gcc that supports the __thread directive!"
+ eerror "please update to gcc-3.2.2-r1 or later, and try again."
+ die "No __thread support in gcc!"
+ else
+ echo "yes"
+ fi
+
+ elif use nptl &> /dev/null
+ then
+ echo
+ # Just tell the user not to expect too much ...
+ ewarn "You have \"nptl\" in your USE, but your kernel version or"
+ ewarn "architecture does not support it!"
+ fi
+
+ echo
+}
+
+src_unpack() {
+
+ local P="${PN}-${MY_PV}"
+
+ unpack glibc-${MY_PV}.tar.bz2
+
+ # Extract pre-made man pages. Otherwise we need perl, which is a no-no.
+ mkdir -p ${S}/man; cd ${S}/man
+ use_nptl || tar xjf ${FILESDIR}/glibc-manpages-${MY_PV}.tar.bz2
+
+ cd ${S}
+ # Extract our threads package ...
+ if (! use_nptl) && [ -z "${BRANCH_UPDATE}" ]
+ then
+ unpack glibc-linuxthreads-${MY_PV}.tar.bz2
+ fi
+
+ if [ -n "${BRANCH_UPDATE}" ]
+ then
+ epatch ${DISTDIR}/${PN}-${PV/_*}-branch-update-${BRANCH_UPDATE}.patch.bz2
+ fi
+
+ if use_nptl
+ then
+ epatch ${FILESDIR}/2.3.2/${P}-redhat-nptl-fixes.patch
+ else
+ epatch ${FILESDIR}/2.3.2/${P}-redhat-linuxthreads-fixes.patch
+ fi
+
+ # To circumvent problems with propolice __guard and
+ # __guard_setup__stack_smash_handler
+ #
+ # http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
+ if [ "${ARCH}" != "hppa" -a "${ARCH}" != "hppa64" ]
+ then
+ cd ${S}; epatch ${FILESDIR}/2.3.2/${P}-propolice-guard-functions-v2.patch
+ fi
+
+ # With latest versions of glibc, a lot of apps failed on a PaX enabled
+ # system with:
+ #
+ # cannot enable executable stack as shared object requires: Permission denied
+ #
+ # This is due to PaX 'exec-protecting' the stack, and ld.so then trying
+ # to make the stack executable due to some libraries not containing the
+ # PT_GNU_STACK section. Bug #32960. <azarah@gentoo.org> (12 Nov 2003).
+ epatch ${FILESDIR}/2.3.3/${PN}-2.3.3-dl_execstack-PaX-support.patch
+
+ # This next patch fixes a test that will timeout due to ReiserFS' slow handling of sparse files
+# cd ${S}/io; epatch ${FILESDIR}/glibc-2.2.2-test-lfs-timeout.patch
+
+ # This add back glibc 2.2 compadibility. See bug #8766 and #9586 for more info,
+ # and also:
+ #
+ # http://lists.debian.org/debian-glibc/2002/debian-glibc-200210/msg00093.html
+ #
+ # We should think about remoing it in the future after things have settled.
+ #
+ # Thanks to Jan Gutter <jangutter@tuks.co.za> for reporting it.
+ #
+ # <azarah@gentoo.org> (26 Oct 2002).
+ cd ${S}; epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-ctype-compat-v3.patch
+
+ # One more compat issue which breaks sun-jdk-1.3.1. See bug #8766 for more
+ # info, and also:
+ #
+ # http://sources.redhat.com/ml/libc-alpha/2002-04/msg00143.html
+ #
+ # Thanks to Jan Gutter <jangutter@tuks.co.za> for reporting it.
+ #
+ # <azarah@gentoo.org> (30 Oct 2002).
+ cd ${S}; epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-libc_wait-compat.patch
+
+ # One more compat issue ... libc_stack_end is missing from ld.so.
+ # Got this one from diffing redhat glibc tarball .. would help if
+ # they used patches and not modified tarball ...
+ #
+ # <azarah@gentoo.org> (7 Nov 2002).
+# cd ${S}; epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-stack_end-compat.patch
+
+ # The mathinline.h header omits the middle term of a ?: expression. This
+ # is a gcc extension, but since the ISO standard forbids it, it's a
+ # GLIBC bug (bug #27142). See also:
+ #
+ # http://bugs.gentoo.org/show_bug.cgi?id=27142
+ #
+ cd ${S}; epatch ${FILESDIR}/2.3.2/${P}-fix-omitted-operand-in-mathinline_h.patch
+
+ # We do not want name_insert() in iconvconfig.c to be defined inside
+ # write_output() as it causes issues with PaX.
+ cd ${S}; epatch ${FILESDIR}/2.3.2/${P}-iconvconfig-name_insert.patch
+
+ # A few patches only for the MIPS platform. Descriptions of what they
+ # do can be found in the patch headers.
+ # <tuxus@gentoo.org> thx <dragon@gentoo.org> (11 Jan 2003)
+ # <kumba@gentoo.org> remove tst-rndseek-mips & ulps-mips patches
+ if [ "${ARCH}" = "mips" ]
+ then
+ cd ${S}
+ epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-fpu-cw-mips.patch
+ epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-libgcc-compat-mips.patch
+ epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-librt-mips.patch
+ epatch ${FILESDIR}/2.3.2/${P}-mips-add-n32-n64-sysdep-cancel.patch
+ epatch ${FILESDIR}/2.3.2/${P}-mips-configure-for-n64-symver.patch
+ epatch ${FILESDIR}/2.3.2/${P}-mips-pread-linux2.5.patch
+ fi
+
+ if [ "${ARCH}" = "alpha" ]
+ then
+ cd ${S}
+ # Fix compatability with compaq compilers by ifdef'ing out some
+ # 2.3.2 additions.
+ # <taviso@gentoo.org> (14 Jun 2003).
+ epatch ${FILESDIR}/2.3.2/${P}-decc-compaq.patch
+
+ # Fix compilation with >=gcc-3.2.3 (01 Nov 2003 agriffis)
+ epatch ${FILESDIR}/2.3.2/${P}-alpha-pwrite.patch
+ fi
+
+ if [ "${ARCH}" = "amd64" ]
+ then
+ cd ${S}; epatch ${FILESDIR}/2.3.2/${P}-amd64-nomultilib.patch
+ fi
+
+ if [ "${ARCH}" = "ia64" ]
+ then
+ # The basically problem is glibc doesn't store information about
+ # what the kernel interface is so that it can't efficiently set up
+ # parameters for system calls. This patch from H.J. Lu fixes it:
+ #
+ # http://sources.redhat.com/ml/libc-alpha/2003-09/msg00165.html
+ #
+ cd ${S}; epatch ${FILESDIR}/2.3.2/${P}-ia64-LOAD_ARGS-fixup.patch
+ fi
+
+ if [ "${ARCH}" = "hppa" ]
+ then
+ local x=
+
+ cd ${WORKDIR}
+ unpack ${P}-hppa-patches-p1.tar.bz2
+ cd ${S}
+ EPATCH_EXCLUDE="010* 020* 030* 040* 050* 055*"
+ for x in ${EPATCH_EXCLUDE}
+ do
+ rm -f ${WORKDIR}/${P}-hppa-patches/${x}
+ done
+ for x in ${WORKDIR}/${P}-hppa-patches/*
+ do
+ epatch ${x}
+ done
+ epatch ${FILESDIR}/2.3.1/glibc23-07-hppa-atomicity.dpatch
+ fi
+
+ # Fix permissions on some of the scripts
+ chmod u+x ${S}/scripts/*.sh
+}
+
+setup_flags() {
+ # -freorder-blocks for all but ia64 s390 s390x
+ use ppc || append-flags "-freorder-blocks"
+
+ # Sparc/Sparc64 support
+ if [ -n "`use sparc`" ]
+ then
+
+ # Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
+ replace-flags "-fcall-used-g7" ""
+ append-flags "-fcall-used-g6"
+
+ # Sparc64 Only support...
+ if [ "${PROFILE_ARCH}" = "sparc64" ]
+ then
+
+ # Get rid of -mcpu options, the CHOST will fix this up
+ replace-flags "-mcpu=ultrasparc" ""
+ replace-flags "-mcpu=v9" ""
+
+ # Get rid of flags known to fail
+ replace-flags "-mvis" ""
+
+ # Setup the CHOST properly to insure "sparcv9"
+ # This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
+ export CHOST="${CHOST/sparc/sparcv9}"
+ fi
+ fi
+}
+
+src_compile() {
+ local myconf=
+ local myconf_nptl=
+
+ setup_flags
+
+ # These should not be set, else the
+ # zoneinfo do not always get installed ...
+ unset LANGUAGE LANG LC_ALL
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ if use_nptl
+ then
+ local kernelheaders="$(get_KHV "`KV_to_int ${MIN_NPTL_KV}`")"
+
+ # NTPL and Thread Local Storage support.
+ myconf="${myconf} --with-tls --with-__thread \
+ --enable-add-ons=nptl \
+ --enable-kernel=${MIN_NPTL_KV} \
+ --with-headers=${kernelheaders}"
+ else
+ myconf="${myconf} --without-__thread \
+ --enable-add-ons=linuxthreads"
+
+ # If we build for the build system we use the kernel headers from the target
+ # We also now set it without "build" as well, else it might use the
+ # current kernel's headers, which might just fail (the linux-headers
+ # package is usually well tested...)
+# ( use build || use sparc ) \
+# && myconf="${myconf} --with-headers=${ROOT}usr/include"
+ myconf="${myconf} --with-headers=${ROOT}usr/include"
+
+ # If kernel version and headers in ${ROOT}/usr/include are ok,
+ # then enable --enable-kernel=${MIN_KV} ...
+ if [ "`get_KV`" -ge "`KV_to_int ${MIN_KV}`" -a \
+ -n "$(get_KHV "`KV_to_int ${MIN_KV}`" "${ROOT}/usr/include")" ]
+ then
+ myconf="${myconf} --enable-kernel=${MIN_KV}"
+ else
+ myconf="${myconf} --enable-kernel=2.2.5"
+ fi
+ fi
+
+ einfo "Configuring GLIBC..."
+ rm -rf ${S}/buildhere
+ mkdir -p ${S}/buildhere
+ cd ${S}/buildhere
+ ../configure --build=${CHOST} \
+ --host=${CHOST} \
+ --with-gd=no \
+ --without-cvs \
+ --disable-profile \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib/misc \
+ ${myconf} || die
+
+ einfo "Building GLIBC..."
+ cd ${S}/buildhere
+ make PARALLELMFLAGS="${MAKEOPTS}" || die
+# einfo "Doing GLIBC checks..."
+# make check
+}
+
+src_install() {
+ local buildtarget="buildhere"
+
+ setup_flags
+
+ # These should not be set, else the
+ # zoneinfo do not always get installed ...
+ unset LANGUAGE LANG LC_ALL
+
+ einfo "Installing GLIBC..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ install -C ${buildtarget} || die
+
+ # If librt.so is a symlink, change it into linker script (Redhat)
+ if [ -L "${D}/usr/lib/librt.so" -a "${LIBRT_LINKERSCRIPT}" = "yes" ]
+ then
+ local LIBRTSO="`cd ${D}/lib; echo librt.so.*`"
+ local LIBPTHREADSO="`cd ${D}/lib; echo libpthread.so.*`"
+
+ rm -f ${D}/usr/lib/librt.so
+ cat > ${D}/usr/lib/librt.so <<EOF
+/* GNU ld script
+ librt.so.1 needs libpthread.so.0 to come before libc.so.6*
+ in search scope. */
+EOF
+ grep "OUTPUT_FORMAT" ${D}/usr/lib/libc.so >> ${D}/usr/lib/librt.so
+ echo "GROUP ( /lib/${LIBPTHREADSO} /lib/${LIBRTSO} )" \
+ >> ${D}/usr/lib/librt.so
+
+ for x in ${D}/usr/lib/librt.so.[1-9]
+ do
+ [ -L "${x}" ] && rm -f ${x}
+ done
+ fi
+
+ if [ -z "`use build`" ]
+ then
+ einfo "Installing Info pages..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ info -C ${buildtarget} || die
+
+ einfo "Installing Locale data..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ localedata/install-locales -C ${buildtarget} || die
+
+ # Compatibility hack: this locale has vanished from glibc,
+ # but some other programs are still using it.
+ keepdir /usr/lib/locale/ru_RU/LC_MESSAGES
+
+ einfo "Installing man pages and docs..."
+ # Install linuxthreads man pages
+ use_nptl || {
+ dodir /usr/share/man/man3
+ doman ${S}/man/*.3thr
+ }
+
+ # Install nscd config file
+ insinto /etc
+ doins ${FILESDIR}/nscd.conf
+
+ dodoc BUGS ChangeLog* CONFORMANCE COPYING* FAQ INTERFACE \
+ NEWS NOTES PROJECTS README*
+ else
+ rm -rf ${D}/usr/share ${D}/usr/lib/gconv
+
+ einfo "Installing Timezone data..."
+ make PARALLELMFLAGS="${MAKEOPTS}" \
+ install_root=${D} \
+ timezone/install-others -C ${buildtarget} || die
+ fi
+
+ if [ "`use pic`" ]
+ then
+ find ${S}/${buildtarget}/ -name "soinit.os" -exec cp {} ${D}/lib/soinit.o \;
+ find ${S}/${buildtarget}/ -name "sofini.os" -exec cp {} ${D}/lib/sofini.o \;
+ find ${S}/${buildtarget}/ -name "*_pic.a" -exec cp {} ${D}/lib \;
+ find ${S}/${buildtarget}/ -name "*.map" -exec cp {} ${D}/lib \;
+ for i in ${D}/lib/*.map
+ do
+ mv ${i} ${i%.map}_pic.map
+ done
+ fi
+
+ # Is this next line actually needed or does the makefile get it right?
+ # It previously has 0755 perms which was killing things.
+ fperms 4755 /usr/lib/misc/pt_chown
+
+ # Currently libraries in /usr/lib/gconv do not get loaded if not
+ # in search path ...
+# insinto /etc/env.d
+# doins ${FILESDIR}/03glibc
+
+ rm -f ${D}/etc/ld.so.cache
+
+ # Prevent overwriting of the /etc/localtime symlink. We'll handle the
+ # creation of the "factory" symlink in pkg_postinst().
+ rm -f ${D}/etc/localtime
+
+ # Some things want this, notably ash.
+ dosym /usr/lib/libbsd-compat.a /usr/lib/libbsd.a
+}
+
+pkg_postinst() {
+ # Correct me if I am wrong here, but my /etc/localtime is a file
+ # created by zic ....
+ # I am thinking that it should only be recreated if no /etc/localtime
+ # exists, or if it is an invalid symlink.
+ #
+ # For invalid symlink:
+ # -f && -e will fail
+ # -L will succeed
+ #
+ if [ ! -e ${ROOT}/etc/localtime ]
+ then
+ echo "Please remember to set your timezone using the zic command."
+ rm -f ${ROOT}/etc/localtime
+ ln -s ../usr/share/zoneinfo/Factory ${ROOT}/etc/localtime
+ fi
+
+ if [ -x ${ROOT}/usr/sbin/iconvconfig ]
+ then
+ # Generate fastloading iconv module configuration file.
+ ${ROOT}/usr/sbin/iconvconfig --prefix=${ROOT}
+ fi
+
+ # Reload init ...
+ if [ "${ROOT}" = "/" ]
+ then
+ /sbin/init U &> /dev/null
+ fi
+}
+