summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-18 03:42:19 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-18 03:42:19 +0000
commitf44a2ee501ecb8fc534c81f6bbf706e382ab5051 (patch)
treeb6c90ad267159e9ba9bc7140b18c69c648f256da /sys-libs/uclibc
parentmips stable (diff)
downloadhistorical-f44a2ee501ecb8fc534c81f6bbf706e382ab5051.tar.gz
historical-f44a2ee501ecb8fc534c81f6bbf706e382ab5051.tar.bz2
historical-f44a2ee501ecb8fc534c81f6bbf706e382ab5051.zip
add support for installing just headers
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'sys-libs/uclibc')
-rw-r--r--sys-libs/uclibc/Manifest10
-rw-r--r--sys-libs/uclibc/uclibc-0.9.27-r1.ebuild25
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.ebuild22
3 files changed, 39 insertions, 18 deletions
diff --git a/sys-libs/uclibc/Manifest b/sys-libs/uclibc/Manifest
index f6c88e4effd4..e21d33d604b6 100644
--- a/sys-libs/uclibc/Manifest
+++ b/sys-libs/uclibc/Manifest
@@ -7,13 +7,13 @@ MD5 9a39fb9a2446443aa355070e819107a0 files/digest-uclibc-0.9.27-r1 298
MD5 851ff3547906842b0d94c848a876be2c files/digest-uclibc-0.9.28 213
MD5 684def72ebc0da73cb8b6d1c53e7e8fb files/getent 1112
MD5 e96b4dfc373a1cdf7735aeae52c4cf7e metadata.xml 999
-MD5 efa96caf831fd746f3f3ddaf61ed7731 uclibc-0.9.27-r1.ebuild 11858
+MD5 6dfd63ecdf1a0eacc00feaae8e765419 uclibc-0.9.27-r1.ebuild 12093
MD5 81cee933f6981c689db448c06576ec3c uclibc-0.9.27.ebuild 10387
-MD5 42289f1a5c6d58c5d4a4bd13973299f7 uclibc-0.9.28.ebuild 12124
+MD5 c223bc3263b89945842908b1f21a37ac uclibc-0.9.28.ebuild 12368
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDfCspgIKl8Uu19MoRAnuBAJ9XvMS257pFi9a8Us0jcLuezB02aACeNZ/7
-g8vJrzfOmtMc5jbBQg+TugQ=
-=wTCQ
+iD8DBQFDfU3xgIKl8Uu19MoRAj0cAJ48hoOfRpnK8pf5Dyw94negnuDgbwCfStDm
+QjwclIQ3N4w0he1/S11awDA=
+=o+Lq
-----END PGP SIGNATURE-----
diff --git a/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild b/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
index 8a331ed4fc67..40a2318ba706 100644
--- a/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.10 2005/11/10 04:21:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.11 2005/11/18 03:42:19 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -23,7 +23,7 @@ fi
# diff -urN --exclude .svn uClibc-0.9.27 uClibc | bzip2 - > uClibc-0.9.27-svn-update-`date +%Y%m%d`.patch.bz2
# rm -rf uClibc-0.9.27-svn-update-`date +%Y%m%d`.patch.bz2 uClibc uClibc-0.9.27
-MY_P=${P/ucl/uCl}
+MY_P=uClibc-${PV}
SVN_VER="20050114"
PATCH_VER="1.5"
DESCRIPTION="C library for developing embedded Linux systems"
@@ -72,9 +72,17 @@ alt_rprefix() {
echo /usr/${CTARGET}/
fi
}
+just_headers() {
+ [[ -z ${_E_CROSS_HEADERS_ONLY} ]] && return 1
+ [[ ${CHOST} == ${CTARGET} ]] && return 1
+ return 0
+}
pkg_setup() {
+ just_headers && return 0
+ has_version ${CATEGORY}/uclibc || return 0
[[ -n ${UCLIBC_AND_GLIBC} ]] && return 0
+
if ! built_with_use ${CATEGORY}/uclibc nls && use nls && ! use pregen ; then
eerror "You previously built uclibc with USE=-nls."
eerror "You cannot generate locale data with this"
@@ -204,11 +212,11 @@ src_unpack() {
echo "UCLIBC_PREGENERATED_LOCALE_DATA=y" >> .config
echo "UCLIBC_DOWNLOAD_PREGENERATED_LOCALE_DATA=y" >> .config
if use userlocales ; then
- cp "${DISTDIR}"/${P}-user-locale.tar.gz \
+ cp "${DISTDIR}"/${MY_P}-user-locale.tar.gz \
extra/locale/uClibc-locale-030818.tgz \
- || die "could not copy ${P}-user-locale.tar.gz"
+ || die "could not copy ${MY_P}-user-locale.tar.gz"
else
- cp "${DISTDIR}"/${P}-$(tc-arch)-full-locale.tar.gz \
+ cp "${DISTDIR}"/${MY_P}-$(tc-arch)-full-locale.tar.gz \
extra/locale/uClibc-locale-030818.tgz \
|| die "could not copy locale"
fi
@@ -303,6 +311,8 @@ src_compile() {
type -p ${CTARGET}-ar && export MAKEOPTS="${MAKEOPTS} CROSS=${CTARGET}-"
emake headers || die "make headers failed"
+ just_headers && return 0
+
if use nls && ! use pregen ; then
cd extra/locale
make clean || die "make locale clean failed"
@@ -339,10 +349,11 @@ src_test() {
}
src_install() {
- emake PREFIX="${D}" install || die "install failed"
+ local target="install"
+ just_headers && target="install_dev"
+ make PREFIX="${D}" ${target} || die "install failed"
# remove files coming from kernel-headers
- # scsi is uclibc's own directory since cvs 20040212
rm -rf "${D}"$(alt_prefix)/include/{asm,linux,asm-generic}
# clean up misc cruft
diff --git a/sys-libs/uclibc/uclibc-0.9.28.ebuild b/sys-libs/uclibc/uclibc-0.9.28.ebuild
index db8b47690053..c64351327454 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.10 2005/11/17 07:01:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.11 2005/11/18 03:42:19 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -19,7 +19,7 @@ if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-uclibc ]] ; then
export CTARGET=${CHOST%%-*}-pc-linux-uclibc
fi
-MY_P=${P/ucl/uCl}
+MY_P=uClibc-${PV}
SVN_VER=""
PATCH_VER="1.1"
DESCRIPTION="C library for developing embedded Linux systems"
@@ -70,8 +70,14 @@ alt_rprefix() {
echo /usr/${CTARGET}/
fi
}
+just_headers() {
+ [[ -z ${_E_CROSS_HEADERS_ONLY} ]] && return 1
+ [[ ${CHOST} == ${CTARGET} ]] && return 1
+ return 0
+}
pkg_setup() {
+ just_headers && return 0
has_version ${CATEGORY}/uclibc || return 0
[[ -n ${UCLIBC_AND_GLIBC} ]] && return 0
@@ -229,11 +235,11 @@ src_unpack() {
echo "UCLIBC_PREGENERATED_LOCALE_DATA=y" >> .config
echo "UCLIBC_DOWNLOAD_PREGENERATED_LOCALE_DATA=y" >> .config
if use userlocales ; then
- cp "${DISTDIR}"/${P}-user-locale.tar.gz \
+ cp "${DISTDIR}"/${MY_P}-user-locale.tar.gz \
extra/locale/uClibc-locale-030818.tgz \
- || die "could not copy ${P}-user-locale.tar.gz"
+ || die "could not copy ${MY_P}-user-locale.tar.gz"
else
- cp "${DISTDIR}"/${P}-$(tc-arch)-full-locale.tar.gz \
+ cp "${DISTDIR}"/${MY_P}-$(tc-arch)-full-locale.tar.gz \
extra/locale/uClibc-locale-030818.tgz \
|| die "could not copy locale"
fi
@@ -331,6 +337,8 @@ src_compile() {
cp myconfig .config
emake headers || die "make headers failed"
+ just_headers && return 0
+
if use iconv && ! use pregen ; then
cd extra/locale
make clean || die "make locale clean failed"
@@ -357,7 +365,9 @@ src_test() {
}
src_install() {
- make PREFIX="${D}" install || die "install failed"
+ local target="install"
+ just_headers && target="install_dev"
+ make PREFIX="${D}" ${target} || die "install failed"
# remove files coming from kernel-headers
rm -rf "${D}"$(alt_prefix)/include/{linux,asm*}