summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-12 09:11:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-12 09:11:00 +0000
commit48f0fa8e9509900f83cad5f153e8c57620e1daeb (patch)
treeb50d69a68a61447d05a2924a005ff15aaf17617b /sys-libs/pam
parentunmask wmaker, i fixed the deps. (diff)
downloadhistorical-48f0fa8e9509900f83cad5f153e8c57620e1daeb.tar.gz
historical-48f0fa8e9509900f83cad5f153e8c57620e1daeb.tar.bz2
historical-48f0fa8e9509900f83cad5f153e8c57620e1daeb.zip
Add patch to fix building on ppc64 with GCC4, by replacing __u8 and __u32 with standard types uint8_t and uint32_t. Closes bug #107430.
Package-Manager: portage-2529-svn
Diffstat (limited to 'sys-libs/pam')
-rw-r--r--sys-libs/pam/ChangeLog9
-rw-r--r--sys-libs/pam/Manifest15
-rw-r--r--sys-libs/pam/files/pam-0.78-inttypes.patch118
-rw-r--r--sys-libs/pam/pam-0.78-r3.ebuild6
4 files changed, 142 insertions, 6 deletions
diff --git a/sys-libs/pam/ChangeLog b/sys-libs/pam/ChangeLog
index 9891c669f37f..356f7f4c237d 100644
--- a/sys-libs/pam/ChangeLog
+++ b/sys-libs/pam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/pam
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.95 2005/10/26 14:05:31 pebenito Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.96 2006/01/12 09:11:00 flameeyes Exp $
+
+ 12 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pam-0.78-inttypes.patch, pam-0.78-r3.ebuild:
+ Add patch to fix building on ppc64 with GCC4, by replacing __u8 and __u32
+ with standard types uint8_t and uint32_t. Closes bug #107430.
*pam-0.78-r3 (26 Oct 2005)
diff --git a/sys-libs/pam/Manifest b/sys-libs/pam/Manifest
index 4ef18a80f322..28182fc841f0 100644
--- a/sys-libs/pam/Manifest
+++ b/sys-libs/pam/Manifest
@@ -1,10 +1,14 @@
-MD5 27137d20ba3f34895dd90a66b5068b7b ChangeLog 15222
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 103f16d915ec413882489abb5f7f1503 ChangeLog 15471
MD5 73f196808b2658496c9a9bd525ca30da files/README.pam_console 2615
MD5 b38aa656e6c205427dd4c4ba7d6d3f97 files/digest-pam-0.77-r6 201
MD5 693d0527279f95e01ad9a5ba6ef45389 files/digest-pam-0.77-r8 201
MD5 f6222db3bcd34dad4edfcdcd8e488920 files/digest-pam-0.78-r2 264
MD5 9ac651407da8dec3264c075cc3bb6717 files/digest-pam-0.78-r3 264
MD5 69f8cfad7f241eb669085eaa753cd9dd files/pam-0.77-console-reset.patch 1826
+MD5 95b7f27f454b393fd12cdae6d9806866 files/pam-0.78-inttypes.patch 5644
MD5 2d840b9afde7319bc8a8f7676582af11 files/pam.d/other 139
MD5 c3d3871612bfb718a50454c8fba54b64 files/pam.d/system-auth 402
MD5 652f6b0ebdc63b0aa9ca6e1783c468a1 files/pam_env.conf 2980
@@ -12,4 +16,11 @@ MD5 393d06cf4b76671f8e6ce72ac71bdad8 metadata.xml 218
MD5 45e4ffa616491f670f6b43f7482889e7 pam-0.77-r6.ebuild 8080
MD5 a12e7f860965fe8642486460693e8aa2 pam-0.77-r8.ebuild 8152
MD5 71f87e5903b032bb13cdca94d73bc2ce pam-0.78-r2.ebuild 11223
-MD5 13b1c1305c3ce125bde42d2ce984bb4f pam-0.78-r3.ebuild 11288
+MD5 d64258776c7ee92d3501165d49682f97 pam-0.78-r3.ebuild 11332
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDxh01AiZjviIA2XgRApFJAJsEyG7l01dtHUId17IqUDeEj8HBFwCgmXGo
+WmkAqakWZ+fs3xPYRAY6Bd8=
+=TAhN
+-----END PGP SIGNATURE-----
diff --git a/sys-libs/pam/files/pam-0.78-inttypes.patch b/sys-libs/pam/files/pam-0.78-inttypes.patch
new file mode 100644
index 000000000000..9b4221351f1f
--- /dev/null
+++ b/sys-libs/pam/files/pam-0.78-inttypes.patch
@@ -0,0 +1,118 @@
+Index: Linux-PAM-0.78/libpamc/include/security/pam_client.h
+===================================================================
+--- Linux-PAM-0.78.orig/libpamc/include/security/pam_client.h
++++ Linux-PAM-0.78/libpamc/include/security/pam_client.h
+@@ -16,19 +16,13 @@ extern "C" {
+ #include <unistd.h>
+ #include <string.h>
+ #include <stdio.h>
++#include <stdint.h>
+
+ /* opaque agent handling structure */
+
+ typedef struct pamc_handle_s *pamc_handle_t;
+
+-/* binary prompt structure pointer */
+-#ifndef __u32
+-# define __u32 unsigned int
+-#endif
+-#ifndef __u8
+-# define __u8 unsigned char
+-#endif
+-typedef struct { __u32 length; __u8 control; } *pamc_bp_t;
++typedef struct { uint32_t length; uint8_t control; } *pamc_bp_t;
+
+ /*
+ * functions provided by libpamc
+@@ -91,10 +85,10 @@ char **pamc_list_agents(pamc_handle_t pc
+ # define PAM_BP_FREE free
+ #endif /* PAM_BP_FREE */
+
+-#define __PAM_BP_WOCTET(x,y) (*((y) + (__u8 *)(x)))
+-#define __PAM_BP_ROCTET(x,y) (*((y) + (const __u8 *)(x)))
++#define __PAM_BP_WOCTET(x,y) (*((y) + (uint8_t *)(x)))
++#define __PAM_BP_ROCTET(x,y) (*((y) + (const uint8_t *)(x)))
+
+-#define PAM_BP_MIN_SIZE (sizeof(__u32) + sizeof(__u8))
++#define PAM_BP_MIN_SIZE (sizeof(uint32_t) + sizeof(uint8_t))
+ #define PAM_BP_MAX_LENGTH 0x20000 /* an advisory limit */
+ #define PAM_BP_WCONTROL(x) (__PAM_BP_WOCTET(x,4))
+ #define PAM_BP_RCONTROL(x) (__PAM_BP_ROCTET(x,4))
+@@ -103,8 +97,8 @@ char **pamc_list_agents(pamc_handle_t pc
+ (__PAM_BP_ROCTET(x,2)<< 8)+ \
+ (__PAM_BP_ROCTET(x,3) ))
+ #define PAM_BP_LENGTH(x) (PAM_BP_SIZE(x) - PAM_BP_MIN_SIZE)
+-#define PAM_BP_WDATA(x) (PAM_BP_MIN_SIZE + (__u8 *) (x))
+-#define PAM_BP_RDATA(x) (PAM_BP_MIN_SIZE + (const __u8 *) (x))
++#define PAM_BP_WDATA(x) (PAM_BP_MIN_SIZE + (uint8_t *) (x))
++#define PAM_BP_RDATA(x) (PAM_BP_MIN_SIZE + (const uint8_t *) (x))
+
+ /* Note, this macro always '\0' terminates renewed packets */
+
+@@ -112,13 +106,13 @@ char **pamc_list_agents(pamc_handle_t pc
+ do { \
+ if (old_p) { \
+ if (*(old_p)) { \
+- __u32 __size; \
++ uint32_t __size; \
+ __size = PAM_BP_SIZE(*(old_p)); \
+ memset(*(old_p), 0, __size); \
+ PAM_BP_FREE(*(old_p)); \
+ } \
+ if (cntrl) { \
+- __u32 __size; \
++ uint32_t __size; \
+ \
+ __size = PAM_BP_MIN_SIZE + data_length; \
+ if ((*(old_p) = PAM_BP_CALLOC(1, 1+__size))) { \
+@@ -141,7 +135,7 @@ do {
+ #define PAM_BP_FILL(prmpt, offset, length, data) \
+ do { \
+ size_t bp_length; \
+- __u8 *prompt = (__u8 *) (prmpt); \
++ uint8_t *prompt = (uint8_t *) (prmpt); \
+ bp_length = PAM_BP_LENGTH(prompt); \
+ if (bp_length < ((length)+(offset))) { \
+ PAM_BP_ASSERT("attempt to write over end of prompt"); \
+@@ -152,7 +146,7 @@ do {
+ #define PAM_BP_EXTRACT(prmpt, offset, length, data) \
+ do { \
+ size_t __bp_length; \
+- const __u8 *__prompt = (const __u8 *) (prmpt); \
++ const uint8_t *__prompt = (const uint8_t *) (prmpt); \
+ __bp_length = PAM_BP_LENGTH(__prompt); \
+ if (((offset) < 0) || (__bp_length < ((length)+(offset))) \
+ || ((length) < 0)) { \
+Index: Linux-PAM-0.78/libpamc/pamc_converse.c
+===================================================================
+--- Linux-PAM-0.78.orig/libpamc/pamc_converse.c
++++ Linux-PAM-0.78/libpamc/pamc_converse.c
+@@ -34,8 +34,8 @@ static int __pamc_select_agent(pamc_hand
+
+ int pamc_converse(pamc_handle_t pch, pamc_bp_t *prompt_p)
+ {
+- __u32 size, offset=0;
+- __u8 control, raw[PAM_BP_MIN_SIZE];
++ uint32_t size, offset=0;
++ uint8_t control, raw[PAM_BP_MIN_SIZE];
+
+ D(("called"));
+
+@@ -109,7 +109,7 @@ int pamc_converse(pamc_handle_t pch, pam
+ /* pump all of the prompt into the agent */
+ do {
+ int rval = write(pch->current->writer,
+- offset + (const __u8 *) (*prompt_p),
++ offset + (const uint8_t *) (*prompt_p),
+ size - offset);
+ if (rval == -1) {
+ switch (errno) {
+@@ -171,7 +171,7 @@ int pamc_converse(pamc_handle_t pch, pam
+ value from the previous loop */
+
+ while (offset < size) {
+- int rval = read(pch->current->reader, offset + (__u8 *) *prompt_p,
++ int rval = read(pch->current->reader, offset + (uint8_t *) *prompt_p,
+ size-offset);
+
+ if (rval == -1) {
diff --git a/sys-libs/pam/pam-0.78-r3.ebuild b/sys-libs/pam/pam-0.78-r3.ebuild
index f22861f5a825..37a24aaf03d2 100644
--- a/sys-libs/pam/pam-0.78-r3.ebuild
+++ b/sys-libs/pam/pam-0.78-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.78-r3.ebuild,v 1.1 2005/10/26 14:05:31 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.78-r3.ebuild,v 1.2 2006/01/12 09:11:00 flameeyes Exp $
FORCE_SYSTEMAUTH_UPDATE="no"
@@ -142,6 +142,8 @@ src_unpack() {
cp /usr/share/automake/install-sh ${S}/ 2>/dev/null || touch install-sh
export WANT_AUTOCONF=2.5
autoconf || die
+
+ epatch "${FILESDIR}/${P}-inttypes.patch"
}
src_compile() {