summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-11-09 23:51:31 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-11-09 23:51:31 +0000
commit181bf07fdfc989c0ea574ad90bcc0149d495e224 (patch)
tree9a72f76e068342971452e208bd7e7a834d3e3164 /sys-libs/nss-mysql
parentNew version. Fixes #7562 (diff)
downloadhistorical-181bf07fdfc989c0ea574ad90bcc0149d495e224.tar.gz
historical-181bf07fdfc989c0ea574ad90bcc0149d495e224.tar.bz2
historical-181bf07fdfc989c0ea574ad90bcc0149d495e224.zip
New version. x86 architecture mask. Fixes #7657
Diffstat (limited to 'sys-libs/nss-mysql')
-rw-r--r--sys-libs/nss-mysql/ChangeLog8
-rw-r--r--sys-libs/nss-mysql/files/digest-nss-mysql-0.431
-rw-r--r--sys-libs/nss-mysql/nss-mysql-0.43.ebuild104
3 files changed, 112 insertions, 1 deletions
diff --git a/sys-libs/nss-mysql/ChangeLog b/sys-libs/nss-mysql/ChangeLog
index cb1f03a37a8e..3896ec298b06 100644
--- a/sys-libs/nss-mysql/ChangeLog
+++ b/sys-libs/nss-mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/nss-mysql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/nss-mysql/ChangeLog,v 1.1 2002/08/09 07:36:00 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/nss-mysql/ChangeLog,v 1.2 2002/11/09 23:51:31 rphillips Exp $
+
+*nss-mysql-0.43 (9 Nov 2002)
+
+ 9 Nov 2002; Ryan Phillips <rphillips@gentoo.org> nss-mysql-0.43.ebuild :
+
+ New version. Added IUSE and x86 Keyword
*nss-mysql-0.40 (9 Aug 2002)
diff --git a/sys-libs/nss-mysql/files/digest-nss-mysql-0.43 b/sys-libs/nss-mysql/files/digest-nss-mysql-0.43
new file mode 100644
index 000000000000..6a2420404378
--- /dev/null
+++ b/sys-libs/nss-mysql/files/digest-nss-mysql-0.43
@@ -0,0 +1 @@
+MD5 1b3e62509dec0904142a06c58e9b9473 nss-mysql-0.43.tar.gz 209713
diff --git a/sys-libs/nss-mysql/nss-mysql-0.43.ebuild b/sys-libs/nss-mysql/nss-mysql-0.43.ebuild
new file mode 100644
index 000000000000..75b5422ecaac
--- /dev/null
+++ b/sys-libs/nss-mysql/nss-mysql-0.43.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Written for Portage by Christian Skarby (Interhost ANS, Norway) christian.skarby@interhost.no
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/nss-mysql/nss-mysql-0.43.ebuild,v 1.1 2002/11/09 23:51:31 rphillips Exp $
+
+IUSE="static"
+DESCRIPTION="NSS MySQL Module"
+HOMEPAGE="http://savannah.gnu.org/projects/nss-mysql"
+SRC_URI="http://savannah.gnu.org/download/nss-mysql/nss-mysql.pkg/0.43/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=">=virtual/glibc-2.1* >=dev-db/mysql-3.23.51-r1"
+LICENSE="GPL-2"
+
+src_compile() {
+ use static && myconf="--enable-static"
+ ./configure ${myconf} \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/nss-mysql \
+ --libdir=/lib \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+ cp -a /usr/portage/${CATEGORY}/nss-mysql/files/gentoo.sql.${P}.gentoo ${S}/gentoo.sql
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README SHADOW THANKS TODO UPGRADE sample.sql gentoo.sql
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ einfo "to autosetup nss-mysql and the mysql tables."
+ einfo "You should then edit your /etc/nsswitch.conf file to activate nss_mysql"
+ einfo "and suit your intentions. Below is an partial example:"
+ einfo
+ einfo "passwd: files mysql"
+ einfo "shadow: files mysql"
+ einfo "group: files mysql"
+ einfo
+}
+
+pkg_config() {
+ echo "In order to continue we'll need to know a MySQL username with enough"
+ echo "privleges to create databases, mysql-users and grant privleges,"
+ echo "typically a user named root."
+ echo
+ echo -n "MySQL-root-user [root]: "
+ read USERNAME
+ if [ -z "${USERNAME}" ]; then
+ USERNAME="root"
+ fi
+ echo -n "Is it required to use a password in order to access mysql with ${USERNAME} [Y/n]: "
+ read NEEDPASS
+ POPT="-p"
+ if [ "${NEEDPASS}" == "n" ]; then
+ POPT=""
+ fi
+ cmd="${ROOT}/usr/bin/makepasswd --minchars=10 --maxchars=12"
+ if [ -f "${cmd}" ]; then
+ PASS=`$cmd`
+ PAS2=`$cmd`
+ fi
+ cmd="${ROOT}/usr/bin/passook"
+ if [ -f "${cmd}" ]; then
+ PASS=`$cmd`
+ PAS2=`$cmd`
+ fi
+ if [ -z "${PASS}" ]; then
+ echo "";
+ echo "Didn't manage to find a passwd-generator, please type a passwords of your choise";
+ echo -n "Shadow-access-password (root-only): ";
+ read PASS
+ echo -n "Select-public-info-password: ";
+ read PAS2
+ fi
+ if [ -z "${PAS2}" ]; then
+ PAS2="badbadbadPASSWDMHALL20020715";
+ fi
+ if [ -z "${PASS}" ]; then
+ einfo "I will not accept that you leave that the shadow-access-password empty"
+ die
+ fi
+ if [ ! -z "$POPT" ]; then
+ einfo "Pass the mysql-users \"${USERNAME}\"s password to mysql:";
+ echo -n "mysql> "
+ fi
+ ( gunzip -c /usr/share/doc/${P}/gentoo.sql.gz | sed s/another_password/${PASS}/ | sed s/"'password'"/"'${PAS2}'"/ | mysql ${POPT} -u ${USERNAME} ) || die
+ FILE="/etc/nss-mysql/nss-mysql-root.conf"; sed -e s/"shadow.db_password ="/"shadow.db_password = ${PASS};#oldpass:"/ < ${FILE} | cat > ${FILE}
+ FILE="/etc/nss-mysql/nss-mysql.conf"; sed -e s/"users.db_password ="/"users.db_password = ${PAS2};#oldpass:"/ < ${FILE} | cat > ${FILE}
+ chown -R 0.0 /etc/nss-mysql
+ chmod 600 /etc/nss-mysql/nss-mysql-root.conf
+ chmod 644 /etc/nss-mysql/nss-mysql.conf
+ einfo "nss_mysql-configfiles and mysql-tables should now be setup"
+ einfo "remember to activate nss-mysql in /etc/nsswitch.conf with someting simillar to:"
+ einfo
+ einfo "passwd: files mysql"
+ einfo "shadow: files mysql"
+ einfo "group: files mysql"
+ einfo
+}