summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-24 21:00:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-24 21:00:04 +0000
commit30ea1411e958b8112f94f3b67438c7cb067083e0 (patch)
treec15e11078fc205b64e78ad59cd5313510f279d96 /sys-libs/libutempter
parentvirtual/perl-Getopt-Long stable on ppc. (diff)
downloadhistorical-30ea1411e958b8112f94f3b67438c7cb067083e0.tar.gz
historical-30ea1411e958b8112f94f3b67438c7cb067083e0.tar.bz2
historical-30ea1411e958b8112f94f3b67438c7cb067083e0.zip
Use the right compiler so that cross-distcc does not fail.
Package-Manager: portage-2.1_rc2-r2
Diffstat (limited to 'sys-libs/libutempter')
-rw-r--r--sys-libs/libutempter/ChangeLog6
-rw-r--r--sys-libs/libutempter/files/digest-libutempter-1.1.2.14
-rw-r--r--sys-libs/libutempter/libutempter-1.1.2.1.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/sys-libs/libutempter/ChangeLog b/sys-libs/libutempter/ChangeLog
index aca1fe5547fd..4aa4e0d1d043 100644
--- a/sys-libs/libutempter/ChangeLog
+++ b/sys-libs/libutempter/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libutempter
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/ChangeLog,v 1.8 2006/04/13 19:02:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/ChangeLog,v 1.9 2006/05/24 21:00:04 flameeyes Exp $
+
+ 24 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ libutempter-1.1.2.1.ebuild:
+ Use the right compiler so that cross-distcc does not fail.
13 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
libutempter-1.1.2.1.ebuild:
diff --git a/sys-libs/libutempter/files/digest-libutempter-1.1.2.1 b/sys-libs/libutempter/files/digest-libutempter-1.1.2.1
index 513a6f432d8e..0b5dc1747626 100644
--- a/sys-libs/libutempter/files/digest-libutempter-1.1.2.1
+++ b/sys-libs/libutempter/files/digest-libutempter-1.1.2.1
@@ -1,2 +1,6 @@
MD5 718df9b195ca947b0e212b96015822f1 libutempter-1.1.2-alt1.src.rpm 20125
+RMD160 084e82c6a7f8b08f35534e5e8dc3e766cc88a098 libutempter-1.1.2-alt1.src.rpm 20125
+SHA256 918e4b02fe0fb6cf31d3de1c9867e1df0935ee6a5d011d26192db6f1d89a93f6 libutempter-1.1.2-alt1.src.rpm 20125
MD5 428f57d482fda1ca1a4199737f0a4c72 libutempter-patches-1.tar.bz2 1968
+RMD160 bb64e7d1b28c0fe235e61a9a79a554af8ca4b9fe libutempter-patches-1.tar.bz2 1968
+SHA256 3acea214f5773f3cc842c1e1b716e6f1808edc9a8cdfa60cb4909b9eac17795c libutempter-patches-1.tar.bz2 1968
diff --git a/sys-libs/libutempter/libutempter-1.1.2.1.ebuild b/sys-libs/libutempter/libutempter-1.1.2.1.ebuild
index dfbf5355cfd8..1c341c914cbb 100644
--- a/sys-libs/libutempter/libutempter-1.1.2.1.ebuild
+++ b/sys-libs/libutempter/libutempter-1.1.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/libutempter-1.1.2.1.ebuild,v 1.10 2006/04/13 19:02:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/libutempter-1.1.2.1.ebuild,v 1.11 2006/05/24 21:00:04 flameeyes Exp $
-inherit rpm eutils flag-o-matic versionator
+inherit rpm eutils flag-o-matic versionator toolchain-funcs
MY_P=${PN}-$(replace_version_separator 3 '-alt')
S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
@@ -42,6 +42,7 @@ src_unpack() {
src_compile() {
make \
+ CC="$(tc-getCC)" \
RPM_OPT_FLAGS="${CFLAGS}" \
libdir=/usr/$(get_libdir) \
libexecdir=/usr/$(get_libdir) || die