summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-02-05 04:12:56 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-02-05 04:12:56 +0000
commit1836ef33e75bd1d683d61472834d06a84ee7f69c (patch)
tree1210913aeec096545fafc2491e53c56e22953180 /sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
parent(non maintainer commit) Don't use bundled intltool, causes problems for some ... (diff)
downloadhistorical-1836ef33e75bd1d683d61472834d06a84ee7f69c.tar.gz
historical-1836ef33e75bd1d683d61472834d06a84ee7f69c.tar.bz2
historical-1836ef33e75bd1d683d61472834d06a84ee7f69c.zip
Patch to compile with gcc-4.3.3, thanks to Magnus Granberg, closes bug #232102. Fixed repoman warnings galore.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild')
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild42
1 files changed, 21 insertions, 21 deletions
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
index 4877a1708bdd..341eb96a7b79 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.43 2009/02/01 22:51:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.44 2009/02/05 04:12:56 je_fro Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -151,16 +151,16 @@ PDEPEND="sys-devel/gcc-config"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fixup libtool to correctly generate .la files with portage
elibtoolize --portage --shallow
- use amd64 && epatch ${FILESDIR}/libstdc++_amd64_multilib_hack.patch
+ use amd64 && epatch "${FILESDIR}"/libstdc++_amd64_multilib_hack.patch
# Misdesign in libstdc++ (Redhat)
- cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
+ cp -a "${S}"/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
- cd ${S}; ./contrib/gcc_update --touch &> /dev/null
+ cd "${S}"; ./contrib/gcc_update --touch &> /dev/null
gnuconfig_update
}
@@ -182,12 +182,12 @@ src_compile() {
einfo "CXXFLAGS=\"${CXXFLAGS}\""
# Build in a separate build tree
- mkdir -p ${WORKDIR}/build
- cd ${WORKDIR}/build
+ mkdir -p "${WORKDIR}"/build
+ cd "${WORKDIR}"/build
einfo "Configuring libstdc++..."
addwrite "/dev/zero"
- ${S}/configure --prefix=${LOC} \
+ "${S}"/configure --prefix=${LOC} \
--bindir=${BINPATH} \
--includedir=${LIBPATH}/include \
--datadir=${DATAPATH} \
@@ -208,7 +208,7 @@ src_compile() {
--with-local-prefix=${LOC}/local \
${myconf} || die
- touch ${S}/gcc/c-gperf.h
+ touch "${S}"/gcc/c-gperf.h
einfo "Compiling libstdc++..."
S="${WORKDIR}/build" \
@@ -222,7 +222,7 @@ src_install() {
# Do allow symlinks in ${LOC}/lib/gcc-lib/${CHOST}/${PV}/include as
# this can break the build.
- for x in ${WORKDIR}/build/gcc/include/*
+ for x in "${WORKDIR}"/build/gcc/include/*
do
if [ -L ${x} ]
then
@@ -232,7 +232,7 @@ src_install() {
done
# Remove generated headers, as they can cause things to break
# (ncurses, openssl, etc).
- for x in `find ${WORKDIR}/build/gcc/include/ -name '*.h'`
+ for x in `find "${WORKDIR}"/build/gcc/include/ -name '*.h'`
do
if grep -q 'It has been auto-edited by fixincludes from' ${x}
then
@@ -242,8 +242,8 @@ src_install() {
einfo "Installing libstdc++..."
# Do the 'make install' from the build directory
- cd ${WORKDIR}/build
- S="${WORKDIR}/build" \
+ cd "${WORKDIR}"/build
+ S="${WORKDIR}"/build \
make prefix=${LOC} \
bindir=${BINPATH} \
includedir=${LIBPATH}/include \
@@ -257,24 +257,24 @@ src_install() {
# we'll move this into a directory we can put at the end of ld.so.conf
# other than the normal versioned directory, so that it doesnt conflict
# with gcc 3.3.3
- mkdir -p ${D}/${LOC}/lib/libstdc++-v3/
- mv ${D}/${LIBPATH}/lib* ${D}/${LOC}/lib/libstdc++-v3/
+ mkdir -p "${D}"/${LOC}/lib/libstdc++-v3/
+ mv "${D}"/${LIBPATH}/lib* "${D}"/${LOC}/lib/libstdc++-v3/
# we dont want the headers...
- rm -rf ${D}/${LOC}/lib/gcc*
+ rm -rf "${D}"/${LOC}/lib/gcc*
# or locales...
- rm -rf ${D}/${LOC}/share
+ rm -rf "${D}"/${LOC}/share
# or anything other than the .so files, really.
- find ${D} | grep -e c++.la$ -e c++.a$ | xargs rm -f
+ find "${D}" | grep -e c++.la$ -e c++.a$ | xargs rm -f
# we dont even want the un-versioned .so symlink, as it confuses some
# apps and also causes others to link against the old libstdc++...
- rm ${D}/${LOC}/lib/libstdc++-v3/libstdc++.so
+ rm "${D}"/${LOC}/lib/libstdc++-v3/libstdc++.so
# and it's much easier to just move around the result than it is to
# configure libstdc++-v3 to use CONF_LIDIR
if [ "$(get_libdir)" != "lib" ] ; then
- mv ${D}/${LOC}/lib ${D}/${LOC}/$(get_libdir)
+ mv "${D}"/${LOC}/lib "${D}"/${LOC}/$(get_libdir)
fi
- mkdir -p ${D}/etc/env.d/
+ mkdir -p "${D}"/etc/env.d/
echo "LDPATH=\"${LOC}/lib/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++
}