summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-24 02:47:31 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-24 02:47:31 +0000
commit81c40be36faa0ed95dd14799ecb49f36f142c122 (patch)
treee7e9ac8938b1cdd34b3fe33ddb09e153b87590d5 /sys-libs/libcap/files
parentQA - fix use invocation (diff)
downloadhistorical-81c40be36faa0ed95dd14799ecb49f36f142c122.tar.gz
historical-81c40be36faa0ed95dd14799ecb49f36f142c122.tar.bz2
historical-81c40be36faa0ed95dd14799ecb49f36f142c122.zip
fix PIC prob #52813
Diffstat (limited to 'sys-libs/libcap/files')
-rw-r--r--sys-libs/libcap/files/1.10-python.patch9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-libs/libcap/files/1.10-python.patch b/sys-libs/libcap/files/1.10-python.patch
index 7e1e77fb3881..f6c3517f68a7 100644
--- a/sys-libs/libcap/files/1.10-python.patch
+++ b/sys-libs/libcap/files/1.10-python.patch
@@ -21,15 +21,18 @@ diff -ur libcap-1.10.orig/libcap/Makefile libcap-1.10/libcap/Makefile
_makenames: _makenames.c cap_names.sed
$(CC) $(CFLAGS) $(LDFLAGS) $< -o $@
-@@ -66,6 +71,12 @@
+@@ -66,6 +71,15 @@
ln -sf $(MINLIBNAME) $(MAJLIBNAME)
ln -sf $(MAJLIBNAME) $(LIBNAME).so
+libcap_wrap.c: include/sys/capability.h
+ swig -python -o libcap_wrap.c include/sys/capability.h
+
-+$(PYTHONMODNAME): $(OBJS) libcap_wrap.o
-+ $(LD) -x -shared -o $@ libcap_wrap.o $(OBJS)
++libcap_wrap.o: libcap_wrap.c
++ $(CC) $(CFLAGS) -fPIC -c $< -o $@
++
++$(PYTHONMODNAME): $(LOBJS) libcap_wrap.o
++ $(LD) -x -shared -o $@ libcap_wrap.o $(LOBJS)
+
%.o: %.c $(INCLS)
$(CC) $(CFLAGS) -c $< -o $@