summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-09 23:04:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-09 23:04:33 +0000
commit6875e881ff489d3990d3015cc38e001a85a12a6f (patch)
treeda0913226d675f4b80f4248f4deb1f9edaf1602c /sys-libs/lib-compat/lib-compat-1.4.ebuild
parentStable on alpha, bug 66912. (diff)
downloadhistorical-6875e881ff489d3990d3015cc38e001a85a12a6f.tar.gz
historical-6875e881ff489d3990d3015cc38e001a85a12a6f.tar.bz2
historical-6875e881ff489d3990d3015cc38e001a85a12a6f.zip
install ld-linux.so #39485
Diffstat (limited to 'sys-libs/lib-compat/lib-compat-1.4.ebuild')
-rw-r--r--sys-libs/lib-compat/lib-compat-1.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-libs/lib-compat/lib-compat-1.4.ebuild b/sys-libs/lib-compat/lib-compat-1.4.ebuild
new file mode 100644
index 000000000000..4ddb130f0433
--- /dev/null
+++ b/sys-libs/lib-compat/lib-compat-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/lib-compat/lib-compat-1.4.ebuild,v 1.1 2004/10/09 23:04:33 vapier Exp $
+
+DESCRIPTION="Compatibility C++ and libc5 and libc6 libraries for programs new and old"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha"
+IUSE="sdl"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${P}/${ARCH}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Rather install this with the proper filename
+ mv -f libstdc++-libc6.2-2.so.3 libstdc++-3-libc6.2-2-2.10.0.so
+ # libstdc++-2-libc6.1-1-2.9.0.so provides this one ...
+ rm -f libstdc++-libc6.1-1.so.2
+ # No package installs this one, so no need for the .dummy
+ mv -f libstdc++.so.2.9.dummy libstdc++.so.2.9.0
+ # dont install if they dont want sdl
+ use sdl || rm -f libsmpeg-0.4.so.0.dummy
+}
+
+src_install() {
+ if use x86 ; then
+ into /
+ dolib.so ld-linux.so.1*
+ rm -f ld-linux.so.1*
+ fi
+ into /usr
+ dolib.so *.so*
+ preplib /usr
+}