summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2001-12-27 06:01:20 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2001-12-27 06:01:20 +0000
commite5e1409b444d17af0512ce323997ff4183bfa475 (patch)
treee602b0e14f0864a00fb436a9cef9abcb8d2c1330 /sys-libs/gpm
parentAdded new, fast mirror in case ftp.gnu.org is full (diff)
downloadhistorical-e5e1409b444d17af0512ce323997ff4183bfa475.tar.gz
historical-e5e1409b444d17af0512ce323997ff4183bfa475.tar.bz2
historical-e5e1409b444d17af0512ce323997ff4183bfa475.zip
New gpm version available
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/gpm-1.19.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-libs/gpm/gpm-1.19.6.ebuild b/sys-libs/gpm/gpm-1.19.6.ebuild
new file mode 100644
index 000000000000..3ce840e9920a
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.19.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.6.ebuild,v 1.1 2001/12/27 06:01:20 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Console-based mouse driver"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/mouse/${P}.tar.gz"
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2 sys-devel/autoconf"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ cp ${FILESDIR}/gpmInt.h .
+# patch -p1 < ${FILESDIR}/devfs.patch
+ #this little hack turns of EMACS byte compilation. Really don't want this thing auto-detecting emacs
+ cp configure.in configure.in.orig
+ sed -e '45i\' -e 'EMACS=:\' -e 'ELISP=' configure.in.orig > configure.in || die
+ autoconf || die
+}
+
+src_compile() {
+ ./configure --prefix=/usr --sysconfdir=/etc/gpm || die
+ # without-curses is required to avoid cyclic dependencies to ncurses
+
+ cp Makefile Makefile.orig
+ #The emacs stuff turns off auto byte-"complication"
+ sed -e "s/doc//" Makefile.orig > Makefile
+ #-e '/$(EMACS)/c\' -e ' echo'
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ chmod 755 ${D}/usr/lib/libgpm.so.1.18.0
+ dodoc Announce COPYING ChangeLog FAQ MANIFEST README*
+ doman doc/gpm.8 doc/mev.1 doc/gpm-root.1 doc/gpm-types.7 doc/mouse-test.1
+ doinfo doc/gpm.info
+ docinto txt
+ dodoc doc/gpmdoc.txt
+
+ insinto /etc/gpm
+ doins gpm-root.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/gpm.rc6 gpm
+ insinto /etc/conf.d
+ newins ${FILESDIR}/gpm.conf.d gpm
+}