summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-07 15:17:38 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-07 15:17:38 +0000
commit5283a84f051aa6f5162b6fb2b952bcfd8307d296 (patch)
tree273fac06ca8a1d6e60e47371957fd5836ffbbcc7 /sys-libs/glibc
parentversion bump (diff)
downloadhistorical-5283a84f051aa6f5162b6fb2b952bcfd8307d296.tar.gz
historical-5283a84f051aa6f5162b6fb2b952bcfd8307d296.tar.bz2
historical-5283a84f051aa6f5162b6fb2b952bcfd8307d296.zip
remove all -lgcc_eh
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/Manifest16
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r12.ebuild14
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild4
4 files changed, 19 insertions, 19 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 422bc97f196a..39bad060edf1 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -1,14 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 65b2608084c75baef2abf5848ff78f3b ChangeLog 62420
MD5 7cf88dee2671dcc30659d07241b8d918 glibc-2.2.5-r9.ebuild 10915
-MD5 e4f211c5762191a6fce67b15caf38c31 glibc-2.3.2-r12.ebuild 20537
+MD5 7ac20d9072665431e9f5cdc3c14f9737 glibc-2.3.2-r12.ebuild 20817
MD5 d59fdfb3aca88476d792b71922c765a5 glibc-2.3.3.20040420-r2.ebuild 21630
MD5 48dcbf88afd15efb62b4313337261968 glibc-2.3.4.20040619-r2.ebuild 21077
MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
-MD5 3628073e660979062c2b09010a36d5d1 glibc-2.3.4.20040808-r1.ebuild 23515
-MD5 43263ca5f0742351fbb0c8aaf3723897 glibc-2.3.4.20041102.ebuild 28281
+MD5 f71fb8ef664fba9e755c7610974cd8f1 glibc-2.3.4.20040808-r1.ebuild 23505
+MD5 ce2fa7fca461bd7e0a41e9132f7b0022 glibc-2.3.4.20041102.ebuild 28271
MD5 9cc1e6b6f749dba7c8759bd07266f7d9 files/digest-glibc-2.2.5-r9 143
MD5 2d5306ef875573750af642a9f93b634a files/digest-glibc-2.3.2-r12 312
MD5 42af7e35fe2404a49954f91fd1aee891 files/digest-glibc-2.3.3.20040420-r2 312
@@ -134,10 +131,3 @@ MD5 03b2b9cfe46d287c2a28df70e7a9e9a1 files/2.3.4/glibc-2.3.4-mips-prot_grows-und
MD5 8d43dc97fe220048ade220f23e84f006 files/2.3.4/glibc-2.3.4-mips-rtld_deepbind-undefined.patch 1425
MD5 1185022e9a50560d1bf9116a0461e011 files/2.3.4/glibc-2.3.4-mips-sysdep-cancel.diff 2402
MD5 039f62650037a4a15cef3066b26d27c9 files/2.3.4/glibc-2.3.4-mips-update-__throw.patch 1975
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBtQr0roRuSHgZdywRAtURAJ9lDdSKC+e2PJ9n+J1YH+90nQs4bACfUUHS
-JjdxstfVi5Cb+hUhUTXm/gs=
-=O6bc
------END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.2-r12.ebuild b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
index c357d235b626..c5312d748e02 100644
--- a/sys-libs/glibc/glibc-2.3.2-r12.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.2 2004/11/12 16:31:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.3 2004/12/07 15:17:38 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -16,6 +16,14 @@ export MIN_KV="2.4.1"
# you are doing !
export MIN_NPTL_KV="2.6.0"
+# (very) Theoretical cross-compiler support
+export CTARGET="${CTARGET:-${CHOST}}"
+if [[ ${CTARGET} = ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET="${CATEGORY/cross-}"
+ fi
+fi
+
MY_PV="${PV/_}"
S="${WORKDIR}/${P%_*}"
DESCRIPTION="GNU libc6 (also called glibc2) C library"
@@ -28,7 +36,9 @@ SRC_URI="http://ftp.gnu.org/gnu/glibc/glibc-${MY_PV}.tar.bz2
hppa? ( mirror://gentoo/${P}-hppa-patches-p1.tar.bz2 )"
LICENSE="LGPL-2"
-SLOT="2.2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}-2.2" \
+ || SLOT="2.2"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc s390 sh sparc x86"
IUSE="nls pic build nptl debug"
RESTRICT="nostrip" # we'll handle stripping ourself #46186
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 93c9ec117b5b..da4247d5604b 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.20 2004/12/07 01:44:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.21 2004/12/07 15:17:38 vapier Exp $
inherit eutils flag-o-matic gcc versionator
@@ -522,7 +522,7 @@ src_unpack() {
# http://sources.redhat.com/ml/libc-alpha/2003-09/msg00100.html
echo 'int main(){}' > ${T}/gcc_eh_test.c
if ! $(tc-getCC) ${T}/gcc_eh_test.c -lgcc_eh 2>/dev/null ; then
- sed -i -e '/static-gnulib := /s:-lgcc -lgcc_eh:-lgcc:' Makeconfig
+ sed -i -e 's:-lgcc_eh::' Makeconfig || die "sed gcc_eh"
fi
# hardened toolchain/relro/nptl/security/etc fixes
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index cf404608eebc..25760007ab07 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.13 2004/12/07 01:44:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.14 2004/12/07 15:17:38 vapier Exp $
inherit eutils flag-o-matic gcc versionator
@@ -546,7 +546,7 @@ src_unpack() {
# http://sources.redhat.com/ml/libc-alpha/2003-09/msg00100.html
echo 'int main(){}' > ${T}/gcc_eh_test.c
if ! $(tc-getCC) ${T}/gcc_eh_test.c -lgcc_eh 2>/dev/null ; then
- sed -i -e '/static-gnulib := /s:-lgcc -lgcc_eh:-lgcc:' Makeconfig
+ sed -i -e 's:-lgcc_eh::' Makeconfig || die "sed gcc_eh"
fi
# hardened toolchain/relro/nptl/security/etc fixes