summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-24 07:51:21 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-24 07:51:21 +0000
commit3eb1a6863349ed3c66bafc92137fcd04465801cd (patch)
treee224addcd159baf546f1ad964c6fe7d598906cf9 /sys-kernel
parentargh, final fix I hope (diff)
downloadhistorical-3eb1a6863349ed3c66bafc92137fcd04465801cd.tar.gz
historical-3eb1a6863349ed3c66bafc92137fcd04465801cd.tar.bz2
historical-3eb1a6863349ed3c66bafc92137fcd04465801cd.zip
bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.53.ebuild102
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.531
2 files changed, 103 insertions, 0 deletions
diff --git a/sys-kernel/development-sources/development-sources-2.5.53.ebuild b/sys-kernel/development-sources/development-sources-2.5.53.ebuild
new file mode 100644
index 000000000000..c166dd22e4fa
--- /dev/null
+++ b/sys-kernel/development-sources/development-sources-2.5.53.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.53.ebuild,v 1.1 2002/12/24 07:51:21 lostlogic Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PV}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# beta 2.5.36 kernel sources
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="x86 ppc"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+# mv linux linux-${KV} || die
+ cd ${S}
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+# make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+# cd ${S}
+# mv Makefile Makefile.orig
+# sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+# Makefile.orig >Makefile || die # test, remove me if Makefile ok
+# rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux-beta ]
+ then
+
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
+ fi
+}
+
+
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.53 b/sys-kernel/development-sources/files/digest-development-sources-2.5.53
new file mode 100644
index 000000000000..86e78406c666
--- /dev/null
+++ b/sys-kernel/development-sources/files/digest-development-sources-2.5.53
@@ -0,0 +1 @@
+MD5 e1da8dbda1a51e05c2eaf3d26c0ebacd linux-2.5.53.tar.bz2 31457681