summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-09-06 07:19:44 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-09-06 07:19:44 +0000
commit176eed46844c49889f6c738fed748cac75d9f41c (patch)
tree33105347e4ed497184ce9228be043ca73e6b7b75 /sys-kernel
parentAdded instructions for ext3 (diff)
downloadhistorical-176eed46844c49889f6c738fed748cac75d9f41c.tar.gz
historical-176eed46844c49889f6c738fed748cac75d9f41c.tar.bz2
historical-176eed46844c49889f6c738fed748cac75d9f41c.zip
new rc6 baselayout bootstrap stuff, and an in-progress linux-sources-2.4.9.9
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-sources/files/digest-linux-sources-2.4.9.96
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.9.9.ebuild454
2 files changed, 460 insertions, 0 deletions
diff --git a/sys-kernel/linux-sources/files/digest-linux-sources-2.4.9.9 b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.9.9
new file mode 100644
index 000000000000..dd6038973321
--- /dev/null
+++ b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.9.9
@@ -0,0 +1,6 @@
+MD5 568a3673324804e0ac846969a3e311cb cloop_0.61-1.tar.gz
+MD5 991c485866bd4c52504ec4721337b46c linux-2.4.9.tar.bz2
+MD5 b02cb1bb5be17dc7b023b632c3356338 lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2
+MD5 4227d98ab42e1f08b4c0804b749b393e lvm_1.0.1-rc1.tar.gz
+MD5 14b33da66be00c77d04f79bc5d2b005c lvm_perl_to_bash.patch.bz2
+MD5 87dcb850c07c00f882095cdb42235e9d patch-2.4.9-ac9.bz2
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.9.9.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.9.9.ebuild
new file mode 100644
index 000000000000..d6af9bc5450d
--- /dev/null
+++ b/sys-kernel/linux-sources/linux-sources-2.4.9.9.ebuild
@@ -0,0 +1,454 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.9.9.ebuild,v 1.1 2001/09/06 07:19:44 drobbins Exp $
+
+#OKV=original kernel version, KV=patched kernel version
+
+OKV=2.4.9
+KV=2.4.9-ac9
+S=${WORKDIR}/linux-${KV}
+S2=${WORKDIR}/linux-${KV}-extras
+if [ $PN = "linux-extras" ]
+then
+ KS=${ROOT}usr/src/linux-${KV}
+ KS2=${ROOT}usr/src/linux-${KV}-extras
+else
+ KS=${S}
+ KS2=${S2}
+fi
+
+# Kernel Features Enabled USE Variable Status
+#
+# Reiserfs Y - Production-ready
+# JFS N jfs Testing-only (commented out for now)
+# LVM Y lvm almost production-ready (still has race conditions during pvmove)
+# ext3 Y ext3 Production-ready
+# MOSIX Y mosix Testing only
+# XFS N xfs Will add soon
+# PCMCIA-CS N pcmcia Need to move this to its own ebuild
+# lm-sensors N lm_sensors Need to move this to its own ebuild
+
+LVMV=1.0.1-rc1
+#EXT3V=2.4-0.9.2-246
+#MOSV=1.1.2
+CLOOPV=0.61
+CLOOPAV=0.61-1
+# AV=0.5.11
+#JFSV=1.0.0
+#KNV="6.g"
+#PIV="1.d"
+#PCV="3.1.27"
+
+[ "${PN}" = "linux" ] && DESCRIPTION="Linux kernel version ${KV}, including modules, binary tools, libraries and includes"
+[ "${PN}" = "linux-sources" ] && DESCRIPTION="Linux kernel version ${KV} - full sources"
+[ "${PN}" = "linux-extras" ] && DESCRIPTION="Linux kernel support tools and libraries"
+
+# We use build in /usr/src/linux in case of linux-extras
+# so we need no sources
+if [ ! "${PN}" = "linux-extras" ] ; then
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/${OKV}/patch-${KV}.bz2
+ ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${LVMV}.tar.gz
+ http://www.knopper.net/download/knoppix/cloop_${CLOOPAV}.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2
+ http://www.ibiblio.org/gentoo/distfiles/lvm_perl_to_bash.patch.bz2"
+fi
+# http://www.zip.com.au/~akpm/ext3-${EXT3V}.gz
+# http://oss.software.ibm.com/developerworks/opensource/jfs/project/pub/jfs-1.0.0-patch.tar.gz
+# ftp://ftp.cs.huji.ac.il/users/mosix/MOSIX-${MOSV}.tar.gz
+# http://www.netroedge.com/~lm78/archive/lm_sensors-${SENV}.tar.gz
+# http://www.netroedge.com/~lm78/archive/i2c-${SENV}.tar.gz
+# http://prdownloads.sourceforge.net/pcmcia-cs/pcmcia-cs-${PCV}.tar.gz
+
+if [ "$PN" != "linux-extras" ]
+then
+ PROVIDE="virtual/kernel"
+fi
+
+HOMEPAGE="http://www.kernel.org/
+ http://www.namesys.com
+ http://www.sistina.com/lvm/"
+
+DEPEND=">=sys-apps/modutils-2.4.2 sys-devel/perl"
+#these deps are messed up; fix 'em and add ncurses (required my mosix compile, menuconfig)
+if [ $PN = "linux" ]
+then
+# RDEPEND="mosix? ( ~sys-apps/mosix-user-${MOSV} ) >=sys-apps/e2fsprogs-1.22 >=sys-apps/util-linux-2.11f >=sys-apps/reiserfs-utils-3.6.25-r1"
+ RDEPEND=">=sys-apps/e2fsprogs-1.22 >=sys-apps/util-linux-2.11f >=sys-apps/reiserfs-utils-3.6.25-r1"
+elif [ $PN = "linux-sources" ]
+then
+ if [ "`use build`" ]
+ then
+ DEPEND=""
+ RDEPEND=""
+ else
+ #ncurses is required for "make menuconfig"
+ RDEPEND=">=sys-libs/ncurses-5.2"
+ fi
+elif [ $PN = "linux-extras" ]
+then
+ #linux-extras/headers requires a rev of the current kernel sources to be installed
+ RDEPEND="~sys-kernel/linux-sources-${PV}"
+elif [ $PN = "linux-headers" ]
+then
+ DEPEND=""
+ RDEPEND=""
+fi
+
+# this is not pretty...
+LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${KS}/include"
+
+src_unpack() {
+ if [ "$PN" = "linux-extras" ]
+ then
+ return
+ fi
+
+ mkdir ${S2}
+
+ #unpack kernel and apply reiserfs-related patches
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ try mv linux linux-${KV}
+ cd ${S}
+ if [ "$KV" != "$OKV" ]
+ then
+ echo "Applying ${KV} patch..."
+ bzip2 -dc ${DISTDIR}/patch-${KV}.bz2 | patch -p1 || die
+ fi
+ dodir /usr/src/linux-${KV}-extras
+
+#### Mosix
+# if [ "`use mosix`" ]
+# then
+# echo "Applying MOSIX patch..."
+# cd ${S2}
+# mkdir MOSIX-${MOSV}
+# cd MOSIX-${MOSV}
+# tar xzf MOSIX-${MOSV}.tar.gz patches.${OKV} kernel.new.${OKV}.tar
+# cd ${S}
+# try cat ${S2}/MOSIX-${MOSV}/patches.${KV} | patch -p0
+# tar -x --no-same-owner -vf ${S2}/MOSIX-${MOSV}/kernel.new.${KV}.tar
+# fi
+#### Mosix
+ if [ "`use lvm`" ]
+ then
+ #create and apply LVM patch. The tools get built later.
+ cd ${S2}
+ echo "Unpacking and applying LVM patch..."
+ unpack lvm_${LVMV}.tar.gz
+ #cd LVM/${LVMV}
+ #We need to convert those 1.0.1-rc1 perl scripts to bash; This'll be fixed in 1.0.1 final. Thanks AJ :)
+ #cat ${DISTDIR}/lvm_perl_to_bash.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ # I had to hack this in so that LVM will look in the current linux
+ # source directory instead of /usr/src/linux for stuff - pete
+ #CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ #cd PATCHES
+ #make KERNEL_VERSION=${KV} KERNEL_DIR=${S} || die
+ #cd ${S}
+ # the -l option allows this patch to apply cleanly (ignore whitespace changes)
+ # the -N option is an "auto no" to previously applied stuff. Needed for 2.4.8-ac8
+
+ #patch -N -l -p1 < ${S2}/LVM/${LVMV}/PATCHES/lvm-${LVMV}-${KV}.patch
+ cd ${S}
+ cat ${DISTDIR}/lvm-1.0.1-rc1-2.4.8-ac8.patch.bz2 | bzip2 -d | patch -N -l -p1
+ #|| die
+ #we removed || die because any stuff that hits -N causes an error code of 1
+ fi
+
+# if [ "`use lm_sensors`" ]
+# then
+# #unpack and apply the lm_sensors patch
+# echo "Unpacking and applying lm_sensors patch..."
+# cd ${S}/extras
+# unpack lm_sensors-${SENV}.tar.gz
+# unpack i2c-${SENV}.tar.gz
+# cd i2c-${SENV}
+# try rmdir src
+# try ln -s ../.. src
+# try mkpatch/mkpatch.pl . /usr/src/linux | patch -p1 -E -d /usr/src/linux
+# cp Makefile Makefile.orig
+# try sed -e \"s:^LINUX=.*:LINUX=src:\" \
+# -e \"s/^COMPILE_KERNEL.*/COMPILE_KERNEL := 2/\" \
+# -e \"s:^I2C_HEADERS.*:I2C_HEADERS=.i2c-src/kernel:\" \
+# -e \"s#^DESTDIR.*#DESTDIR := ${D}#\" \
+# -e \"s#^PREFIX.*#PREFIX := /usr#\" \
+# -e \"s#^MANDIR.*#MANDIR := /usr/share/man#\" \
+# Makefile.orig > Makefile
+# cd ${S}/extras/lm_sensors-${SENV}
+# try rmdir src
+# try ln -s ../.. src
+# try ln -s ../i2c-${SENV} i2c-src
+# try mkpatch/mkpatch.pl . /usr/src/linux | patch -p1 -E -d /usr/src/linux
+# try sed -e \"s:^LINUX=.*:LINUX=src:\" \
+# -e \"s/^COMPILE_KERNEL.*/COMPILE_KERNEL := 2/\" \
+# -e \"s:^I2C_HEADERS.*:I2C_HEADERS=.i2c-src/kernel:\" \
+# -e \"s#^DESTDIR.*#DESTDIR := ${D}#\" \
+# -e \"s#^PREFIX.*#PREFIX := /usr#\" \
+# -e \"s#^MANDIR.*#MANDIR := /usr/share/man#\" \
+# Makefile.orig > Makefile
+# fi
+# if [ "`use pcmcia-cs`" ]
+# then
+# echo "Unpacking pcmcia-cs tools..."
+# cd ${S2}
+# unpack pcmcia-cs-${PCV}.tar.gz
+ # patch -p0 < ${FILESDIR}/${PVR}/pcmcia-cs-${PCV}-gentoo.diff
+# fi
+
+ #JFS patch works; commented out because it's not ready for production use
+ #if [ "`use jfs`" ]
+ #then
+ # echo "Applying JFS patch..."
+ # cd ${WORKDIR}
+ # unpack jfs-${JFSV}-patch.tar.gz
+ # cd ${S}
+ # patch -p1 < ${WORKDIR}/jfs-common-v1.0.0-patch
+ # patch -p1 < ${WORKDIR}/jfs-2.4.5-v1.0.0-patch
+ #fi
+
+# if [ "`use ext3`" ]
+# then
+# echo "Applying ext3 patch..."
+### Mosix
+# if [ "`use mosix`" ]
+# then
+# echo
+# echo "There will be one reject; we will fix it. (no worries)"
+# echo
+# fi
+### Mosix
+# cd ${S}
+# gzip -dc ${DISTDIR}/ext3-${EXT3V}.gz | patch -l -p1
+### Mosix
+# if [ "`use mosix`" ]
+# then
+# echo
+# echo "Fixing reject in include/linux/sched.h..."
+# echo
+# cp ${FILESDIR}/${PVR}/sched.h include/linux
+# fi
+### Mosix
+# fi
+
+ cd ${S2}
+ unpack cloop_${CLOOPAV}.tar.gz
+
+ #get sources ready for compilation or for sitting at /usr/src/linux
+ echo "Preparing for compilation..."
+ cd ${S}
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ try make mrproper
+
+ #linux-sources needs to be fully configured, too. Not just linux
+ #this is the configuration for the default kernel
+ try cp ${FILESDIR}/${PVR}/config.bootcd .config
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+}
+
+src_compile() {
+ if [ "${PN}" = "linux-sources" ] || [ "${PN}" = "linux-headers" ]
+ then
+ cd ${KS}
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
+ else
+ if [ $PN = "linux" ]
+ then
+ cd ${KS}
+ make symlinks || die
+ fi
+ if [ "`use lvm`" ]
+ then
+ #LVM tools are included in the linux and linux-extras pakcages
+ cd ${KS2}/LVM/${LVMV}
+
+ # This is needed for linux-extras
+ if [ -f "Makefile" ]
+ then
+ make clean || die
+ fi
+ # I had to hack this in so that LVM will look in the current linux
+ # source directory instead of /usr/src/linux for stuff - pete
+ CFLAGS="${CFLAGS} -I${KS}/include" ./configure --prefix=/ --mandir=/usr/share/man --with-kernel_dir="${KS}" || die
+ make || die
+ fi
+
+# if [ "`use lm_sensors`" ]
+# then
+# cd ${KS}/extras/lm_sensors-${SENV}
+# try make
+# fi
+
+# Works, just commented out because JFS isn't ready to be used by non-developers
+# if [ "`use jfs`" ]
+# then
+# cd ${S}/fs/jfs/utils
+# try make
+# cd output
+# into /
+# dosbin *
+# doman `find -iname *.8`
+# fi
+
+ if [ "$PN" == "linux" ]
+ then
+ cd ${KS}
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" dep || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" bzImage || die
+ make HOSTCFLAGS="${LINUX_HOSTCFLAGS}" LEX="flex -l" modules || die
+ fi
+
+# if [ "`use pcmcia-cs`" ]
+# then
+# cd ${KS2}/pcmcia-cs-${PCV}
+# # This is needed for linux-extras
+# if [ -f "Makefile" ]
+# then
+# try make clean
+# fi
+# try ./Configure -n --kernel=${KS} --moddir=/lib/modules/${KV} \
+# --notrust --cardbus --nopnp --noapm --srctree --sysv --rcdir=/etc/rc.d/
+# try make all
+# fi
+
+ cd ${KS2}/cloop-${CLOOPV}
+ make KERNEL_DIR=${KS}
+ fi
+}
+
+src_install() {
+ if [ "${PN}" = "linux" ] || [ "${PN}" = "linux-extras" ]
+ then
+ dodir /usr/lib
+
+ if [ "`use lvm`" ]
+ then
+ cd ${KS2}/LVM/${LVMV}/tools
+
+ CFLAGS="${CFLAGS} -I${KS}/include" try make install -e prefix=${D} mandir=${D}/usr/share/man \
+ sbindir=${D}/sbin libdir=${D}/lib
+ #no need for a static library in /lib
+ mv ${D}/lib/*.a ${D}/usr/lib
+ fi
+
+# if [ "`use lm_sensors`" ]
+# then
+# echo "Install sensor tools..."
+# #install sensors tools
+# cd ${KS}/extras/lm_sensors-${SENV}
+# make install
+# fi
+
+ if [ "${PN}" = "linux" ]
+ then
+ dodir /usr/src/linux-${KV}
+ cd ${D}/usr/src
+ #grab includes and documentation only
+ echo ">>> Copying includes and documentation..."
+ cp -ax ${S}/include ${D}/usr/src/linux-${KV}
+ cp -ax ${S}/Documentation ${D}/usr/src/linux-${KV}
+
+ #grab compiled kernel
+ dodir /boot/boot
+ insinto /boot/boot
+ cd ${S}
+ doins arch/i386/boot/bzImage
+
+ #grab modules
+ # Do we have a bug in modutils ?
+ # Meanwhile we use this quick fix (achim)
+
+ install -d ${D}/lib/modules/`uname -r`
+ try make INSTALL_MOD_PATH=${D} modules_install
+
+ cd ${S}
+ depmod -b ${D} -F ${S}/System.map ${KV}
+ #rm -rf ${D}/lib/modules/`uname -r`
+ #fix symlink
+ cd ${D}/lib/modules/${KV}
+ rm build
+ ln -sf /usr/src/linux-${KV} build
+ fi
+
+# if [ "`use pcmcia-cs`" ]
+# then
+# #install PCMCIA modules and utilities
+# cd ${KS2}/pcmcia-cs-${PCV}
+# try make PREFIX=${D} MANDIR=${D}/usr/share/man install
+# rm -rf ${D}/etc/rc.d
+# exeinto /etc/rc.d/init.d
+# doexe ${FILESDIR}/${KV}/pcmcia
+# fi
+
+ cd ${KS2}/cloop-${CLOOPV}
+ insinto /lib/modules/${KV}/kernel/drivers/block
+ doins cloop.o
+ into /usr
+ dobin create_compressed_fs extract_compressed_fs
+
+ if [ "`use bootcd`" ]
+ then
+ rm -rf ${D}/usr/include ${D}/usr/lib/lib*.a ${D}/usr/src
+ fi
+
+ elif [ "$PN" = "linux-sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ cp -ax ${WORKDIR}/* ${D}/usr/src
+ elif [ "$PN" = "linux-headers" ]
+ then
+ dodir /usr/include/linux
+ cp -ax ${KS}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${KS}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+ if [ -d ${D}/usr/src/linux-${KV} ]
+ then
+ #don't overwrite existing .config if present
+ cd ${D}/usr/src/linux-${KV}
+ if [ -e .config ]
+ then
+ cp -a .config .config.eg
+ fi
+ fi
+}
+
+pkg_preinst() {
+ if [ "$PN" = "linux-headers" ]
+ then
+ if [ -L ${ROOT}usr/include/linux ]
+ then
+ rm ${ROOT}usr/include/linux
+ fi
+ if [ -L ${ROOT}usr/include/asm ]
+ then
+ rm ${ROOT}usr/include/asm
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if [ "$PN" = "linux-extras" ] || [ "$PN" = "linux-headers" ]
+ then
+ return
+ fi
+ rm -f ${ROOT}/usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+
+ #copy over our .config if one isn't already present
+ cd ${ROOT}/usr/src/linux-${KV}
+ if [ "${PN}" = "linux-sources" ] && [ -e .config.eg ] && [ ! -e .config ]
+ then
+ cp -a .config.eg .config
+ fi
+}